Upstream information

CVE-2018-16883 at MITRE

Description

sssd versions from 1.13.0 to before 2.0.0 did not properly restrict access to the infopipe according to the "allowed_uids" configuration parameter. If sensitive information were stored in the user directory, this could be inadvertently disclosed to local attackers.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 2.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Local Local
Access Complexity Low High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1120089 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications sssd Not affected
SUSE Linux Enterprise 15 Module for Basesystem sssd Ignore
SUSE Linux Enterprise Desktop 12 SP3 sssd Not affected
SUSE Linux Enterprise Desktop 12 SP4 sssd Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 sssd Not affected
SUSE Linux Enterprise Server 11 SP3 sssd Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS sssd Not affected
SUSE Linux Enterprise Server 11 SP4 sssd Not affected
SUSE Linux Enterprise Server 12 LTSS sssd Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS sssd Not affected
SUSE Linux Enterprise Server 12 SP3 sssd Not affected
SUSE Linux Enterprise Server 12 SP4 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sssd Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 sssd Ignore