Upstream information

CVE-2018-1000654 at MITRE

Description

GNU Libtasn1-4.13 libtasn1-4.13 version libtasn1-4.13, libtasn1-4.12 contains a DoS, specifically CPU usage will reach 100% when running asn1Paser against the POC due to an issue in _asn1_expand_object_id(p_tree), after a long time, the program will be killed. This attack appears to be exploitable via parsing a crafted file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 6.2
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1105435 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
Patchnames:
SUSE-CAASP-3.0-2019-1379
SUSE CaaS Platform ALL
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
Patchnames:
SUSE-CAASP-ALL-2019-1379
SUSE Linux Enterprise Desktop 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1379
SUSE Linux Enterprise Desktop 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1379
SUSE Linux Enterprise Module for Basesystem 15
  • libtasn1 >= 4.13-4.5.1
  • libtasn1-6 >= 4.13-4.5.1
  • libtasn1-6-32bit >= 4.13-4.5.1
  • libtasn1-devel >= 4.13-4.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1372
SUSE Linux Enterprise Module for Desktop Applications 15
  • libtasn1 >= 4.13-4.5.1
  • libtasn1-6-32bit >= 4.13-4.5.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-1372
SUSE Linux Enterprise Server 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1379
SUSE Linux Enterprise Server 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1379
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1379
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-6 >= 4.9-3.10.1
  • libtasn1-6-32bit >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1379
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1379
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libtasn1 >= 4.9-3.10.1
  • libtasn1-devel >= 4.9-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1379
openSUSE Leap 15.0
  • libtasn1 >= 4.13-lp150.3.3.1
  • libtasn1-6 >= 4.13-lp150.3.3.1
  • libtasn1-6-32bit >= 4.13-lp150.3.3.1
  • libtasn1-6-32bit-debuginfo >= 4.13-lp150.3.3.1
  • libtasn1-6-debuginfo >= 4.13-lp150.3.3.1
  • libtasn1-debuginfo >= 4.13-lp150.3.3.1
  • libtasn1-debugsource >= 4.13-lp150.3.3.1
  • libtasn1-devel >= 4.13-lp150.3.3.1
  • libtasn1-devel-32bit >= 4.13-lp150.3.3.1
Patchnames:
openSUSE-2019-1498
openSUSE Leap 15.1
  • libtasn1 >= 4.13-lp151.4.3.1
  • libtasn1-6 >= 4.13-lp151.4.3.1
  • libtasn1-6-32bit >= 4.13-lp151.4.3.1
  • libtasn1-6-32bit-debuginfo >= 4.13-lp151.4.3.1
  • libtasn1-6-debuginfo >= 4.13-lp151.4.3.1
  • libtasn1-debuginfo >= 4.13-lp151.4.3.1
  • libtasn1-debugsource >= 4.13-lp151.4.3.1
  • libtasn1-devel >= 4.13-lp151.4.3.1
  • libtasn1-devel-32bit >= 4.13-lp151.4.3.1
Patchnames:
openSUSE-2019-1498
openSUSE Leap 42.3
  • libtasn1 >= 4.9-6.1
  • libtasn1-6 >= 4.9-6.1
  • libtasn1-6-32bit >= 4.9-6.1
  • libtasn1-6-debuginfo >= 4.9-6.1
  • libtasn1-6-debuginfo-32bit >= 4.9-6.1
  • libtasn1-debuginfo >= 4.9-6.1
  • libtasn1-debugsource >= 4.9-6.1
  • libtasn1-devel >= 4.9-6.1
  • libtasn1-devel-32bit >= 4.9-6.1
Patchnames:
openSUSE-2019-1510

List of packages in QA

Product(s) Package(s)
Openstack Cloud Magnum Orchestration 7
  • libtasn1 >= 3.7-13.3.1
  • libtasn1-6 >= 3.7-13.3.1
  • libtasn1-6-debuginfo >= 3.7-13.3.1
  • libtasn1-debuginfo >= 3.7-13.3.1
  • libtasn1-debugsource >= 3.7-13.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 libtasn1 Released
CaaS Platform 3.0 libtasn1 Released
OpenStack Cloud Magnum Orchestration 7.0 libtasn1 In progress
SUSE Linux Enterprise Desktop 12 SP3 libtasn1 Released
SUSE Linux Enterprise Desktop 12 SP4 libtasn1 Released
SUSE Linux Enterprise High Performance Computing 12 libtasn1 Released
SUSE Linux Enterprise Module for Basesystem 15 GA libtasn1 Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA libtasn1 Released
SUSE Linux Enterprise SDK 11 SP4 libtasn1 Affected
SUSE Linux Enterprise SDK 12 SP3 libtasn1 Released
SUSE Linux Enterprise SDK 12 SP4 libtasn1 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libtasn1 Affected
SUSE Linux Enterprise Server 11 SP4 libtasn1 Affected
SUSE Linux Enterprise Server 12 GA LTSS libtasn1 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libtasn1 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libtasn1 Affected
SUSE Linux Enterprise Server 12 SP3 libtasn1 Released
SUSE Linux Enterprise Server 12 SP4 libtasn1 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libtasn1 Released