Upstream information

CVE-2017-9023 at MITRE

Description

The ASN.1 parser in strongSwan before 5.5.3 improperly handles CHOICE types when the x509 plugin is enabled, which allows remote attackers to cause a denial of service (infinite loop) via a crafted certificate.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1039515 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-906
SUSE Linux Enterprise Desktop 12 SP3
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA strongswan
SUSE Linux Enterprise Server 11 SP4
  • strongswan >= 4.4.0-6.35.1
  • strongswan-doc >= 4.4.0-6.35.1
Patchnames:
slessp4-strongswan-13136
SUSE Linux Enterprise Server 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-906
SUSE Linux Enterprise Server 12 SP3
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA strongswan
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-906


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 12 GA LTSS
strongswan


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 strongswan Unsupported
SUSE Linux Enterprise Desktop 12 SP2 strongswan Released
SUSE Linux Enterprise Server 11 SP3 LTSS strongswan Affected
SUSE Linux Enterprise Server 11 SP4 strongswan Released
SUSE Linux Enterprise Server 12 GA LTSS strongswan Affected
SUSE Linux Enterprise Server 12 SP1 strongswan Unsupported
SUSE Linux Enterprise Server 12 SP2 strongswan Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI strongswan Released