Upstream information

CVE-2017-7484 at MITRE

Description

It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3 did not check user privileges before providing information from pg_statistic, possibly leaking information. An unprivileged attacker could use this flaw to steal some information from tables they are otherwise not allowed to access.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 3.5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N AV:N/AC:M/Au:S/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entries: 1037603 [RESOLVED], 1051015 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • postgresql94 >= 9.4.12-20.1
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
SUSE Linux Enterprise Desktop 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libecpg6 >= 9.4.12-0.22.3
  • libpq5 >= 9.4.12-0.22.3
  • libpq5-32bit >= 9.4.12-0.22.3
  • postgresql94 >= 9.4.12-0.22.3
  • postgresql94-contrib >= 9.4.12-0.22.3
  • postgresql94-docs >= 9.4.12-0.22.3
  • postgresql94-libs >= 9.4.12-0.22.3
  • postgresql94-server >= 9.4.12-0.22.3
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • postgresql94 >= 9.4.12-20.1
  • postgresql94-contrib >= 9.4.12-20.1
  • postgresql94-docs >= 9.4.12-20.1
  • postgresql94-server >= 9.4.12-20.1
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
  • postgresql96-contrib >= 9.6.3-2.4
  • postgresql96-docs >= 9.6.3-2.4
  • postgresql96-server >= 9.6.3-2.4
SUSE Linux Enterprise Server 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
  • postgresql10-contrib >= 10.5-1.3.2
  • postgresql10-docs >= 10.5-1.3.2
  • postgresql10-server >= 10.5-1.3.2
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • postgresql93 >= 9.3.17-24.2
  • postgresql93-contrib >= 9.3.17-24.2
  • postgresql93-docs >= 9.3.17-24.2
  • postgresql93-server >= 9.3.17-24.2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql94-devel >= 9.4.12-0.22.3
  • postgresql94-libs >= 9.4.12-0.22.3
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.12-20.1
  • postgresql94-libs >= 9.4.12-20.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.3-2.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • postgresql10-devel >= 10.5-1.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postgresql10-devel >= 10.10-1.15.1
openSUSE Leap 15.0
  • postgresql96 >= 9.6.8-lp150.1.2
  • postgresql96-server >= 9.6.8-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA postgresql96
openSUSE Leap 42.2
  • postgresql93 >= 9.3.17-5.9.1
  • postgresql93-contrib >= 9.3.17-5.9.1
  • postgresql93-contrib-debuginfo >= 9.3.17-5.9.1
  • postgresql93-debuginfo >= 9.3.17-5.9.1
  • postgresql93-debugsource >= 9.3.17-5.9.1
  • postgresql93-devel >= 9.3.17-5.9.1
  • postgresql93-devel-debuginfo >= 9.3.17-5.9.1
  • postgresql93-docs >= 9.3.17-5.9.1
  • postgresql93-libs >= 9.3.17-5.9.1
  • postgresql93-libs-debugsource >= 9.3.17-5.9.1
  • postgresql93-plperl >= 9.3.17-5.9.1
  • postgresql93-plperl-debuginfo >= 9.3.17-5.9.1
  • postgresql93-plpython >= 9.3.17-5.9.1
  • postgresql93-plpython-debuginfo >= 9.3.17-5.9.1
  • postgresql93-pltcl >= 9.3.17-5.9.1
  • postgresql93-pltcl-debuginfo >= 9.3.17-5.9.1
  • postgresql93-server >= 9.3.17-5.9.1
  • postgresql93-server-debuginfo >= 9.3.17-5.9.1
  • postgresql93-test >= 9.3.17-5.9.1
  • postgresql94 >= 9.4.12-9.6.1
  • postgresql94-contrib >= 9.4.12-9.6.1
  • postgresql94-contrib-debuginfo >= 9.4.12-9.6.1
  • postgresql94-debuginfo >= 9.4.12-9.6.1
  • postgresql94-debugsource >= 9.4.12-9.6.1
  • postgresql94-devel >= 9.4.12-9.6.1
  • postgresql94-devel-debuginfo >= 9.4.12-9.6.1
  • postgresql94-docs >= 9.4.12-9.6.1
  • postgresql94-libs >= 9.4.12-9.6.1
  • postgresql94-libs-debugsource >= 9.4.12-9.6.1
  • postgresql94-plperl >= 9.4.12-9.6.1
  • postgresql94-plperl-debuginfo >= 9.4.12-9.6.1
  • postgresql94-plpython >= 9.4.12-9.6.1
  • postgresql94-plpython-debuginfo >= 9.4.12-9.6.1
  • postgresql94-pltcl >= 9.4.12-9.6.1
  • postgresql94-pltcl-debuginfo >= 9.4.12-9.6.1
  • postgresql94-server >= 9.4.12-9.6.1
  • postgresql94-server-debuginfo >= 9.4.12-9.6.1
  • postgresql94-test >= 9.4.12-9.6.1
Patchnames:
openSUSE-2017-657
openSUSE-2017-770
openSUSE Leap 42.3
  • libecpg6 >= 9.6.3-3.1
  • libpq5 >= 9.6.3-3.1
  • postgresql93-docs >= 9.3.17-6.1
  • postgresql94-docs >= 9.4.12-10.1
  • postgresql95-docs >= 9.5.7-1.8
  • postgresql96 >= 9.6.3-3.1
  • postgresql96-contrib >= 9.6.3-3.1
  • postgresql96-devel >= 9.6.3-3.1
  • postgresql96-docs >= 9.6.3-3.1
  • postgresql96-server >= 9.6.3-3.1
Patchnames:
openSUSE Leap 42.3 GA libecpg6
openSUSE Leap 42.3 GA postgresql93-docs
openSUSE Leap 42.3 GA postgresql94-docs
openSUSE Leap 42.3 GA postgresql95-docs


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 postgresql94 In progress
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Released
SUSE Linux Enterprise Server 12 GA LTSS postgresql93 Released
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Affected
SUSE Linux Enterprise Server 12 SP1 postgresql94 In progress
SUSE Linux Enterprise Server 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI postgresql94 Released