Upstream information

CVE-2017-12166 at MITRE

Description

OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 10
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 10
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Access Vector Network Network
Access Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1060877 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • openvpn >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1762
SUSE Linux Enterprise Desktop 12 SP3
  • openvpn >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1762
SUSE Linux Enterprise Desktop 12 SP4
  • openvpn >= 2.3.8-16.20.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • openvpn >= 2.4.3-5.3.19
  • openvpn-auth-pam-plugin >= 2.4.3-5.3.19
  • openvpn-devel >= 2.4.3-5.3.19
SUSE Linux Enterprise Module for Basesystem 15
  • openvpn >= 2.4.3-3.39
  • openvpn-auth-pam-plugin >= 2.4.3-3.39
  • openvpn-devel >= 2.4.3-3.39
SUSE Linux Enterprise Point of Sale 11 SP3
  • openvpn >= 2.0.9-143.47.3.1
  • openvpn-auth-pam-plugin >= 2.0.9-143.47.3.1
Patchnames:
sleposp3-openvpn-13322
SUSE Linux Enterprise Server 11 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • openvpn >= 2.0.9-143.47.3.1
  • openvpn-auth-pam-plugin >= 2.0.9-143.47.3.1
Patchnames:
slessp3-openvpn-13322
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openvpn >= 2.0.9-143.47.3.1
  • openvpn-auth-pam-plugin >= 2.0.9-143.47.3.1
Patchnames:
slessp4-openvpn-13322
SUSE Linux Enterprise Server 11-SECURITY
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • openvpn-openssl1 >= 2.3.2-0.10.3.1
  • openvpn-openssl1-down-root-plugin >= 2.3.2-0.10.3.1
Patchnames:
secsp3-openvpn-openssl1-13362
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1762
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1762
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1762
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1762
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1762
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1762
SUSE OpenStack Cloud 6
  • openvpn >= 2.3.8-16.20.1
  • openvpn-auth-pam-plugin >= 2.3.8-16.20.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1762
openSUSE Leap 15.0
  • openvpn >= 2.4.3-lp150.2.10
Patchnames:
openSUSE Leap 15.0 GA openvpn
openSUSE Leap 42.2
  • openvpn >= 2.3.8-8.13.1
  • openvpn-auth-pam-plugin >= 2.3.8-8.13.1
  • openvpn-auth-pam-plugin-debuginfo >= 2.3.8-8.13.1
  • openvpn-debuginfo >= 2.3.8-8.13.1
  • openvpn-debugsource >= 2.3.8-8.13.1
  • openvpn-devel >= 2.3.8-8.13.1
  • openvpn-down-root-plugin >= 2.3.8-8.13.1
  • openvpn-down-root-plugin-debuginfo >= 2.3.8-8.13.1
Patchnames:
openSUSE-2017-1202
openSUSE Leap 42.3
  • openvpn >= 2.3.8-14.1
  • openvpn-auth-pam-plugin >= 2.3.8-14.1
  • openvpn-auth-pam-plugin-debuginfo >= 2.3.8-14.1
  • openvpn-debuginfo >= 2.3.8-14.1
  • openvpn-debugsource >= 2.3.8-14.1
  • openvpn-devel >= 2.3.8-14.1
  • openvpn-down-root-plugin >= 2.3.8-14.1
  • openvpn-down-root-plugin-debuginfo >= 2.3.8-14.1
Patchnames:
openSUSE-2017-1202


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 openvpn Released
SUSE Linux Enterprise Desktop 12 SP3 openvpn Released
SUSE Linux Enterprise Server 11 SP1 openvpn Released
SUSE Linux Enterprise Server 11 SP3 openvpn Released
SUSE Linux Enterprise Server 11 SP3 openvpn-openssl1 Released
SUSE Linux Enterprise Server 11 SP3 LTSS openvpn Released
SUSE Linux Enterprise Server 11 SP4 openvpn Released
SUSE Linux Enterprise Server 12 LTSS openvpn Released
SUSE Linux Enterprise Server 12 SP1 LTSS openvpn Released
SUSE Linux Enterprise Server 12 SP2 openvpn Released
SUSE Linux Enterprise Server 12 SP3 openvpn Released
SUSE Linux Enterprise Server for the Raspberry Pi openvpn Released
Security Module for SUSE Linux Enterprise 11 openvpn-openssl1 Released