Upstream information

CVE-2016-9587 at MITRE


Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 7.5
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:S/C:P/I:C/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None Single
Confidentiality Impact Complete Partial
Integrity Impact Complete Complete
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1019021 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 7
  • ansible >=
  • monasca-installer >= 20170912_10.45-5.1
SUSE Package Hub for SUSE Linux Enterprise 12
  • ansible >=
openSUSE Leap 42.2
  • ansible >=
openSUSE Leap 42.3
  • ansible >=

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 11 SP3 ansible Released
SUSE OpenStack Cloud 7 ansible Released
SUSE OpenStack Cloud 7 monasca-installer Released