Upstream information

CVE-2016-10729 at MITRE

Description

An issue was discovered in Amanda 3.3.1. A user with backup privileges can trivially compromise a client installation. The "runtar" setuid root binary does not check for additional arguments supplied after --create, allowing users to manipulate commands and perform command injection as root.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 6.7
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1110797 [RESOLVED / FIXED], 1112916 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • amanda >= 2.5.2.1-188.5.1
Patchnames:
slessp4-amanda-13911
openSUSE Leap 42.3
  • amanda >= 3.3.6-10.3.1
  • amanda-debuginfo >= 3.3.6-10.3.1
  • amanda-debugsource >= 3.3.6-10.3.1
Patchnames:
openSUSE-2018-1421


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications amanda Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem permissions Released
SUSE Linux Enterprise Server 11 SP1 amanda Released
SUSE Linux Enterprise Server 11 SP3 amanda Released
SUSE Linux Enterprise Server 11 SP3 LTSS amanda Released
SUSE Linux Enterprise Server 11 SP4 amanda Released