Upstream information

CVE-2015-6673 at MITRE

Description

Use-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 943304 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libpgf6 >= 6.14.12-3.5
Patchnames:
openSUSE Leap 42.1 GA libpgf6
openSUSE Tumbleweed
  • libpgf-devel >= 6.14.12-4.6
  • libpgf6 >= 6.14.12-4.6
Patchnames:
openSUSE Tumbleweed GA libpgf-devel