Upstream information

CVE-2014-9625 at MITRE

Description

The GetUpdateFile function in misc/update.c in the Updater in VideoLAN VLC media player before 2.1.6 performs an incorrect cast operation from a 64-bit integer to a 32-bit integer, which allows remote attackers to conduct buffer overflow attacks and execute arbitrary code via a crafted update status file, aka an "integer truncation" vulnerability.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 914268 [RESOLVED], 920781 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • libvlc5 >= 2.1.5-14.1
  • libvlc5-debuginfo >= 2.1.5-14.1
  • libvlccore7 >= 2.1.5-14.1
  • libvlccore7-debuginfo >= 2.1.5-14.1
  • live555 >= 2014.09.22-2.4.1
  • live555-devel >= 2014.09.22-2.4.1
  • vlc >= 2.1.5-14.1
  • vlc-debuginfo >= 2.1.5-14.1
  • vlc-debugsource >= 2.1.5-14.1
  • vlc-devel >= 2.1.5-14.1
  • vlc-gnome >= 2.1.5-14.1
  • vlc-gnome-debuginfo >= 2.1.5-14.1
  • vlc-noX >= 2.1.5-14.1
  • vlc-noX-debuginfo >= 2.1.5-14.1
  • vlc-noX-lang >= 2.1.5-14.1
  • vlc-qt >= 2.1.5-14.1
  • vlc-qt-debuginfo >= 2.1.5-14.1
Patchnames:
openSUSE-2015-99
openSUSE Tumbleweed
  • libvlc5 >= 2.2.4-11.1
  • libvlccore8 >= 2.2.4-11.1
  • vlc >= 2.2.4-11.1
  • vlc-codec-gstreamer >= 2.2.4-11.1
  • vlc-devel >= 2.2.4-11.1
  • vlc-lang >= 2.2.4-11.1
  • vlc-noX >= 2.2.4-11.1
  • vlc-qt >= 2.2.4-11.1
Patchnames:
openSUSE Tumbleweed GA libvlc5