Upstream information

CVE-2014-3591 at MITRE

Description

Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 1.9 4.3
Vector AV:L/AC:M/Au:N/C:P/I:N/A:N AV:A/AC:H/Au:S/C:C/I:N/A:N
Access Vector Local Adjacent Network
Access Complexity Medium High
Authentication None Single
Confidentiality Impact Partial Complete
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.2
Vector CVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Physical
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entries: 920057 [RESOLVED / FIXED], 949135 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/default-http-backend:beta1
Container caasp/v4/dnsmasq-nanny:2.78
Container caasp/v4/flannel:0.9.1
Container caasp/v4/haproxy:beta1
Container caasp/v4/kubedns:beta1
Container caasp/v4/nginx-ingress-controller:beta1
Container caasp/v4/openldap:beta1
Container caasp/v4/pause:1.0.0
Container caasp/v4/pv-recycler-node:8.25
Container caasp/v4/salt-api:beta1
Container caasp/v4/salt-master:beta1
Container caasp/v4/salt-minion:beta1
Container caasp/v4/sidecar:beta1
Container caasp/v4/velum:4.0.0
Container sles12/caasp-dex:2.7.1
Container suse/sles12sp4:latest
Container suse/sles12sp5:latest
Image sles12sp3-caasp-dex-image
  • libgcrypt20 >= 1.6.1-13.1
SUSE Linux Enterprise Desktop 11 SP3
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt11 >= 1.5.0-0.19.1
  • libgcrypt11-32bit >= 1.5.0-0.19.1
Patchnames:
sledsp3-libgcrypt-12102
SUSE Linux Enterprise Desktop 11 SP4
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt11 >= 1.5.0-0.19.1
  • libgcrypt11-32bit >= 1.5.0-0.19.1
Patchnames:
sledsp4-libgcrypt-12102
SUSE Linux Enterprise Desktop 12 SP1
  • libgcrypt20 >= 1.6.1-16.1
  • libgcrypt20-32bit >= 1.6.1-16.1
SUSE Linux Enterprise Desktop 12 SP2
  • libgcrypt20 >= 1.6.1-16.33.1
  • libgcrypt20-32bit >= 1.6.1-16.33.1
SUSE Linux Enterprise Desktop 12 SP3
  • libgcrypt20 >= 1.6.1-16.39.1
  • libgcrypt20-32bit >= 1.6.1-16.39.1
SUSE Linux Enterprise Desktop 12 SP4
  • libgcrypt20 >= 1.6.1-16.61.1
  • libgcrypt20-32bit >= 1.6.1-16.61.1
SUSE Linux Enterprise Desktop 12
  • libgcrypt >= 1.6.1-13.1
  • libgcrypt20 >= 1.6.1-13.1
  • libgcrypt20-32bit >= 1.6.1-13.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-296
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libgcrypt20 >= 1.6.1-16.68.1
  • libgcrypt20-32bit >= 1.6.1-16.68.1
  • libgcrypt20-hmac >= 1.6.1-16.68.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.68.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libgcrypt-devel >= 1.8.2-6.7
  • libgcrypt20 >= 1.8.2-6.7
  • libgcrypt20-32bit >= 1.8.2-6.7
  • libgcrypt20-hmac >= 1.8.2-6.7
  • libgcrypt20-hmac-32bit >= 1.8.2-6.7
SUSE Linux Enterprise Module for Basesystem 15
  • libgcrypt-devel >= 1.8.2-4.5
  • libgcrypt20 >= 1.8.2-4.5
  • libgcrypt20-32bit >= 1.8.2-4.5
  • libgcrypt20-hmac >= 1.8.2-4.5
  • libgcrypt20-hmac-32bit >= 1.8.2-4.5
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt11 >= 1.5.0-0.19.1
  • libgcrypt11-32bit >= 1.5.0-0.19.1
  • libgcrypt11-x86 >= 1.5.0-0.19.1
Patchnames:
slessp3-libgcrypt-12102
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt11 >= 1.5.0-0.19.1
  • libgcrypt11-32bit >= 1.5.0-0.19.1
  • libgcrypt11-x86 >= 1.5.0-0.19.1
Patchnames:
slessp4-libgcrypt-12102
SUSE Linux Enterprise Server 12 SP1
  • libgcrypt20 >= 1.6.1-16.1
  • libgcrypt20-32bit >= 1.6.1-16.1
  • libgcrypt20-hmac >= 1.6.1-16.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.1
SUSE Linux Enterprise Server 12 SP2
  • libgcrypt20 >= 1.6.1-16.33.1
  • libgcrypt20-32bit >= 1.6.1-16.33.1
  • libgcrypt20-hmac >= 1.6.1-16.33.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.33.1
SUSE Linux Enterprise Server 12 SP3
  • libgcrypt20 >= 1.6.1-16.39.1
  • libgcrypt20-32bit >= 1.6.1-16.39.1
  • libgcrypt20-hmac >= 1.6.1-16.39.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.39.1
SUSE Linux Enterprise Server 12 SP4
  • libgcrypt20 >= 1.6.1-16.61.1
  • libgcrypt20-32bit >= 1.6.1-16.61.1
  • libgcrypt20-hmac >= 1.6.1-16.61.1
  • libgcrypt20-hmac-32bit >= 1.6.1-16.61.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libgcrypt >= 1.6.1-13.1
  • libgcrypt20 >= 1.6.1-13.1
  • libgcrypt20-32bit >= 1.6.1-13.1
  • libgcrypt20-hmac >= 1.6.1-13.1
  • libgcrypt20-hmac-32bit >= 1.6.1-13.1
Patchnames:
SUSE-SLE-SERVER-12-2015-296
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libgcrypt20 >= 1.6.1-16.33.1
  • libgcrypt20-hmac >= 1.6.1-16.33.1
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt-devel >= 1.5.0-0.19.1
  • libgcrypt-devel-32bit >= 1.5.0-0.19.1
Patchnames:
sdksp3-libgcrypt-12102
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgcrypt >= 1.5.0-0.19.1
  • libgcrypt-devel >= 1.5.0-0.19.1
  • libgcrypt-devel-32bit >= 1.5.0-0.19.1
Patchnames:
sdksp4-libgcrypt-12102
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgcrypt-devel >= 1.6.1-16.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgcrypt-devel >= 1.6.1-16.33.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgcrypt-devel >= 1.6.1-16.39.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libgcrypt-devel >= 1.6.1-16.61.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgcrypt-devel >= 1.6.1-16.68.1
SUSE Linux Enterprise Software Development Kit 12
  • libgcrypt >= 1.6.1-13.1
  • libgcrypt-devel >= 1.6.1-13.1
Patchnames:
SUSE-SLE-SDK-12-2015-296
openSUSE 13.1
  • libgcrypt >= 1.5.4-2.8.1
  • libgcrypt-debugsource >= 1.5.4-2.8.1
  • libgcrypt-devel >= 1.5.4-2.8.1
  • libgcrypt-devel-32bit >= 1.5.4-2.8.1
  • libgcrypt-devel-debuginfo >= 1.5.4-2.8.1
  • libgcrypt-devel-debuginfo-32bit >= 1.5.4-2.8.1
  • libgcrypt11 >= 1.5.4-2.8.1
  • libgcrypt11-32bit >= 1.5.4-2.8.1
  • libgcrypt11-debuginfo >= 1.5.4-2.8.1
  • libgcrypt11-debuginfo-32bit >= 1.5.4-2.8.1
Patchnames:
openSUSE-2015-566
openSUSE Leap 15.0
  • libgcrypt20 >= 1.8.2-lp150.4.2
  • libgcrypt20-32bit >= 1.8.2-lp150.4.2
Patchnames:
openSUSE Leap 15.0 GA libgcrypt20
openSUSE Leap 42.1
  • libgcrypt-devel >= 1.6.1-18.7
  • libgcrypt20 >= 1.6.1-18.7
  • libgcrypt20-32bit >= 1.6.1-18.7
Patchnames:
openSUSE Leap 42.1 GA libgcrypt-devel
openSUSE Leap 42.2
  • libgcrypt-devel >= 1.6.1-33.1
  • libgcrypt20 >= 1.6.1-33.1
  • libgcrypt20-32bit >= 1.6.1-33.1
Patchnames:
openSUSE Leap 42.2 GA libgcrypt-devel
openSUSE Leap 42.3
  • libgcrypt-devel >= 1.6.1-37.2
  • libgcrypt20 >= 1.6.1-37.2
  • libgcrypt20-32bit >= 1.6.1-37.2
Patchnames:
openSUSE Leap 42.3 GA libgcrypt-devel
openSUSE Tumbleweed
  • libgcrypt-cavs >= 1.7.3-1.3
  • libgcrypt-devel >= 1.7.3-1.3
  • libgcrypt-devel-32bit >= 1.7.3-1.3
  • libgcrypt20 >= 1.7.3-1.3
  • libgcrypt20-32bit >= 1.7.3-1.3
  • libgcrypt20-hmac >= 1.7.3-1.3
  • libgcrypt20-hmac-32bit >= 1.7.3-1.3
Patchnames:
openSUSE Tumbleweed GA libgcrypt-cavs


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 gpg Released
SLED-10-SP3 libgcrypt Released
SLED-10-SP4 gpg Released
SLED-10-SP4 libgcrypt Released
SLES for SAP Applications libgcrypt Released
SLES-10-SP3 gpg Released
SLES-10-SP3 libgcrypt Released
SLES-10-SP4 gpg Released
SLES-10-SP4 libgcrypt Released
SLES_LTSS-10-SP4 gpg Released
SLES_LTSS-10-SP4 libgcrypt Released
SUSE Linux Enterprise Desktop 11 SP1 libgcrypt Released
SUSE Linux Enterprise Desktop 11 SP2 libgcrypt Released
SUSE Linux Enterprise Desktop 11 SP3 gpg2 Not affected
SUSE Linux Enterprise Desktop 11 SP3 libgcrypt Released
SUSE Linux Enterprise Desktop 11 SP4 libgcrypt Released
SUSE Linux Enterprise Desktop 12 gpg2 Not affected
SUSE Linux Enterprise Desktop 12 libgcrypt Released
SUSE Linux Enterprise Desktop 12 SP1 libgcrypt Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libgcrypt Released
SUSE Linux Enterprise Server 11 SP1 gpg2 Not affected
SUSE Linux Enterprise Server 11 SP1 libgcrypt Released
SUSE Linux Enterprise Server 11 SP1 LTSS libgcrypt Released
SUSE Linux Enterprise Server 11 SP2 libgcrypt Released
SUSE Linux Enterprise Server 11 SP2 LTSS libgcrypt Released
SUSE Linux Enterprise Server 11 SP2 for VMware libgcrypt Released
SUSE Linux Enterprise Server 11 SP3 gpg2 Not affected
SUSE Linux Enterprise Server 11 SP3 libgcrypt Released
SUSE Linux Enterprise Server 11 SP3 for VMware gpg2 Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware libgcrypt Released
SUSE Linux Enterprise Server 11 SP4 libgcrypt Released
SUSE Linux Enterprise Server 12 gpg2 Not affected
SUSE Linux Enterprise Server 12 libgcrypt Released
SUSE Linux Enterprise Server 12 SP5 libgcrypt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libgcrypt Released
SUSE Linux Enterprise Software Development Kit 11 SP2 libgcrypt Released
SUSE Linux Enterprise Software Development Kit 11 SP3 libgcrypt Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libgcrypt Released
SUSE Linux Enterprise Software Development Kit 12 libgcrypt Released