Upstream information

CVE-2014-2907 at MITRE

Description

The srtp_add_address function in epan/dissectors/packet-rtp.c in the RTP dissector in Wireshark 1.10.x before 1.10.7 does not properly update SRTP conversation data, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 874693 [ASSIGNED], 874760 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • wireshark >= 1.12.7-15.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • wireshark >= 1.12.13-31.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libwireshark8 >= 2.2.7-47.1
  • libwiretap6 >= 2.2.7-47.1
  • libwscodecs1 >= 2.2.7-47.1
  • libwsutil7 >= 2.2.7-47.1
  • wireshark >= 2.2.7-47.1
  • wireshark-gtk >= 2.2.7-47.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • libwireshark9 >= 2.4.9-48.29.1
  • libwiretap7 >= 2.4.9-48.29.1
  • libwscodecs1 >= 2.4.9-48.29.1
  • libwsutil8 >= 2.4.9-48.29.1
  • wireshark >= 2.4.9-48.29.1
  • wireshark-gtk >= 2.4.9-48.29.1
SUSE Linux Enterprise Desktop 12
  • wireshark >= 1.10.9-1.11
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libwireshark9 >= 2.4.16-48.51.1
  • libwiretap7 >= 2.4.16-48.51.1
  • libwscodecs1 >= 2.4.16-48.51.1
  • libwsutil8 >= 2.4.16-48.51.1
  • wireshark >= 2.4.16-48.51.1
  • wireshark-gtk >= 2.4.16-48.51.1
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
SUSE Linux Enterprise Server 12
  • wireshark >= 1.10.9-1.5
SUSE Linux Enterprise Software Development Kit 12 SP1
  • wireshark-devel >= 1.12.7-15.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • wireshark-devel >= 1.12.13-31.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wireshark-devel >= 2.2.7-47.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • wireshark-devel >= 2.4.9-48.29.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • wireshark-devel >= 2.4.16-48.51.1
SUSE Linux Enterprise Software Development Kit 12
  • wireshark-devel >= 1.10.9-1.11
openSUSE 13.1
  • wireshark >= 1.10.7-12.1
  • wireshark-debuginfo >= 1.10.7-12.1
  • wireshark-debugsource >= 1.10.7-12.1
  • wireshark-devel >= 1.10.7-12.1
Patchnames:
openSUSE-2014-343
openSUSE Leap 42.1
  • wireshark >= 1.12.7-7.3
  • wireshark-ui-gtk >= 1.12.7-7.3
Patchnames:
openSUSE Leap 42.1 GA wireshark
openSUSE Leap 42.2
  • wireshark >= 2.2.1-1.1
  • wireshark-ui-gtk >= 2.2.1-1.1
Patchnames:
openSUSE Leap 42.2 GA wireshark
openSUSE Leap 42.3
  • wireshark >= 2.2.7-15.1
  • wireshark-ui-gtk >= 2.2.7-15.1
Patchnames:
openSUSE Leap 42.3 GA wireshark
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15-SP1 Module for Basesystem wireshark Not affected
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications wireshark Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 wireshark Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 wireshark Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS wireshark Not affected
SUSE Linux Enterprise Server 11 SP1 wireshark Not affected
SUSE Linux Enterprise Server 11 SP3 wireshark Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP2 BCL wireshark Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 BCL wireshark Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS wireshark Not affected
SUSE Linux Enterprise Server 12 SP4 wireshark Not affected
SUSE Linux Enterprise Server 12 SP5 wireshark Not affected
SUSE Linux Enterprise Server 15 LTSS wireshark Not affected
SUSE Linux Enterprise Server ESPOS 15 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wireshark Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wireshark Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 wireshark Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 wireshark Not affected