Upstream information

CVE-2013-1945 at MITRE

Description

ruby193 uses an insecure LD_LIBRARY_PATH setting.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.3
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1160788 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
ruby Not affected
Magnum Orchestration ruby2.1 Not affected
SLED-10-SP3 ruby Not affected
SLED-10-SP4 ruby Not affected
SLES for SAP Applications ruby Not affected
SUSE CaaS Platform 3.0 ruby2.1 Not affected
SUSE Cloud 5 ruby2.1 Not affected
SUSE Container as a Service Platform 1.0 ruby2.1 Affected
SUSE Container as a Service Platform 2.0 ruby2.1 Not affected
SUSE Lifecycle Management Server 1.3 ruby Not affected
SUSE Linux Enterprise 15 Module for Basesystem ruby Not affected
SUSE Linux Enterprise 15 Module for Basesystem ruby2.5 Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem ruby Not affected
SUSE Linux Enterprise Desktop 11 ruby Not affected
SUSE Linux Enterprise Desktop 11 SP1 ruby Not affected
SUSE Linux Enterprise Desktop 11 SP2 ruby Not affected
SUSE Linux Enterprise Desktop 11 SP3 ruby Not affected
SUSE Linux Enterprise Desktop 11 SP4 ruby Not affected
SUSE Linux Enterprise Desktop 12 ruby Not affected
SUSE Linux Enterprise Desktop 12 ruby2.1 Not affected
SUSE Linux Enterprise Desktop 12 SP1 ruby Not affected
SUSE Linux Enterprise Desktop 12 SP1 ruby2.1 Not affected
SUSE Linux Enterprise Desktop 12 SP2 ruby Not affected
SUSE Linux Enterprise Desktop 12 SP2 ruby2.1 Not affected
SUSE Linux Enterprise Desktop 12 SP3 ruby Not affected
SUSE Linux Enterprise Desktop 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise Desktop 12 SP4 ruby Not affected
SUSE Linux Enterprise Desktop 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise Desktop 12 SP5 ruby Not affected
SUSE Linux Enterprise Desktop 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ruby Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 ruby Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 ruby2.1 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 ruby Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ruby Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ruby Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS ruby Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS ruby2.5 Affected
SUSE Linux Enterprise Server 11 ruby Not affected
SUSE Linux Enterprise Server 11 SP1 ruby Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS ruby Not affected
SUSE Linux Enterprise Server 11 SP2 ruby Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS ruby Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware ruby Not affected
SUSE Linux Enterprise Server 11 SP3 ruby Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS ruby Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware ruby Not affected
SUSE Linux Enterprise Server 11 SP4 ruby Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 ruby Not affected
SUSE Linux Enterprise Server 12 ruby2.1 Not affected
SUSE Linux Enterprise Server 12 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP1 ruby Not affected
SUSE Linux Enterprise Server 12 SP1 ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP2 ruby Not affected
SUSE Linux Enterprise Server 12 SP2 ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP2 BCL ruby Affected
SUSE Linux Enterprise Server 12 SP2 BCL ruby2.1 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP3 ruby Not affected
SUSE Linux Enterprise Server 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP3 BCL ruby Affected
SUSE Linux Enterprise Server 12 SP3 BCL ruby2.1 Affected
SUSE Linux Enterprise Server 12 SP3 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP4 ruby Not affected
SUSE Linux Enterprise Server 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP5 ruby Not affected
SUSE Linux Enterprise Server 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise Server 15 LTSS ruby Affected
SUSE Linux Enterprise Server 15 LTSS ruby2.5 Affected
SUSE Linux Enterprise Server ESPOS 15 ruby Affected
SUSE Linux Enterprise Server ESPOS 15 ruby2.5 Affected
SUSE Linux Enterprise Server for SAP Applications 12 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One ruby Not affected
SUSE Linux Enterprise Server for the Raspberry Pi ruby Not affected
SUSE Linux Enterprise Server for the Raspberry Pi ruby2.1 Not affected
SUSE Linux Enterprise Software Development Kit 11 ruby Not affected
SUSE Linux Enterprise Software Development Kit 11 SP1 ruby Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 ruby Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 ruby Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 ruby2.1 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ruby2.1 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ruby Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ruby2.1 Not affected
SUSE Studio Extension for System z 1.2 ruby Not affected
SUSE Studio Onsite ruby Not affected
WebYaST for SLE-11 ruby Not affected