Upstream information

CVE-2012-4425 at MITRE

Description

libgio, when used in setuid or other privileged programs in spice-gtk and possibly other products, allows local users to gain privileges and execute arbitrary code via the DBUS_SYSTEM_BUS_ADDRESS environment variable. NOTE: it could be argued that this is a vulnerability in the applications that do not cleanse environment variables, not in libgio itself.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • libspice-client-glib-2_0-8 >= 0.29-1.4
  • libspice-client-gtk-2_0-4 >= 0.29-1.4
  • libspice-client-gtk-3_0-4 >= 0.29-1.4
  • libspice-controller0 >= 0.29-1.4
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.29-1.4
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.29-1.4
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libspice-client-glib-2_0-8 >= 0.31-7.2
  • libspice-client-glib-helper >= 0.31-7.2
  • libspice-client-gtk-2_0-4 >= 0.31-7.2
  • libspice-client-gtk-3_0-4 >= 0.31-7.2
  • libspice-controller0 >= 0.31-7.2
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.31-7.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.31-7.2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-1.33
  • libspice-client-glib-helper >= 0.33-1.33
  • libspice-client-gtk-3_0-5 >= 0.33-1.33
  • libspice-controller0 >= 0.33-1.33
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-1.33
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-1.33
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libspice-client-glib-2_0-8 >= 0.33-3.6.1
  • libspice-client-glib-helper >= 0.33-3.6.1
  • libspice-client-gtk-3_0-5 >= 0.33-3.6.1
  • libspice-controller0 >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server 12
  • libspice-client-glib-2_0-8 >= 0.25-3.4
  • libspice-client-gtk-2_0-4 >= 0.25-3.4
  • libspice-client-gtk-3_0-4 >= 0.25-3.4
  • libspice-controller0 >= 0.25-3.4
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.25-3.4
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.25-3.4
SUSE Linux Enterprise Module for Basesystem 15
  • libspice-client-glib-2_0-8 >= 0.34-1.64
  • libspice-client-glib-helper >= 0.34-1.64
  • libspice-client-gtk-3_0-5 >= 0.34-1.64
  • libspice-controller0 >= 0.34-1.64
SUSE Linux Enterprise Module for Server Applications 15
  • spice-gtk-devel >= 0.34-1.64
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.34-1.64
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.34-1.64
SUSE Linux Enterprise Software Development Kit 12 SP1
  • spice-gtk-devel >= 0.29-1.4
  • typelib-1_0-SpiceClientGtk-2_0 >= 0.29-1.4
SUSE Linux Enterprise Software Development Kit 12 SP2
  • spice-gtk-devel >= 0.31-7.2
  • typelib-1_0-SpiceClientGtk-2_0 >= 0.31-7.2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • spice-gtk-devel >= 0.33-1.33
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-1.33
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • spice-gtk-devel >= 0.33-3.6.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.6.1
SUSE Linux Enterprise Software Development Kit 12
  • spice-gtk-devel >= 0.25-3.4
  • typelib-1_0-SpiceClientGtk-2_0 >= 0.25-3.4
openSUSE Leap 15.0
  • libspice-client-glib-2_0-8 >= 0.34-lp150.1.14
  • libspice-client-glib-helper >= 0.34-lp150.1.14
  • libspice-client-gtk-3_0-5 >= 0.34-lp150.1.14
  • libspice-controller0 >= 0.34-lp150.1.14
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.34-lp150.1.14
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.34-lp150.1.14
Patchnames:
openSUSE Leap 15.0 GA libspice-client-glib-2_0-8
openSUSE Leap 42.1
  • libspice-client-glib-2_0-8 >= 0.29-4.2
  • libspice-client-gtk-2_0-4 >= 0.29-4.2
  • libspice-client-gtk-3_0-4 >= 0.29-4.2
  • libspice-controller0 >= 0.29-4.2
  • python-SpiceClientGtk >= 0.29-4.2
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.29-4.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.29-4.2
Patchnames:
openSUSE Leap 42.1 GA libspice-client-glib-2_0-8
openSUSE Leap 42.2
  • libspice-client-glib-2_0-8 >= 0.31-2.1
  • libspice-client-glib-helper >= 0.31-2.1
  • libspice-client-gtk-2_0-4 >= 0.31-2.1
  • libspice-client-gtk-3_0-4 >= 0.31-2.1
  • libspice-controller0 >= 0.31-2.1
  • python-SpiceClientGtk >= 0.31-2.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.31-2.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.31-2.1
Patchnames:
openSUSE Leap 42.2 GA libspice-client-glib-2_0-8
openSUSE Leap 42.3
  • libspice-client-glib-2_0-8 >= 0.33-1.1
  • libspice-client-glib-helper >= 0.33-1.1
  • libspice-client-gtk-3_0-5 >= 0.33-1.1
  • libspice-controller0 >= 0.33-1.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-1.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-1.1
Patchnames:
openSUSE Leap 42.3 GA libspice-client-glib-2_0-8
openSUSE Tumbleweed
  • libspice-client-glib-2_0-8 >= 0.33-2.1
  • libspice-client-glib-helper >= 0.33-2.1
  • libspice-client-gtk-3_0-5 >= 0.33-2.1
  • libspice-controller0 >= 0.33-2.1
  • spice-gtk >= 0.33-2.1
  • spice-gtk-devel >= 0.33-2.1
  • spice-gtk-lang >= 0.33-2.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-2.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-2.1
Patchnames:
openSUSE Tumbleweed GA libspice-client-glib-2_0-8