Upstream information

CVE-2011-2725 at MITRE

Description

Directory traversal vulnerability in Ark 4.7.x and earlier allows remote attackers to delete and force the display of arbitrary files via .. (dot dot) sequences in a zip file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 708268 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ark >= 4.3.5-0.3.3
  • kcalc >= 4.3.5-0.3.3
  • kcharselect >= 4.3.5-0.3.3
  • kdessh >= 4.3.5-0.3.3
  • kdf >= 4.3.5-0.3.3
  • kfloppy >= 4.3.5-0.3.3
  • kgpg >= 4.3.5-0.3.3
  • ktimer >= 4.3.5-0.3.3
  • kwalletmanager >= 4.3.5-0.3.3
  • kwikdisk >= 4.3.5-0.3.3
  • okteta >= 4.3.5-0.3.3
Patchnames:
slessp1-ark
SUSE Linux Enterprise Server 11 SP2
  • ark >= 4.3.5-0.3.3
  • kcalc >= 4.3.5-0.3.3
  • kcharselect >= 4.3.5-0.3.3
  • kdessh >= 4.3.5-0.3.3
  • kdf >= 4.3.5-0.3.3
  • kfloppy >= 4.3.5-0.3.3
  • kgpg >= 4.3.5-0.3.3
  • ktimer >= 4.3.5-0.3.3
  • kwalletmanager >= 4.3.5-0.3.3
  • kwikdisk >= 4.3.5-0.3.3
  • okteta >= 4.3.5-0.3.3
Patchnames:
slessp1fsp2-ark
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • ark >= 4.3.5-0.3.3
  • kcalc >= 4.3.5-0.3.3
  • kcharselect >= 4.3.5-0.3.3
  • kdessh >= 4.3.5-0.3.3
  • kdf >= 4.3.5-0.3.3
  • kfloppy >= 4.3.5-0.3.3
  • kgpg >= 4.3.5-0.3.3
  • ktimer >= 4.3.5-0.3.3
  • kwalletmanager >= 4.3.5-0.3.3
  • kwikdisk >= 4.3.5-0.3.3
  • okteta >= 4.3.5-0.3.3
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • ark >= 4.3.5-0.3.3
  • kcalc >= 4.3.5-0.3.3
  • kdessh >= 4.3.5-0.3.3
  • kdf >= 4.3.5-0.3.3
  • kfloppy >= 4.3.5-0.3.3
  • kgpg >= 4.3.5-0.3.3
  • kwalletmanager >= 4.3.5-0.3.3
  • kwikdisk >= 4.3.5-0.3.3
  • okteta >= 4.3.5-0.3.3
Builds
SAT Patch Nr: 5906
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • ark >= 4.3.5-0.3.3
  • kcalc >= 4.3.5-0.3.3
  • kcharselect >= 4.3.5-0.3.3
  • kdessh >= 4.3.5-0.3.3
  • kdf >= 4.3.5-0.3.3
  • kfloppy >= 4.3.5-0.3.3
  • kgpg >= 4.3.5-0.3.3
  • ktimer >= 4.3.5-0.3.3
  • kwalletmanager >= 4.3.5-0.3.3
  • kwikdisk >= 4.3.5-0.3.3
  • okteta >= 4.3.5-0.3.3
Builds
SAT Patch Nr: 5906
openSUSE 11.4
  • ark >= 4.6.0-4.5.1
  • filelight >= 4.6.0-4.5.1
  • kcalc >= 4.6.0-4.5.1
  • kcharselect >= 4.6.0-4.5.1
  • kde4-printer-applet >= 4.6.0-4.5.1
  • kdeutils4 >= 4.6.0-4.5.1
  • kdf >= 4.6.0-4.5.1
  • kfloppy >= 4.6.0-4.5.1
  • kgpg >= 4.6.0-4.5.1
  • kremotecontrol >= 4.6.0-4.5.1
  • ktimer >= 4.6.0-4.5.1
  • kwalletmanager >= 4.6.0-4.5.1
  • kwikdisk >= 4.6.0-4.5.1
  • superkaramba >= 4.6.0-4.5.1
  • sweeper >= 4.6.0-4.5.1
openSUSE 11.4
  • ark >= 4.6.0-4.5.1
  • ark-debuginfo >= 4.6.0-4.5.1
  • filelight >= 4.6.0-4.5.1
  • filelight-debuginfo >= 4.6.0-4.5.1
  • kcalc >= 4.6.0-4.5.1
  • kcalc-debuginfo >= 4.6.0-4.5.1
  • kcharselect >= 4.6.0-4.5.1
  • kcharselect-debuginfo >= 4.6.0-4.5.1
  • kde4-printer-applet >= 4.6.0-4.5.1
  • kdeutils4 >= 4.6.0-4.5.1
  • kdeutils4-debugsource >= 4.6.0-4.5.1
  • kdf >= 4.6.0-4.5.1
  • kdf-debuginfo >= 4.6.0-4.5.1
  • kfloppy >= 4.6.0-4.5.1
  • kfloppy-debuginfo >= 4.6.0-4.5.1
  • kgpg >= 4.6.0-4.5.1
  • kgpg-debuginfo >= 4.6.0-4.5.1
  • kremotecontrol >= 4.6.0-4.5.1
  • kremotecontrol-debuginfo >= 4.6.0-4.5.1
  • ktimer >= 4.6.0-4.5.1
  • ktimer-debuginfo >= 4.6.0-4.5.1
  • kwalletmanager >= 4.6.0-4.5.1
  • kwalletmanager-debuginfo >= 4.6.0-4.5.1
  • kwikdisk >= 4.6.0-4.5.1
  • kwikdisk-debuginfo >= 4.6.0-4.5.1
  • superkaramba >= 4.6.0-4.5.1
  • superkaramba-debuginfo >= 4.6.0-4.5.1
  • sweeper >= 4.6.0-4.5.1
  • sweeper-debuginfo >= 4.6.0-4.5.1
Patchnames:
ark


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications kdeutils4 Released
SUSE Linux Enterprise Desktop 11 SP1 kdeutils4 Released
SUSE Linux Enterprise Desktop 11 SP2 kdeutils4 Released
SUSE Linux Enterprise Desktop 11 SP3 kdeutils4 Released
SUSE Linux Enterprise Desktop 11 SP4 kdeutils4 Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search kdeutils4 Released
SUSE Linux Enterprise Server 11 SP1 kdeutils4 Released
SUSE Linux Enterprise Server 11 SP1 LTSS kdeutils4 Released
SUSE Linux Enterprise Server 11 SP2 kdeutils4 Released
SUSE Linux Enterprise Server 11 SP2 LTSS kdeutils4 Released
SUSE Linux Enterprise Server 11 SP2 for VMware kdeutils4 Released
SUSE Linux Enterprise Server 11 SP3 kdeutils4 Released
SUSE Linux Enterprise Server 11 SP3 LTSS kdeutils4 Released
SUSE Linux Enterprise Server 11 SP3 for VMware kdeutils4 Released
SUSE Linux Enterprise Server 11 SP4 kdeutils4 Released
SUSE Linux Enterprise Server 11 SP4 LTSS kdeutils4 Released
SUSE Linux Enterprise Server for SAP Business All-in-One kdeutils4 Released