Upstream information

CVE-2011-2178 at MITRE

Description

The virSecurityManagerGetPrivateData function in security/security_manager.c in libvirt 0.8.8 through 0.9.1 uses the wrong argument for a sizeof call, which causes incorrect processing of "security manager private data" that "reopens disk probing" and might allow guest OS users to read arbitrary files on the host OS. NOTE: this vulnerability exists because of a CVE-2010-2238 regression.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:S/C:C/I:N/A:N
Access Vector Local
Access Complexity Medium
Authentication Single
Confidentiality Impact Complete
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 697904 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.4
  • libvirt >= 0.8.8-0.10.1
  • libvirt-client >= 0.8.8-0.10.1
  • libvirt-devel >= 0.8.8-0.10.1
  • libvirt-doc >= 0.8.8-0.10.1
  • libvirt-python >= 0.8.8-0.10.1
openSUSE 11.4
  • libvirt >= 0.8.8-0.10.1
  • libvirt-client >= 0.8.8-0.10.1
  • libvirt-client-debuginfo >= 0.8.8-0.10.1
  • libvirt-debuginfo >= 0.8.8-0.10.1
  • libvirt-debugsource >= 0.8.8-0.10.1
  • libvirt-devel >= 0.8.8-0.10.1
  • libvirt-doc >= 0.8.8-0.10.1
  • libvirt-python >= 0.8.8-0.10.1
  • libvirt-python-debuginfo >= 0.8.8-0.10.1
Patchnames:
libvirt


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications libvirt Not affected
SUSE Linux Enterprise 15 Module for Basesystem libvirt Not affected
SUSE Linux Enterprise 15 Module for Server Applications libvirt Not affected
SUSE Linux Enterprise Desktop 12 SP3 libvirt Not affected
SUSE Linux Enterprise Desktop 12 SP4 libvirt Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 libvirt Not affected
SUSE Linux Enterprise Server 11 SP1 libvirt Not affected
SUSE Linux Enterprise Server 11 SP3 libvirt Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP3 libvirt Not affected
SUSE Linux Enterprise Server 12 SP4 libvirt Not affected
SUSE Linux Enterprise Server for SAP Applications 12 libvirt Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libvirt Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libvirt Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libvirt Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libvirt Not affected