Upstream information

CVE-2007-6199 at MITRE

Description

rsync before 3.0.0pre6, when running a writable rsync daemon that is not using chroot, allows remote attackers to access restricted files via unknown vectors that cause rsync to create a symlink that points outside of the module's hierarchy.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 345507 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • rsync >= 3.0.4-2.33.82
SUSE Linux Enterprise Server 11 SP2
  • rsync >= 3.0.4-2.38.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • rsync >= 3.0.4-2.47.28
openSUSE Tumbleweed
  • rsync >= 3.2.3-2.6
Patchnames:
openSUSE Tumbleweed GA rsync-3.2.3-2.6