SUSE Support

Here When You Need Us

Upgrading from SLES 11 SP4 to SLES 12 SP5 results in certificate error

This document (000019726) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 SP5 x86_64

Situation

After performing a off-line/down-server upgrade from SLES11SP4 to SLES12SP5, attempts to bootstrap the upgraded system to a SUMA server, or attempts to run the "update-ca-certificates" command result in the following error:

p11-kit: RHN-ORG-TRUSTED-SSL-CERT.pem: Certificate: invalid or unsupported attribute

Resolution

Edit /etc/pki/RHN-ORG-TRUSTED-SSL-CERT.pem and remove the following line...

[p11-kit-object-v1]

... or delete the file altogether.

Once the file is saved or has been deleted, bootstrapping the system to SUMA or running the "update-ca-certificates" command should succeed and a new certificate will be obtained.

Cause

After the SLES11SP4 -> SLES12SP5 upgrade procedure, RHN-ORG-TRUSTED-SSL-CERT.pem has a new tag on top of it that is causing issues...

[p11-kit-object-v1]

Additional Information

This issue affects both systems that were SUMA clients prior to upgrade, and standalone systems subscribed directly to the SUSE Customer Centre.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019726
  • Creation Date: 26-Oct-2020
  • Modified Date:26-Oct-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.