Upstream information

CVE-2020-6860 at MITRE

Description

libmysofa 0.9.1 has a stack-based buffer overflow in readDataVar in hdf/dataobject.c during the reading of a header message attribute.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1182883 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP2
  • libmysofa-devel >= 0.9.1-bp152.4.3.1
  • libmysofa0 >= 0.9.1-bp152.4.3.1
  • libmysofa0-64bit >= 0.9.1-bp152.4.3.1
Patchnames:
openSUSE-2021-459
openSUSE Leap 15.2
  • libmysofa-devel >= 0.9.1-lp152.3.3.1
  • libmysofa0 >= 0.9.1-lp152.3.3.1
Patchnames:
openSUSE-2021-444
openSUSE Tumbleweed
  • libmysofa-devel >= 1.2-1.3
  • libmysofa1 >= 1.2-1.3
  • libmysofa1-32bit >= 1.2-1.3
Patchnames:
openSUSE-Tumbleweed-2024-10960


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP6 libmysofa Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 libmysofa Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 libmysofa Already fixed
SUSE Linux Enterprise Server 15 SP6 libmysofa Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 libmysofa Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE Package Hub 15 SP2 libmysofa Released


SUSE Timeline for this CVE

CVE page created: Tue Mar 2 10:06:28 2021
CVE page last modified: Sun Jun 16 00:58:14 2024