Upstream information

CVE-2020-13777 at MITRE

Description

GnuTLS 3.6.x before 3.6.14 uses incorrect cryptography for encrypting a session ticket (a loss of confidentiality in TLS 1.2, and an authentication bypass in TLS 1.3). The earliest affected version is 3.6.4 (2018-09-24) because of an error in a 2018-09-18 commit. Until the first key rotation, the TLS server always uses wrong data in place of an encryption key derived from an application.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.4 7.4
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1172461 [RESOLVED / FIXED], 1172506 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/caasp-dex:2.16.0
Container caasp/v4/cilium-init:1.5.3
Container caasp/v4/cilium-operator:1.6.6
Container caasp/v4/cilium:1.6.6
Container caasp/v4/gangway:3.1.0
Container suse/sle15:15.0
Container suse/sle15:15.1
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image caasp4/caasp-389-ds-image
Image caasp4/caasp-busybox-image
Image caasp4/caasp-caasp-dex-image
Image caasp4/caasp-cert-exporter-image
Image caasp4/caasp-cilium-etcd-operator-image
Image caasp4/caasp-cilium-image
Image caasp4/caasp-cilium-init-image
Image caasp4/caasp-cilium-operator-image
Image caasp4/caasp-cloud-provider-openstack-image
Image caasp4/caasp-configmap-reload-image
Image caasp4/caasp-coredns-image
Image caasp4/caasp-curl-image
Image caasp4/caasp-etcd-image
Image caasp4/caasp-gangway-image
Image caasp4/caasp-grafana-image
Image caasp4/caasp-helm-tiller-image
Image caasp4/caasp-hyperkube-image
Image caasp4/caasp-k8s-sidecar-image
Image caasp4/caasp-kube-state-metrics-image
Image caasp4/caasp-kubernetes-client-image
Image caasp4/caasp-kured-image
Image caasp4/caasp-metrics-server-image
Image caasp4/caasp-prometheus-alertmanager-image
Image caasp4/caasp-prometheus-node-exporter-image
Image caasp4/caasp-prometheus-pushgateway-image
Image caasp4/caasp-prometheus-server-image
Image caasp4/caasp-rsyslog-image
Image caasp4/caasp-test-update-image
Image caasp4/caasp-velero-image
Image caasp4/caasp-velero-plugin-for-aws-image
Image caasp4/caasp-velero-plugin-for-gcp-image
Image caasp4/caasp-velero-plugin-for-microsoft-azure-image
Image caasp4/caasp-velero-restic-restore-helper-image
  • libgnutls30 >= 3.6.7-6.29.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • gnutls >= 3.6.7-6.29.1
  • libgnutls-devel >= 3.6.7-6.29.1
  • libgnutls30 >= 3.6.7-6.29.1
  • libgnutls30-32bit >= 3.6.7-6.29.1
  • libgnutls30-hmac >= 3.6.7-6.29.1
  • libgnutls30-hmac-32bit >= 3.6.7-6.29.1
  • libgnutlsxx-devel >= 3.6.7-6.29.1
  • libgnutlsxx28 >= 3.6.7-6.29.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1584
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gnutls >= 3.6.7-6.29.1
  • libgnutls-devel >= 3.6.7-6.29.1
  • libgnutls30 >= 3.6.7-6.29.1
  • libgnutls30-32bit >= 3.6.7-6.29.1
  • libgnutls30-hmac >= 3.6.7-6.29.1
  • libgnutls30-hmac-32bit >= 3.6.7-6.29.1
  • libgnutlsxx-devel >= 3.6.7-6.29.1
  • libgnutlsxx28 >= 3.6.7-6.29.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1584
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • gnutls >= 3.6.7-12.1
  • libgnutls-devel >= 3.6.7-12.1
  • libgnutls30 >= 3.6.7-12.1
  • libgnutls30-32bit >= 3.6.7-12.1
  • libgnutls30-hmac >= 3.6.7-12.1
  • libgnutls30-hmac-32bit >= 3.6.7-12.1
  • libgnutlsxx-devel >= 3.6.7-12.1
  • libgnutlsxx28 >= 3.6.7-12.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • gnutls >= 3.6.7-6.29.1
  • gnutls-guile >= 3.6.7-6.29.1
  • libgnutls-devel-32bit >= 3.6.7-6.29.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1584
SUSE Linux Enterprise Server 15-LTSS
  • gnutls >= 3.6.7-6.29.1
  • libgnutls-devel >= 3.6.7-6.29.1
  • libgnutls30 >= 3.6.7-6.29.1
  • libgnutls30-32bit >= 3.6.7-6.29.1
  • libgnutls30-hmac >= 3.6.7-6.29.1
  • libgnutls30-hmac-32bit >= 3.6.7-6.29.1
  • libgnutlsxx-devel >= 3.6.7-6.29.1
  • libgnutlsxx28 >= 3.6.7-6.29.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1584
SUSE Linux Enterprise Server for SAP Applications 15
  • gnutls >= 3.6.7-6.29.1
  • libgnutls-devel >= 3.6.7-6.29.1
  • libgnutls30 >= 3.6.7-6.29.1
  • libgnutls30-32bit >= 3.6.7-6.29.1
  • libgnutls30-hmac >= 3.6.7-6.29.1
  • libgnutls30-hmac-32bit >= 3.6.7-6.29.1
  • libgnutlsxx-devel >= 3.6.7-6.29.1
  • libgnutlsxx28 >= 3.6.7-6.29.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1584
openSUSE Leap 15.1
  • gnutls >= 3.6.7-lp151.2.18.1
  • gnutls-debuginfo >= 3.6.7-lp151.2.18.1
  • gnutls-debugsource >= 3.6.7-lp151.2.18.1
  • gnutls-guile >= 3.6.7-lp151.2.18.1
  • gnutls-guile-debuginfo >= 3.6.7-lp151.2.18.1
  • libgnutls-dane-devel >= 3.6.7-lp151.2.18.1
  • libgnutls-dane0 >= 3.6.7-lp151.2.18.1
  • libgnutls-dane0-debuginfo >= 3.6.7-lp151.2.18.1
  • libgnutls-devel >= 3.6.7-lp151.2.18.1
  • libgnutls-devel-32bit >= 3.6.7-lp151.2.18.1
  • libgnutls30 >= 3.6.7-lp151.2.18.1
  • libgnutls30-32bit >= 3.6.7-lp151.2.18.1
  • libgnutls30-32bit-debuginfo >= 3.6.7-lp151.2.18.1
  • libgnutls30-debuginfo >= 3.6.7-lp151.2.18.1
  • libgnutls30-hmac >= 3.6.7-lp151.2.18.1
  • libgnutls30-hmac-32bit >= 3.6.7-lp151.2.18.1
  • libgnutlsxx-devel >= 3.6.7-lp151.2.18.1
  • libgnutlsxx28 >= 3.6.7-lp151.2.18.1
  • libgnutlsxx28-debuginfo >= 3.6.7-lp151.2.18.1
Patchnames:
openSUSE-2020-790


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15-SP1 Module for Basesystem gnutls Released
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 gnutls Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS gnutls Released
SUSE Linux Enterprise Server 11 SP4 LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP2 BCL gnutls Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP3 BCL gnutls Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS gnutls Not affected
SUSE Linux Enterprise Server 12 SP4 gnutls Not affected
SUSE Linux Enterprise Server 12 SP5 gnutls Not affected
SUSE Linux Enterprise Server 15 LTSS gnutls Released
SUSE Linux Enterprise Server ESPOS 15 gnutls Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gnutls Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 gnutls Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 gnutls Not affected