Upstream information

CVE-2019-9936 at MITRE

Description

In SQLite 3.27.2, running fts5 prefix queries inside a transaction could trigger a heap-based buffer over-read in fts5HashEntrySort in sqlite3.c, which may lead to an information leak. This is related to ext/fts5/fts5_hash.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1130326 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libsqlite3-0 >= 3.28.0-3.6.1
  • libsqlite3-0-32bit >= 3.28.0-3.6.1
  • sqlite3 >= 3.28.0-3.6.1
  • sqlite3-devel >= 3.28.0-3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1127
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libsqlite3-0 >= 3.28.0-3.6.1
  • libsqlite3-0-32bit >= 3.28.0-3.6.1
  • sqlite3 >= 3.28.0-3.6.1
  • sqlite3-devel >= 3.28.0-3.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libsqlite3-0
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • sqlite3 >= 3.28.0-3.6.1
  • sqlite3-doc >= 3.28.0-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1127
openSUSE Leap 15.0
  • libsqlite3-0 >= 3.28.0-lp150.2.6.1
  • libsqlite3-0-32bit >= 3.28.0-lp150.2.6.1
  • libsqlite3-0-32bit-debuginfo >= 3.28.0-lp150.2.6.1
  • libsqlite3-0-debuginfo >= 3.28.0-lp150.2.6.1
  • sqlite3 >= 3.28.0-lp150.2.6.1
  • sqlite3-debuginfo >= 3.28.0-lp150.2.6.1
  • sqlite3-debugsource >= 3.28.0-lp150.2.6.1
  • sqlite3-devel >= 3.28.0-lp150.2.6.1
  • sqlite3-doc >= 3.28.0-lp150.2.6.1
Patchnames:
openSUSE-2019-1372


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 sqlite3 Not affected
CaaS Platform 2.0 sqlite3 Not affected
CaaS Platform 3.0 sqlite3 Not affected
OpenStack Cloud Magnum Orchestration 7.0 sqlite3 Not affected
SUSE Business Critical Linux 12 SP2 sqlite3 Not affected
SUSE Linux Enterprise Desktop 11 GA sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 GA sqlite3 Not affected
SUSE Linux Enterprise Desktop 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP1 sqlite3 Not affected
SUSE Linux Enterprise Desktop 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP2 sqlite3 Not affected
SUSE Linux Enterprise Desktop 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP3 sqlite3 Not affected
SUSE Linux Enterprise Desktop 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Desktop 12 GA sqlite3 Not affected
SUSE Linux Enterprise Desktop 12 SP1 sqlite3 Not affected
SUSE Linux Enterprise Desktop 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP3 sqlite3 Not affected
SUSE Linux Enterprise Desktop 12 SP4 sqlite3 Not affected
SUSE Linux Enterprise High Availability 12 GA sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 GA sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 sqlite3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA sqlite3 Released
SUSE Linux Enterprise SDK 11 GA sqlite2 Not affected
SUSE Linux Enterprise SDK 11 GA sqlite3 Not affected
SUSE Linux Enterprise SDK 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP1 sqlite3 Not affected
SUSE Linux Enterprise SDK 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP2 sqlite3 Not affected
SUSE Linux Enterprise SDK 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP3 sqlite3 Not affected
SUSE Linux Enterprise SDK 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise SDK 12 GA sqlite2 Not affected
SUSE Linux Enterprise SDK 12 GA sqlite3 Not affected
SUSE Linux Enterprise SDK 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP1 sqlite3 Not affected
SUSE Linux Enterprise SDK 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP2 sqlite3 Not affected
SUSE Linux Enterprise SDK 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP3 sqlite3 Not affected
SUSE Linux Enterprise SDK 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite2 Not affected
SUSE Linux Enterprise Server 11 SP1 sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP2 sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP3 sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 11 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server 12 GA sqlite3 Not affected
SUSE Linux Enterprise Server 12 GA LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP1 sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP2 sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP3 sqlite3 Not affected
SUSE Linux Enterprise Server 12 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite3 Not affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 sqlite3 Not affected
SUSE Linux Enterprise Server for VMWare 11 SP2 sqlite3 Not affected
SUSE Linux Enterprise Server for VMWare 11 SP3 sqlite3 Not affected
SUSE Studio Onsite 1.3 sqlite3 Not affected