Upstream information

CVE-2019-5094 at MITRE

Description

An exploitable code execution vulnerability exists in the quota file functionality of E2fsprogs 1.45.3. A specially crafted ext4 partition can cause an out-of-bounds write on the heap, resulting in code execution. An attacker can corrupt a partition to trigger this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 6.7
Vector CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required High
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1152101 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/389-ds:1.4.0
Container caasp/v4/busybox:1.26.2
Container caasp/v4/cert-exporter:2.3.0
Container caasp/v4/cilium-etcd-operator:2.0.5
Container caasp/v4/cilium-init:1.5.3
Container caasp/v4/cilium-operator:1.6.6
Container caasp/v4/cilium:1.6.6
Container caasp/v4/configmap-reload:0.3.0
Container caasp/v4/coredns:1.6.5
Container caasp/v4/curl:7.60.0
Container caasp/v4/etcd:3.4.3
Container caasp/v4/gangway:3.1.0
Container caasp/v4/grafana:6.2.5
Container caasp/v4/helm-tiller:2.16.1
Container caasp/v4/hyperkube:v1.17.4
Container caasp/v4/k8s-sidecar:0.1.75
Container caasp/v4/kube-state-metrics:1.9.3
Container caasp/v4/kubernetes-client:1.17.4
Container caasp/v4/kured:1.3.0
Container caasp/v4/metrics-server:0.3.6
Container caasp/v4/prometheus-alertmanager:0.16.2
Container caasp/v4/prometheus-node-exporter:0.17.0
Container caasp/v4/prometheus-pushgateway:0.6.0
Container caasp/v4/prometheus-server:2.7.1
Container caasp/v4/velero-plugin-for-aws:1.0.1
Container caasp/v4/velero-plugin-for-gcp:1.0.1
Container caasp/v4/velero-plugin-for-microsoft-azure:1.0.1
Container caasp/v4/velero-restic-restore-helper:1.3.1
Container caasp/v4/velero:1.3.1
Container caasp/v5/389-ds:beta
Container caasp/v5/busybox:beta
Container caasp/v5/caasp-dex:beta
Container caasp/v5/cert-manager-cainjector:beta
Container caasp/v5/cert-manager-controller:beta
Container caasp/v5/cert-manager-webhook:beta
Container caasp/v5/cilium-etcd-operator:beta
Container caasp/v5/cilium-operator:beta
Container caasp/v5/cilium:beta
Container caasp/v5/configmap-reload:beta
Container caasp/v5/coredns:beta
Container caasp/v5/curl:beta
Container caasp/v5/etcd:beta
Container caasp/v5/gangway:beta
Container caasp/v5/grafana:beta
Container caasp/v5/helm-tiller:beta
Container caasp/v5/k8s-sidecar:beta
Container caasp/v5/kube-apiserver:beta
Container caasp/v5/kube-controller-manager:beta
Container caasp/v5/kube-proxy:beta
Container caasp/v5/kube-scheduler:beta
Container caasp/v5/kube-state-metrics:beta
Container caasp/v5/kubernetes-client:beta
Container caasp/v5/kucero:beta
Container caasp/v5/kured:beta
Container caasp/v5/metrics-server:beta
Container caasp/v5/prometheus-alertmanager:beta
Container caasp/v5/prometheus-node-exporter:beta
Container caasp/v5/prometheus-pushgateway:beta
Container caasp/v5/prometheus-server:beta
Container caasp/v5/reloader:beta
Container caasp/v5/rsyslog:beta
Container caasp/v5/skuba-tooling:beta
Container caasp/v5/velero-plugin-for-aws:beta
Container caasp/v5/velero-plugin-for-gcp:beta
Container caasp/v5/velero-plugin-for-microsoft-azure:beta
Container caasp/v5/velero-restic-restore-helper:beta
Container caasp/v5/velero:beta
Container suse/sle15:15.0
Container suse/sle15:15.1
Container suse/sle15:15.2
Image caasp-389-ds-image
Image caasp-busybox-image
Image caasp-caasp-dex-image
Image caasp-cert-exporter-image
Image caasp-cilium-etcd-operator-image
Image caasp-cilium-image
Image caasp-cilium-init-image
Image caasp-cilium-operator-image
Image caasp-cloud-provider-openstack-image
Image caasp-configmap-reload-image
Image caasp-coredns-image
Image caasp-curl-image
Image caasp-etcd-image
Image caasp-gangway-image
Image caasp-grafana-image
Image caasp-helm-tiller-image
Image caasp-hyperkube-image
Image caasp-k8s-sidecar-image
Image caasp-kube-state-metrics-image
Image caasp-kubernetes-client-image
Image caasp-kured-image
Image caasp-metrics-server-image
Image caasp-prometheus-alertmanager-image
Image caasp-prometheus-node-exporter-image
Image caasp-prometheus-pushgateway-image
Image caasp-prometheus-server-image
Image caasp-rsyslog-image
Image caasp-test-update-image
Image caasp-velero-image
Image caasp-velero-plugin-for-aws-image
Image caasp-velero-plugin-for-gcp-image
Image caasp-velero-plugin-for-microsoft-azure-image
Image caasp-velero-restic-restore-helper-image
  • libcom_err2 >= 1.43.8-4.11.1
Container suse/sles12sp4:latest
Container suse/sles12sp5:latest
  • libcom_err2 >= 1.43.8-3.8.1
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • e2fsprogs >= 1.43.8-4.11.1
  • libcom_err2 >= 1.43.8-4.11.1
  • libext2fs2 >= 1.43.8-4.11.1
SUSE Linux Enterprise Desktop 12 SP4
  • e2fsprogs >= 1.43.8-3.8.1
  • libcom_err2 >= 1.43.8-3.8.1
  • libcom_err2-32bit >= 1.43.8-3.8.1
  • libext2fs2 >= 1.43.8-3.8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2677
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • e2fsprogs >= 1.43.8-3.8.1
  • libcom_err2 >= 1.43.8-3.8.1
  • libcom_err2-32bit >= 1.43.8-3.8.1
  • libext2fs2 >= 1.43.8-3.8.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • e2fsprogs >= 1.43.8-4.11.1
  • e2fsprogs-devel >= 1.43.8-4.11.1
  • libcom_err-devel >= 1.43.8-4.11.1
  • libcom_err-devel-static >= 1.43.8-4.11.1
  • libcom_err2 >= 1.43.8-4.11.1
  • libcom_err2-32bit >= 1.43.8-4.11.1
  • libext2fs-devel >= 1.43.8-4.11.1
  • libext2fs-devel-static >= 1.43.8-4.11.1
  • libext2fs2 >= 1.43.8-4.11.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2676
SUSE Linux Enterprise Module for Basesystem 15
  • e2fsprogs >= 1.43.8-4.11.1
  • e2fsprogs-devel >= 1.43.8-4.11.1
  • libcom_err-devel >= 1.43.8-4.11.1
  • libcom_err-devel-static >= 1.43.8-4.11.1
  • libcom_err2 >= 1.43.8-4.11.1
  • libcom_err2-32bit >= 1.43.8-4.11.1
  • libext2fs-devel >= 1.43.8-4.11.1
  • libext2fs-devel-static >= 1.43.8-4.11.1
  • libext2fs2 >= 1.43.8-4.11.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2676
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • e2fsprogs >= 1.43.8-4.11.1
  • libcom_err-devel-32bit >= 1.43.8-4.11.1
  • libext2fs-devel-32bit >= 1.43.8-4.11.1
  • libext2fs2-32bit >= 1.43.8-4.11.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2676
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • e2fsprogs >= 1.43.8-3.8.1
  • libcom_err2 >= 1.43.8-3.8.1
  • libcom_err2-32bit >= 1.43.8-3.8.1
  • libext2fs2 >= 1.43.8-3.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2677
SUSE Linux Enterprise Software Development Kit 12 SP4
  • e2fsprogs >= 1.43.8-3.8.1
  • e2fsprogs-devel >= 1.43.8-3.8.1
  • libcom_err-devel >= 1.43.8-3.8.1
  • libext2fs-devel >= 1.43.8-3.8.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2677
SUSE Linux Enterprise Software Development Kit 12 SP5
  • e2fsprogs-devel >= 1.43.8-3.8.1
  • libcom_err-devel >= 1.43.8-3.8.1
  • libext2fs-devel >= 1.43.8-3.8.1
openSUSE Leap 15.0
  • e2fsprogs >= 1.43.8-lp150.11.1
  • e2fsprogs-32bit-debuginfo >= 1.43.8-lp150.11.1
  • e2fsprogs-debuginfo >= 1.43.8-lp150.11.1
  • e2fsprogs-debugsource >= 1.43.8-lp150.11.1
  • e2fsprogs-devel >= 1.43.8-lp150.11.1
  • libcom_err-devel >= 1.43.8-lp150.11.1
  • libcom_err-devel-32bit >= 1.43.8-lp150.11.1
  • libcom_err-devel-static >= 1.43.8-lp150.11.1
  • libcom_err2 >= 1.43.8-lp150.11.1
  • libcom_err2-32bit >= 1.43.8-lp150.11.1
  • libcom_err2-32bit-debuginfo >= 1.43.8-lp150.11.1
  • libcom_err2-debuginfo >= 1.43.8-lp150.11.1
  • libext2fs-devel >= 1.43.8-lp150.11.1
  • libext2fs-devel-32bit >= 1.43.8-lp150.11.1
  • libext2fs-devel-static >= 1.43.8-lp150.11.1
  • libext2fs2 >= 1.43.8-lp150.11.1
  • libext2fs2-32bit >= 1.43.8-lp150.11.1
  • libext2fs2-32bit-debuginfo >= 1.43.8-lp150.11.1
  • libext2fs2-debuginfo >= 1.43.8-lp150.11.1
Patchnames:
openSUSE-2019-2349
openSUSE Leap 15.1
  • e2fsprogs >= 1.43.8-lp151.5.6.1
  • e2fsprogs-32bit-debuginfo >= 1.43.8-lp151.5.6.1
  • e2fsprogs-debuginfo >= 1.43.8-lp151.5.6.1
  • e2fsprogs-debugsource >= 1.43.8-lp151.5.6.1
  • e2fsprogs-devel >= 1.43.8-lp151.5.6.1
  • libcom_err-devel >= 1.43.8-lp151.5.6.1
  • libcom_err-devel-32bit >= 1.43.8-lp151.5.6.1
  • libcom_err-devel-static >= 1.43.8-lp151.5.6.1
  • libcom_err2 >= 1.43.8-lp151.5.6.1
  • libcom_err2-32bit >= 1.43.8-lp151.5.6.1
  • libcom_err2-32bit-debuginfo >= 1.43.8-lp151.5.6.1
  • libcom_err2-debuginfo >= 1.43.8-lp151.5.6.1
  • libext2fs-devel >= 1.43.8-lp151.5.6.1
  • libext2fs-devel-32bit >= 1.43.8-lp151.5.6.1
  • libext2fs-devel-static >= 1.43.8-lp151.5.6.1
  • libext2fs2 >= 1.43.8-lp151.5.6.1
  • libext2fs2-32bit >= 1.43.8-lp151.5.6.1
  • libext2fs2-32bit-debuginfo >= 1.43.8-lp151.5.6.1
  • libext2fs2-debuginfo >= 1.43.8-lp151.5.6.1
Patchnames:
openSUSE-2019-2352


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 e2fsprogs Not affected
CaaS Platform 2.0 e2fsprogs Not affected
CaaS Platform 3.0 e2fsprogs Not affected
SUSE Linux Enterprise Desktop 12 SP4 e2fsprogs Already fixed
SUSE Linux Enterprise High Performance Computing 12 e2fsprogs Already fixed
SUSE Linux Enterprise Module for Basesystem 15 GA e2fsprogs Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 e2fsprogs Already fixed
SUSE Linux Enterprise SDK 12 SP4 e2fsprogs Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS e2fsprogs Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS e2fsprogs Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS e2fsprogs Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS e2fsprogs Not affected
SUSE Linux Enterprise Server 12 SP4 e2fsprogs Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 e2fsprogs Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 e2fsprogs Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 e2fsprogs Already fixed