Upstream information

CVE-2019-20485 at MITRE

Description

qemu/qemu_driver.c in libvirt before 6.0.0 mishandles the holding of a monitor job during a query to a guest agent, which allows attackers to cause a denial of service (API blockage).

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.7
Vector AV:A/AC:L/Au:S/C:N/I:N/A:P
Access Vector Adjacent Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.7 5.7
Vector CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Adjacent Network Adjacent Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1165616 [NEW], 1168683 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Basesystem libvirt Affected
SUSE Linux Enterprise 15 Module for Server Applications libvirt Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem libvirt Affected
SUSE Linux Enterprise 15-SP1 Module for Server Applications libvirt Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 libvirt Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libvirt Affected
SUSE Linux Enterprise Server 11 SP3 libvirt Affected
SUSE Linux Enterprise Server 11 SP4 LTSS libvirt Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libvirt Affected
SUSE Linux Enterprise Server 12 SP2 BCL libvirt Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libvirt Affected
SUSE Linux Enterprise Server 12 SP3 BCL libvirt Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libvirt Affected
SUSE Linux Enterprise Server 12 SP4 libvirt Affected
SUSE Linux Enterprise Server 12 SP5 libvirt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libvirt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libvirt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libvirt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libvirt Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libvirt Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libvirt Affected