Upstream information

CVE-2019-14850 at MITRE


A denial of service vulnerability was discovered in nbdkit 1.12.7, 1.14.1 and 1.15.1. An attacker could connect to the nbdkit service and cause it to perform a large amount of work in initializing backend plugins, by simply opening a connection to the service. This vulnerability could cause resource consumption and degradation of service in nbdkit, depending on the plugins configured on the server-side.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently not rated by SUSE as it is not affecting the SUSE Enterprise products.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.7
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 7
  • nbdkit >= 1.8.0-3.el7
  • nbdkit-basic-plugins >= 1.8.0-3.el7
  • nbdkit-devel >= 1.8.0-3.el7
  • nbdkit-example-plugins >= 1.8.0-3.el7
  • nbdkit-plugin-python-common >= 1.8.0-3.el7
  • nbdkit-plugin-python2 >= 1.8.0-3.el7
  • nbdkit-plugin-vddk >= 1.8.0-3.el7

SUSE Timeline for this CVE

CVE page created: Tue Oct 1 08:40:07 2019
CVE page last modified: Mon Oct 30 18:01:58 2023