Upstream information

CVE-2019-12904 at MITRE

Description

In Libgcrypt 1.8.4, the C implementation of AES is vulnerable to a flush-and-reload side-channel attack because physical addresses are available to other processes. (The C implementation is used on platforms where an assembly-language implementation is unavailable.)

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1138939 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libgcrypt >= 1.8.2-6.17.1
  • libgcrypt-devel >= 1.8.2-6.17.1
  • libgcrypt20 >= 1.8.2-6.17.1
  • libgcrypt20-32bit >= 1.8.2-6.17.1
  • libgcrypt20-hmac >= 1.8.2-6.17.1
  • libgcrypt20-hmac-32bit >= 1.8.2-6.17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1859
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libgcrypt >= 1.8.2-8.6.2
  • libgcrypt-devel >= 1.8.2-8.6.2
  • libgcrypt20 >= 1.8.2-8.6.2
  • libgcrypt20-32bit >= 1.8.2-8.6.2
  • libgcrypt20-hmac >= 1.8.2-8.6.2
  • libgcrypt20-hmac-32bit >= 1.8.2-8.6.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1971
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libgcrypt >= 1.8.2-6.17.1
  • libgcrypt-cavs >= 1.8.2-6.17.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1859
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libgcrypt >= 1.8.2-8.6.2
  • libgcrypt-cavs >= 1.8.2-8.6.2
  • libgcrypt-devel-32bit >= 1.8.2-8.6.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1971
openSUSE Leap 15.0
  • libgcrypt >= 1.8.2-lp150.5.10.1
  • libgcrypt-cavs >= 1.8.2-lp150.5.10.1
  • libgcrypt-cavs-debuginfo >= 1.8.2-lp150.5.10.1
  • libgcrypt-debugsource >= 1.8.2-lp150.5.10.1
  • libgcrypt-devel >= 1.8.2-lp150.5.10.1
  • libgcrypt-devel-32bit >= 1.8.2-lp150.5.10.1
  • libgcrypt-devel-32bit-debuginfo >= 1.8.2-lp150.5.10.1
  • libgcrypt-devel-debuginfo >= 1.8.2-lp150.5.10.1
  • libgcrypt20 >= 1.8.2-lp150.5.10.1
  • libgcrypt20-32bit >= 1.8.2-lp150.5.10.1
  • libgcrypt20-32bit-debuginfo >= 1.8.2-lp150.5.10.1
  • libgcrypt20-debuginfo >= 1.8.2-lp150.5.10.1
  • libgcrypt20-hmac >= 1.8.2-lp150.5.10.1
  • libgcrypt20-hmac-32bit >= 1.8.2-lp150.5.10.1
Patchnames:
openSUSE-2019-1792


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 libgcrypt Analysis
CaaS Platform 2.0 libgcrypt Analysis
CaaS Platform 3.0 libgcrypt Analysis
OpenStack Cloud Magnum Orchestration 7.0 libgcrypt Analysis
SUSE Linux Enterprise Desktop 12 SP3 libgcrypt Analysis
SUSE Linux Enterprise Desktop 12 SP4 libgcrypt Analysis
SUSE Linux Enterprise High Performance Computing 12 libgcrypt Analysis
SUSE Linux Enterprise Module for Basesystem 15 GA libgcrypt Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 libgcrypt Released
SUSE Linux Enterprise SDK 12 SP3 libgcrypt Analysis
SUSE Linux Enterprise SDK 12 SP4 libgcrypt Analysis
SUSE Linux Enterprise Server 11 SP3 LTSS libgcrypt Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS libgcrypt Analysis
SUSE Linux Enterprise Server 12 GA LTSS libgcrypt Analysis
SUSE Linux Enterprise Server 12 SP1 LTSS libgcrypt Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS libgcrypt Analysis
SUSE Linux Enterprise Server 12 SP3 libgcrypt Analysis
SUSE Linux Enterprise Server 12 SP4 libgcrypt Analysis
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libgcrypt Analysis
SUSE Linux Enterprise Server for SAP Applications 12 GA libgcrypt Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libgcrypt Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libgcrypt Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libgcrypt Analysis