Upstream information

CVE-2018-16845 at MITRE

Description

nginx before versions 1.15.6, 1.14.1 has a vulnerability in the ngx_http_mp4_module, which might allow an attacker to cause infinite loop in a worker process, cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted mp4 file. The issue only affects nginx if it is built with the ngx_http_mp4_module (the module is not built by default) and the .mp4. directive is used in the configuration file. Further, the attack is only possible if an attacker is able to trigger processing of a specially crafted mp4 file with the ngx_http_mp4_module.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.1 8.2
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1115015 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • nginx >= 1.14.2-3.3.1
  • vim-plugin-nginx >= 1.14.2-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-334
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • nginx >= 1.14.2-6.3.1
  • vim-plugin-nginx >= 1.14.2-6.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2309
SUSE Linux Enterprise Module for Server Applications 15
  • nginx >= 1.14.2-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-334
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • nginx >= 1.14.2-6.3.1
  • nginx-source >= 1.14.2-6.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-2309
SUSE Package Hub for SUSE Linux Enterprise 12
  • nginx >= 1.14.2-16.1
  • nginx-debuginfo >= 1.14.2-16.1
  • nginx-debugsource >= 1.14.2-16.1
  • vim-plugin-nginx >= 1.14.2-16.1
Patchnames:
openSUSE-2019-195
openSUSE Leap 15.0
  • nginx >= 1.14.2-lp150.2.4.1
  • nginx-debuginfo >= 1.14.2-lp150.2.4.1
  • nginx-debugsource >= 1.14.2-lp150.2.4.1
  • vim-plugin-nginx >= 1.14.2-lp150.2.4.1
Patchnames:
openSUSE-2019-195
openSUSE Leap 15.1
  • nginx >= 1.14.2-lp151.4.3.1
  • nginx-debuginfo >= 1.14.2-lp151.4.3.1
  • nginx-debugsource >= 1.14.2-lp151.4.3.1
  • nginx-source >= 1.14.2-lp151.4.3.1
  • vim-plugin-nginx >= 1.14.2-lp151.4.3.1
Patchnames:
openSUSE-2019-2120
openSUSE Leap 42.3
  • nginx >= 1.14.2-2.7.1
  • nginx-debuginfo >= 1.14.2-2.7.1
  • nginx-debugsource >= 1.14.2-2.7.1
  • vim-plugin-nginx >= 1.14.2-2.7.1
Patchnames:
openSUSE-2019-195


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 nginx-1.0 Affected
SUSE Linux Enterprise Module for Server Applications 15 GA nginx Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 nginx Released
SUSE Studio Onsite 1.3 nginx-1.0 Affected