Upstream information

CVE-2018-16644 at MITRE

Description

There is a missing check for length in the functions ReadDCMImage of coders/dcm.c and ReadPICTImage of coders/pict.c in ImageMagick 7.0.8-11, which allows remote attackers to cause a denial of service via a crafted image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 3.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entries: 1107609 [RESOLVED / FIXED], 1107612 [RESOLVED / FIXED], 1117463 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-Storage-4-2019-1033
SUSE Linux Enterprise Desktop 12 SP3
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.85.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.85.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2195
SUSE-SLE-DESKTOP-12-SP3-2018-2480
SUSE-SLE-DESKTOP-12-SP3-2019-1033
SUSE Linux Enterprise Desktop 12 SP4
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.85.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.85.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA ImageMagick
SUSE-SLE-DESKTOP-12-SP4-2019-1033
SUSE Linux Enterprise Module for Desktop Applications 15
  • ImageMagick >= 7.0.7.34-3.24.1
  • ImageMagick-devel >= 7.0.7.34-3.24.1
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-3.24.1
  • libMagick++-devel >= 7.0.7.34-3.24.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-3.24.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-3.24.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2118
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • ImageMagick >= 7.0.7.34-3.54.3
  • ImageMagick-config-7-SUSE >= 7.0.7.34-3.54.3
  • ImageMagick-devel >= 7.0.7.34-3.54.3
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-3.54.3
  • libMagick++-devel >= 7.0.7.34-3.54.3
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-3.54.3
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-3.54.3
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA ImageMagick
SUSE Linux Enterprise Module for Development Tools 15
  • ImageMagick >= 7.0.7.34-3.24.1
  • perl-PerlMagick >= 7.0.7.34-3.24.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2118
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • perl-PerlMagick >= 7.0.7.34-3.54.3
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA perl-PerlMagick
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-1033
SUSE Linux Enterprise Server 11 SP4
  • ImageMagick >= 6.4.3.6-78.79.1
  • libMagickCore1 >= 6.4.3.6-78.79.1
  • libMagickCore1-32bit >= 6.4.3.6-78.79.1
Patchnames:
slessp4-ImageMagick-13831
slessp4-ImageMagick-13868
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1033
SUSE Linux Enterprise Server 12 SP2-BCL
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1033
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1033
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1033
SUSE Linux Enterprise Server 12 SP3
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.85.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.85.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2195
SUSE-SLE-SERVER-12-SP3-2018-2480
SUSE-SLE-SERVER-12-SP3-2019-1033
SUSE Linux Enterprise Server 12 SP4
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.85.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.85.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libMagickCore-6_Q16-1
SUSE-SLE-SERVER-12-SP4-2019-1033
SUSE Linux Enterprise Server 12-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1033
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ImageMagick >= 6.4.3.6-78.79.1
  • libMagickCore1 >= 6.4.3.6-78.79.1
  • libMagickCore1-32bit >= 6.4.3.6-78.79.1
Patchnames:
slessp4-ImageMagick-13831
slessp4-ImageMagick-13868
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.85.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.85.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2195
SUSE-SLE-SERVER-12-SP3-2018-2480
SUSE-SLE-SERVER-12-SP3-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1033
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1033
SUSE Linux Enterprise Software Development Kit 11 SP4
  • GraphicsMagick >= 1.2.5-78.72.1
  • ImageMagick >= 6.4.3.6-78.79.1
  • ImageMagick-devel >= 6.4.3.6-78.79.1
  • libGraphicsMagick2 >= 1.2.5-78.72.1
  • libMagick++-devel >= 6.4.3.6-78.79.1
  • libMagick++1 >= 6.4.3.6-78.79.1
  • libMagickWand1 >= 6.4.3.6-78.79.1
  • libMagickWand1-32bit >= 6.4.3.6-78.79.1
  • perl-GraphicsMagick >= 1.2.5-78.72.1
  • perl-PerlMagick >= 6.4.3.6-78.79.1
Patchnames:
sdksp4-GraphicsMagick-13827
sdksp4-ImageMagick-13831
sdksp4-ImageMagick-13868
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-devel >= 6.8.8.1-71.85.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagick++-devel >= 6.8.8.1-71.85.1
  • perl-PerlMagick >= 6.8.8.1-71.85.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2195
SUSE-SLE-SDK-12-SP3-2018-2480
SUSE-SLE-SDK-12-SP3-2019-1033
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-devel >= 6.8.8.1-71.85.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagick++-devel >= 6.8.8.1-71.85.1
  • perl-PerlMagick >= 6.8.8.1-71.85.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA ImageMagick
SUSE-SLE-SDK-12-SP4-2019-1033
SUSE Linux Enterprise Workstation Extension 12 SP3
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.85.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-2195
SUSE-SLE-WE-12-SP3-2018-2480
SUSE-SLE-WE-12-SP3-2019-1033
SUSE Linux Enterprise Workstation Extension 12 SP4
  • ImageMagick >= 6.8.8.1-71.85.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-71.85.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-71.85.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA ImageMagick
SUSE-SLE-WE-12-SP4-2019-1033
SUSE OpenStack Cloud 7
  • ImageMagick >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-71.108.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-71.108.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-71.108.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-71.108.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1033
SUSE Studio Onsite 1.3
  • GraphicsMagick >= 1.2.5-78.72.1
  • libGraphicsMagick2 >= 1.2.5-78.72.1
Patchnames:
slestso13-GraphicsMagick-13827
openSUSE Leap 15.0
  • GraphicsMagick >= 1.3.29-lp150.3.12.1
  • GraphicsMagick-debuginfo >= 1.3.29-lp150.3.12.1
  • GraphicsMagick-debugsource >= 1.3.29-lp150.3.12.1
  • GraphicsMagick-devel >= 1.3.29-lp150.3.12.1
  • ImageMagick >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-debuginfo >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-debugsource >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-devel >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-devel-32bit >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-doc >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-extra >= 7.0.7.34-lp150.2.15.1
  • ImageMagick-extra-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libGraphicsMagick++-Q16-12 >= 1.3.29-lp150.3.12.1
  • libGraphicsMagick++-Q16-12-debuginfo >= 1.3.29-lp150.3.12.1
  • libGraphicsMagick++-devel >= 1.3.29-lp150.3.12.1
  • libGraphicsMagick-Q16-3 >= 1.3.29-lp150.3.12.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.29-lp150.3.12.1
  • libGraphicsMagick3-config >= 1.3.29-lp150.3.12.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.29-lp150.3.12.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.29-lp150.3.12.1
  • libMagick++-7_Q16HDRI4 >= 7.0.7.34-lp150.2.15.1
  • libMagick++-7_Q16HDRI4-32bit >= 7.0.7.34-lp150.2.15.1
  • libMagick++-7_Q16HDRI4-32bit-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libMagick++-7_Q16HDRI4-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libMagick++-devel >= 7.0.7.34-lp150.2.15.1
  • libMagick++-devel-32bit >= 7.0.7.34-lp150.2.15.1
  • libMagickCore-7_Q16HDRI6 >= 7.0.7.34-lp150.2.15.1
  • libMagickCore-7_Q16HDRI6-32bit >= 7.0.7.34-lp150.2.15.1
  • libMagickCore-7_Q16HDRI6-32bit-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libMagickCore-7_Q16HDRI6-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libMagickWand-7_Q16HDRI6 >= 7.0.7.34-lp150.2.15.1
  • libMagickWand-7_Q16HDRI6-32bit >= 7.0.7.34-lp150.2.15.1
  • libMagickWand-7_Q16HDRI6-32bit-debuginfo >= 7.0.7.34-lp150.2.15.1
  • libMagickWand-7_Q16HDRI6-debuginfo >= 7.0.7.34-lp150.2.15.1
  • perl-GraphicsMagick >= 1.3.29-lp150.3.12.1
  • perl-GraphicsMagick-debuginfo >= 1.3.29-lp150.3.12.1
  • perl-PerlMagick >= 7.0.7.34-lp150.2.15.1
  • perl-PerlMagick-debuginfo >= 7.0.7.34-lp150.2.15.1
Patchnames:
openSUSE-2019-688
openSUSE-2019-758
openSUSE Leap 42.3
  • GraphicsMagick >= 1.3.25-105.1
  • GraphicsMagick-debuginfo >= 1.3.25-105.1
  • GraphicsMagick-debugsource >= 1.3.25-105.1
  • GraphicsMagick-devel >= 1.3.25-105.1
  • ImageMagick >= 6.8.8.1-82.1
  • ImageMagick-config-6-SUSE >= 6.8.8.1-82.1
  • ImageMagick-config-6-upstream >= 6.8.8.1-82.1
  • ImageMagick-debuginfo >= 6.8.8.1-82.1
  • ImageMagick-debugsource >= 6.8.8.1-82.1
  • ImageMagick-devel >= 6.8.8.1-82.1
  • ImageMagick-devel-32bit >= 6.8.8.1-82.1
  • ImageMagick-doc >= 6.8.8.1-82.1
  • ImageMagick-extra >= 6.8.8.1-82.1
  • ImageMagick-extra-debuginfo >= 6.8.8.1-82.1
  • libGraphicsMagick++-Q16-12 >= 1.3.25-105.1
  • libGraphicsMagick++-Q16-12-debuginfo >= 1.3.25-105.1
  • libGraphicsMagick++-devel >= 1.3.25-105.1
  • libGraphicsMagick-Q16-3 >= 1.3.25-105.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.25-105.1
  • libGraphicsMagick3-config >= 1.3.25-105.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-105.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.25-105.1
  • libMagick++-6_Q16-3 >= 6.8.8.1-82.1
  • libMagick++-6_Q16-3-32bit >= 6.8.8.1-82.1
  • libMagick++-6_Q16-3-debuginfo >= 6.8.8.1-82.1
  • libMagick++-6_Q16-3-debuginfo-32bit >= 6.8.8.1-82.1
  • libMagick++-devel >= 6.8.8.1-82.1
  • libMagick++-devel-32bit >= 6.8.8.1-82.1
  • libMagickCore-6_Q16-1 >= 6.8.8.1-82.1
  • libMagickCore-6_Q16-1-32bit >= 6.8.8.1-82.1
  • libMagickCore-6_Q16-1-debuginfo >= 6.8.8.1-82.1
  • libMagickCore-6_Q16-1-debuginfo-32bit >= 6.8.8.1-82.1
  • libMagickWand-6_Q16-1 >= 6.8.8.1-82.1
  • libMagickWand-6_Q16-1-32bit >= 6.8.8.1-82.1
  • libMagickWand-6_Q16-1-debuginfo >= 6.8.8.1-82.1
  • libMagickWand-6_Q16-1-debuginfo-32bit >= 6.8.8.1-82.1
  • perl-GraphicsMagick >= 1.3.25-105.1
  • perl-GraphicsMagick-debuginfo >= 1.3.25-105.1
  • perl-PerlMagick >= 6.8.8.1-82.1
  • perl-PerlMagick-debuginfo >= 6.8.8.1-82.1
Patchnames:
openSUSE-2018-1181
openSUSE-2018-1312
openSUSE-2019-1320
openSUSE-2019-688


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 ImageMagick Released
SUSE Linux Enterprise Desktop 12 SP4 ImageMagick Released
SUSE Linux Enterprise High Performance Computing 12 ImageMagick Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA ImageMagick Released
SUSE Linux Enterprise Module for Development Tools 15 GA ImageMagick Released
SUSE Linux Enterprise SDK 11 SP4 GraphicsMagick Released
SUSE Linux Enterprise SDK 11 SP4 ImageMagick Released
SUSE Linux Enterprise SDK 12 SP3 ImageMagick Released
SUSE Linux Enterprise SDK 12 SP4 ImageMagick Released
SUSE Linux Enterprise Server 11 SP3 LTSS ImageMagick Affected
SUSE Linux Enterprise Server 11 SP4 ImageMagick Released
SUSE Linux Enterprise Server 12 GA LTSS ImageMagick Released
SUSE Linux Enterprise Server 12 SP1 LTSS ImageMagick Released
SUSE Linux Enterprise Server 12 SP2 LTSS ImageMagick Released
SUSE Linux Enterprise Server 12 SP3 ImageMagick Released
SUSE Linux Enterprise Server 12 SP4 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ImageMagick Released
SUSE Linux Enterprise Workstation Extension 12 SP3 ImageMagick Released
SUSE Linux Enterprise Workstation Extension 12 SP4 ImageMagick Released
SUSE Studio Onsite 1.3 GraphicsMagick Released