Upstream information

CVE-2017-7500 at MITRE

Description

It was found that rpm did not properly handle RPM installations when a destination path was a symbolic link to a directory, possibly changing ownership and permissions of an arbitrary directory, and RPM files being placed in an arbitrary destination. An attacker, with write access to a directory in which a subdirectory will be installed, could redirect that directory to an arbitrary location and gain root privilege.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.2 6.8
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C AV:L/AC:L/Au:S/C:C/I:C/A:C
Access Vector Local Local
Access Complexity Low Low
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.3
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1126909 [RESOLVED / FIXED], 1157882 [NEW], 1157883 [NEW], 943457 [CONFIRMED], 964063 [VERIFIED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/389-ds:1.4.0
Container caasp/v4/busybox:1.26.2
Container caasp/v4/caasp-dex:2.16.0
Container caasp/v4/caaspctl-tooling:beta
Container caasp/v4/cert-exporter:2.3.0
Container caasp/v4/cilium-etcd-operator:2.0.5
Container caasp/v4/cilium-init:1.5.3
Container caasp/v4/cilium-operator:1.6.6
Container caasp/v4/cilium:1.6.6
Container caasp/v4/cloud-provider-openstack:1.15.0
Container caasp/v4/configmap-reload:0.3.0
Container caasp/v4/coredns:1.6.5
Container caasp/v4/curl:7.60.0
Container caasp/v4/etcd:3.4.3
Container caasp/v4/gangway:3.1.0
Container caasp/v4/grafana:6.2.5
Container caasp/v4/helm-tiller:2.16.1
Container caasp/v4/hyperkube:v1.17.4
Container caasp/v4/k8s-sidecar:0.1.75
Container caasp/v4/kube-state-metrics:1.9.3
Container caasp/v4/kubernetes-client:1.17.4
Container caasp/v4/kured:1.3.0
Container caasp/v4/metrics-server:0.3.6
Container caasp/v4/prometheus-alertmanager:0.16.2
Container caasp/v4/prometheus-node-exporter:0.17.0
Container caasp/v4/prometheus-pushgateway:0.6.0
Container caasp/v4/prometheus-server:2.7.1
Container caasp/v4/rsyslog:8.39.0
Container caasp/v4/skuba-tooling:0.1.0
Container caasp/v4/test-update:beta
Container caasp/v4/velero-plugin-for-aws:1.0.1
Container caasp/v4/velero-plugin-for-gcp:1.0.1
Container caasp/v4/velero-plugin-for-microsoft-azure:1.0.1
Container caasp/v4/velero-restic-restore-helper:1.3.1
Container caasp/v4/velero:1.3.1
Container suse/sle15:15.0
Container suse/sle15:15.1
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image caasp4/caasp-389-ds-image
Image caasp4/caasp-busybox-image
Image caasp4/caasp-caasp-dex-image
Image caasp4/caasp-cert-exporter-image
Image caasp4/caasp-cilium-etcd-operator-image
Image caasp4/caasp-cilium-image
Image caasp4/caasp-cilium-init-image
Image caasp4/caasp-cilium-operator-image
Image caasp4/caasp-cloud-provider-openstack-image
Image caasp4/caasp-configmap-reload-image
Image caasp4/caasp-coredns-image
Image caasp4/caasp-curl-image
Image caasp4/caasp-etcd-image
Image caasp4/caasp-gangway-image
Image caasp4/caasp-grafana-image
Image caasp4/caasp-helm-tiller-image
Image caasp4/caasp-hyperkube-image
Image caasp4/caasp-k8s-sidecar-image
Image caasp4/caasp-kube-state-metrics-image
Image caasp4/caasp-kubernetes-client-image
Image caasp4/caasp-kured-image
Image caasp4/caasp-metrics-server-image
Image caasp4/caasp-prometheus-alertmanager-image
Image caasp4/caasp-prometheus-node-exporter-image
Image caasp4/caasp-prometheus-pushgateway-image
Image caasp4/caasp-prometheus-server-image
Image caasp4/caasp-rsyslog-image
Image caasp4/caasp-test-update-image
Image caasp4/caasp-velero-image
Image caasp4/caasp-velero-plugin-for-aws-image
Image caasp4/caasp-velero-plugin-for-gcp-image
Image caasp4/caasp-velero-plugin-for-microsoft-azure-image
Image caasp4/caasp-velero-restic-restore-helper-image
  • rpm >= 4.14.1-10.3.1
Container caasp/v4/default-http-backend:beta1
Container caasp/v4/dnsmasq-nanny:2.78
Container caasp/v4/flannel:0.9.1
Container caasp/v4/haproxy:beta1
Container caasp/v4/kubedns:beta1
Container caasp/v4/nginx-ingress-controller:beta1
Container caasp/v4/openldap:beta1
Container caasp/v4/pause:1.0.0
Container caasp/v4/pv-recycler-node:8.25
Container caasp/v4/sidecar:beta1
Container caasp/v4/velum:4.0.0
Container sles12/caasp-dex:2.7.1
Container suse/sles12sp4:latest
Container suse/sles12sp5:latest
Image sles12sp3-caasp-dex-image
  • rpm >= 4.11.2-16.21.1
Container caasp/v4/salt-api:beta1
Container caasp/v4/salt-master:beta1
Container caasp/v4/salt-minion:beta1
  • rpm >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Openstack Cloud Magnum Orchestration 7
  • rpm >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2373
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2766
SUSE CaaS Platform 3.0
  • rpm >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-CAASP-3.0-2018-2373
SUSE-CAASP-3.0-2018-2766
SUSE CaaS Platform ALL
  • rpm >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-CAASP-ALL-2018-2373
SUSE-CAASP-ALL-2018-2766
SUSE Enterprise Storage 4
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-Storage-4-2018-2766
SUSE Linux Enterprise Desktop 12 SP3
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2373
SUSE-SLE-DESKTOP-12-SP3-2018-2766
SUSE Linux Enterprise Desktop 12 SP4
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2766
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • rpm >= 4.14.1-10.16.1
  • rpm-32bit >= 4.14.1-10.16.1
  • rpm-devel >= 4.14.1-10.16.1
SUSE Linux Enterprise Module for Basesystem 15
  • python-rpm >= 4.14.1-10.3.1
  • python2-rpm >= 4.14.1-10.3.1
  • python3-rpm >= 4.14.1-10.3.1
  • rpm >= 4.14.1-10.3.1
  • rpm-32bit >= 4.14.1-10.3.1
  • rpm-devel >= 4.14.1-10.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1396
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • rpm-build >= 4.14.1-10.16.1
SUSE Linux Enterprise Module for Development Tools 15
  • rpm >= 4.14.1-10.3.1
  • rpm-build >= 4.14.1-10.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-1396
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2766
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2766
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2766
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2766
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2766
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2373
SUSE-SLE-SERVER-12-SP3-2018-2766
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2766
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2766
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1062
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2766
SUSE Linux Enterprise Software Development Kit 12 SP3
  • rpm >= 4.11.2-16.21.1
  • rpm-devel >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2373
SUSE-SLE-SDK-12-SP3-2018-2766
SUSE Linux Enterprise Software Development Kit 12 SP4
  • rpm >= 4.11.2-16.21.1
  • rpm-devel >= 4.11.2-16.21.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2766
SUSE Linux Enterprise Software Development Kit 12 SP5
  • rpm-devel >= 4.11.2-16.21.1
SUSE OpenStack Cloud 7
  • python3-rpm >= 4.11.2-16.21.1
  • rpm >= 4.11.2-16.21.1
  • rpm-32bit >= 4.11.2-16.21.1
  • rpm-build >= 4.11.2-16.21.1
  • rpm-python >= 4.11.2-16.21.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2766
openSUSE Leap 15.0
  • python-rpm >= 4.14.1-lp150.9.3.1
  • python-rpm-debugsource >= 4.14.1-lp150.9.3.1
  • python2-rpm >= 4.14.1-lp150.9.3.1
  • python2-rpm-debuginfo >= 4.14.1-lp150.9.3.1
  • python3-rpm >= 4.14.1-lp150.9.3.1
  • python3-rpm-debuginfo >= 4.14.1-lp150.9.3.1
  • rpm >= 4.14.1-lp150.9.3.1
  • rpm-32bit >= 4.14.1-lp150.9.3.1
  • rpm-32bit-debuginfo >= 4.14.1-lp150.9.3.1
  • rpm-build >= 4.14.1-lp150.9.3.1
  • rpm-build-debuginfo >= 4.14.1-lp150.9.3.1
  • rpm-debuginfo >= 4.14.1-lp150.9.3.1
  • rpm-debugsource >= 4.14.1-lp150.9.3.1
  • rpm-devel >= 4.14.1-lp150.9.3.1
Patchnames:
openSUSE-2019-564
openSUSE Leap 42.3
  • python3-rpm >= 4.11.2-14.10.1
  • python3-rpm-debuginfo >= 4.11.2-14.10.1
  • python3-rpm-debugsource >= 4.11.2-14.10.1
  • rpm >= 4.11.2-14.10.1
  • rpm-32bit >= 4.11.2-14.10.1
  • rpm-build >= 4.11.2-14.10.1
  • rpm-build-debuginfo >= 4.11.2-14.10.1
  • rpm-debuginfo >= 4.11.2-14.10.1
  • rpm-debuginfo-32bit >= 4.11.2-14.10.1
  • rpm-debugsource >= 4.11.2-14.10.1
  • rpm-devel >= 4.11.2-14.10.1
  • rpm-python >= 4.11.2-14.10.1
  • rpm-python-debuginfo >= 4.11.2-14.10.1
  • rpm-python-debugsource >= 4.11.2-14.10.1
Patchnames:
openSUSE-2018-1246


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration rpm Released
SUSE CaaS Platform 3.0 rpm Released
SUSE Container as a Service Platform 2.0 rpm Released
SUSE Linux Enterprise 15 Module for Basesystem rpm Released
SUSE Linux Enterprise 15 Module for Development Tools rpm Released
SUSE Linux Enterprise Desktop 11 SP3 rpm Affected
SUSE Linux Enterprise Desktop 11 SP4 rpm Affected
SUSE Linux Enterprise Desktop 12 rpm Affected
SUSE Linux Enterprise Desktop 12 SP3 rpm Released
SUSE Linux Enterprise Desktop 12 SP4 rpm Released
SUSE Linux Enterprise High Performance Computing 12 SP4 rpm Released
SUSE Linux Enterprise High Performance Computing 12 SP5 python3-rpm Released
SUSE Linux Enterprise High Performance Computing 12 SP5 rpm Released
SUSE Linux Enterprise High Performance Computing 12 SP5 rpm-python Released
SUSE Linux Enterprise Server 11 SP3 rpm Affected
SUSE Linux Enterprise Server 11 SP3 for VMware rpm Affected
SUSE Linux Enterprise Server 11 SP4 rpm Affected
SUSE Linux Enterprise Server 12 rpm Affected
SUSE Linux Enterprise Server 12 LTSS rpm Released
SUSE Linux Enterprise Server 12 SP1 LTSS rpm Released
SUSE Linux Enterprise Server 12 SP2 LTSS rpm Released
SUSE Linux Enterprise Server 12 SP3 rpm Released
SUSE Linux Enterprise Server 12 SP4 rpm Released
SUSE Linux Enterprise Server 12 SP5 python3-rpm Released
SUSE Linux Enterprise Server 12 SP5 rpm Released
SUSE Linux Enterprise Server 12 SP5 rpm-python Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 rpm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 rpm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rpm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python3-rpm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rpm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rpm-python Released
SUSE Linux Enterprise Software Development Kit 11 SP3 rpm Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 rpm Affected
SUSE Linux Enterprise Software Development Kit 12 rpm Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 rpm Released
SUSE Linux Enterprise Software Development Kit 12 SP4 rpm Released
SUSE Manager Proxy 4.0 Module rpm Affected
SUSE Manager Server 4.0 Module rpm Affected