Upstream information

CVE-2014-3532 at MITRE

Description

dbus 1.3.0 before 1.6.22 and 1.8.x before 1.8.6, when running on Linux 2.6.37-rc4 or later, allows local users to cause a denial of service (system-bus disconnect of other services or applications) by sending a message containing a file descriptor, then exceeding the maximum recursion depth before the initial message is forwarded.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 885241 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • dbus-1 >= 1.8.16-14.1
  • dbus-1-x11 >= 1.8.16-14.1
  • libdbus-1-3 >= 1.8.16-14.1
  • libdbus-1-3-32bit >= 1.8.16-14.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
  • dbus-1 >= 1.8.16-19.1
  • dbus-1-x11 >= 1.8.16-19.1
  • libdbus-1-3 >= 1.8.16-19.1
  • libdbus-1-3-32bit >= 1.8.16-19.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • dbus-1 >= 1.8.22-28.19
  • dbus-1-x11 >= 1.8.22-28.19
  • libdbus-1-3 >= 1.8.22-28.14
  • libdbus-1-3-32bit >= 1.8.22-28.14
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • dbus-1 >= 1.8.22-29.10.2
  • dbus-1-x11 >= 1.8.22-29.10.2
  • libdbus-1-3 >= 1.8.22-29.10.2
  • libdbus-1-3-32bit >= 1.8.22-29.10.2
SUSE Linux Enterprise Desktop 12
  • dbus-1 >= 1.8.8-1.5
  • dbus-1-x11 >= 1.8.8-1.5
  • libdbus-1-3 >= 1.8.8-1.12
  • libdbus-1-3-32bit >= 1.8.8-1.12
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • dbus-1 >= 1.8.22-9.38
  • dbus-1-x11 >= 1.8.22-9.38
  • libdbus-1-3 >= 1.8.22-9.28
  • libdbus-1-3-32bit >= 1.8.22-9.28
SUSE Linux Enterprise Module for Basesystem 15
  • dbus-1 >= 1.12.2-1.76
  • dbus-1-devel >= 1.12.2-1.76
  • dbus-1-x11 >= 1.12.2-1.23
  • libdbus-1-3 >= 1.12.2-1.76
  • libdbus-1-3-32bit >= 1.12.2-1.76
SUSE Linux Enterprise Server 12
  • dbus-1 >= 1.8.8-1.5
  • dbus-1-x11 >= 1.8.8-1.5
  • libdbus-1-3 >= 1.8.8-1.5
  • libdbus-1-3-32bit >= 1.8.8-1.12
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • dbus-1 >= 1.8.16-19.1
  • dbus-1-x11 >= 1.8.16-19.1
  • libdbus-1-3 >= 1.8.16-19.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • dbus-1-devel >= 1.8.16-14.1
  • dbus-1-devel-doc >= 1.8.16-14.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • dbus-1-devel >= 1.8.16-19.1
  • dbus-1-devel-doc >= 1.8.16-19.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • dbus-1-devel >= 1.8.22-28.14
  • dbus-1-devel-doc >= 1.8.22-28.19
SUSE Linux Enterprise Software Development Kit 12 SP4
  • dbus-1-devel >= 1.8.22-29.10.2
  • dbus-1-devel-doc >= 1.8.22-29.10.2
SUSE Linux Enterprise Software Development Kit 12 SP5
  • dbus-1-devel >= 1.8.22-9.28
  • dbus-1-devel-doc >= 1.8.22-9.38
SUSE Linux Enterprise Software Development Kit 12
  • dbus-1-devel >= 1.8.8-1.12
  • dbus-1-devel-doc >= 1.8.8-1.5
openSUSE 13.1
  • dbus-1 >= 1.7.4-4.16.2
  • dbus-1-debuginfo >= 1.7.4-4.16.2
  • dbus-1-debuginfo-32bit >= 1.7.4-4.16.2
  • dbus-1-debugsource >= 1.7.4-4.16.1
  • dbus-1-devel >= 1.7.4-4.16.1
  • dbus-1-devel-32bit >= 1.7.4-4.16.1
  • dbus-1-devel-doc >= 1.7.4-4.16.2
  • dbus-1-x11 >= 1.7.4-4.16.2
  • dbus-1-x11-debuginfo >= 1.7.4-4.16.2
  • dbus-1-x11-debugsource >= 1.7.4-4.16.2
  • libdbus-1-3 >= 1.7.4-4.16.1
  • libdbus-1-3-32bit >= 1.7.4-4.16.1
  • libdbus-1-3-debuginfo >= 1.7.4-4.16.1
  • libdbus-1-3-debuginfo-32bit >= 1.7.4-4.16.1
Patchnames:
openSUSE-2014-465
openSUSE Leap 15.0
  • dbus-1 >= 1.12.2-lp150.1.28
  • dbus-1-x11 >= 1.12.2-lp150.1.3
  • libdbus-1-3 >= 1.12.2-lp150.1.28
Patchnames:
openSUSE Leap 15.0 GA dbus-1
openSUSE Leap 42.1
  • dbus-1 >= 1.8.16-5.9
  • dbus-1-devel >= 1.8.16-5.2
  • dbus-1-x11 >= 1.8.16-5.9
  • libdbus-1-3 >= 1.8.16-5.2
  • libdbus-1-3-32bit >= 1.8.16-5.2
Patchnames:
openSUSE Leap 42.1 GA dbus-1
openSUSE Leap 42.2
  • dbus-1 >= 1.8.22-1.1
  • dbus-1-devel >= 1.8.22-1.1
  • dbus-1-x11 >= 1.8.22-1.1
  • libdbus-1-3 >= 1.8.22-1.1
  • libdbus-1-3-32bit >= 1.8.22-1.1
Patchnames:
openSUSE Leap 42.2 GA dbus-1
openSUSE Leap 42.3
  • dbus-1 >= 1.8.22-5.2
  • dbus-1-devel >= 1.8.22-5.1
  • dbus-1-x11 >= 1.8.22-5.2
  • libdbus-1-3 >= 1.8.22-5.1
  • libdbus-1-3-32bit >= 1.8.22-5.1
Patchnames:
openSUSE Leap 42.3 GA dbus-1
openSUSE Tumbleweed
  • dbus-1 >= 1.10.12-2.1
  • dbus-1-devel >= 1.10.12-2.1
  • dbus-1-devel-32bit >= 1.10.12-2.1
  • dbus-1-devel-doc >= 1.10.12-2.1
  • dbus-1-x11 >= 1.10.12-2.1
  • libdbus-1-3 >= 1.10.12-2.1
  • libdbus-1-3-32bit >= 1.10.12-2.1
Patchnames:
openSUSE Tumbleweed GA dbus-1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 dbus-1 Released
SLED-10-SP4 dbus-1 Released
SLES-10-SP3 dbus-1 Released
SLES-10-SP4 dbus-1 Released
SLES_LTSS-10-SP4 dbus-1 Released
SUSE Linux Enterprise Desktop 11 SP3 dbus-1 Released
SUSE Linux Enterprise Server 11 SP3 dbus-1 Released
SUSE Linux Enterprise Server 11 SP3 for VMware dbus-1 Released
SUSE Linux Enterprise Software Development Kit 11 SP3 dbus-1 Released