Upstream information

CVE-2014-0017 at MITRE

Description

The RAND_bytes function in libssh before 0.6.3, when forking is enabled, does not properly reset the state of the OpenSSL pseudo-random number generator (PRNG), which causes the state to be shared between children processes and allows local users to obtain sensitive information by leveraging a pid collision.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 866278 [VERIFIED / FIXED], 866286 [RESOLVED / INVALID]

SUSE Security Advisories:

  • SUSE-SU-2014:0413-1, published Thu Mar 20 23:04:08 MDT 2014
  • openSUSE-SU-2014:0366-1 openSUSE-SU-2014:0370-1

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libssh2 >= 0.2-5.20.1
Patchnames:
sdksp3-libssh2
sledsp3-libssh2
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libssh2 >= 0.2-5.20.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libssh2-0.2-5.20.1
SUSE Linux Enterprise Desktop 12 SP1
  • libssh-devel >= 0.6.3-8.1
  • libssh-devel-doc >= 0.6.3-8.1
  • libssh4 >= 0.6.3-8.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libssh4-0.6.3-8.1
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libssh-devel-0.6.3-8.1
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libssh4-0.6.3-8.1
SUSE Linux Enterprise Desktop 12 SP2
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Desktop 12 SP3
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Desktop 12 SP4
  • libssh-devel >= 0.6.3-12.6.1
  • libssh-devel-doc >= 0.6.3-12.6.1
  • libssh4 >= 0.6.3-12.6.1
  • libssh4-32bit >= 0.6.3-12.6.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libssh4-0.6.3-12.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libssh-devel-0.6.3-12.6.1
SUSE Linux Enterprise Desktop 12
  • libssh-devel >= 0.6.3-1.4
  • libssh-devel-doc >= 0.6.3-1.4
  • libssh4 >= 0.6.3-1.4
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libssh4-0.6.3-1.4
SUSE Linux Enterprise Software Development Kit 12 GA libssh-devel-0.6.3-1.4
SUSE Linux Enterprise Workstation Extension 12 GA libssh4-0.6.3-1.4
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libssh-devel >= 0.7.5-4.16
  • libssh4 >= 0.7.5-4.16
  • libssh4-32bit >= 0.7.5-4.16
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libssh-devel-0.7.5-4.16
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libssh4 >= 0.8.7-1.31
  • libssh4-32bit >= 0.8.7-1.31
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libssh4-0.8.7-1.31
SUSE Linux Enterprise Micro 6.0
  • libssh-config >= 0.10.6-1.12
  • libssh4 >= 0.10.6-1.12
Patchnames:
SUSE Linux Enterprise Micro 6.0 GA libssh-config-0.10.6-1.12
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2 >= 0.2-5.20.1
Patchnames:
sdksp3-libssh2
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libssh-devel >= 0.6.3-8.1
  • libssh-devel-doc >= 0.6.3-8.1
  • libssh4 >= 0.6.3-8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libssh-devel-0.6.3-8.1
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libssh4-0.6.3-8.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Server 12 SP4
  • libssh-devel >= 0.6.3-12.6.1
  • libssh-devel-doc >= 0.6.3-12.6.1
  • libssh4 >= 0.6.3-12.6.1
  • libssh4-32bit >= 0.6.3-12.6.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libssh4-0.6.3-12.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libssh-devel-0.6.3-12.6.1
SUSE Linux Enterprise Server 12 SP5
  • libssh-devel >= 0.8.7-1.31
  • libssh-devel-doc >= 0.6.3-12.6.1
  • libssh4 >= 0.8.7-1.31
  • libssh4-32bit >= 0.8.7-1.31
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libssh4-0.8.7-1.31
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libssh-devel-0.8.7-1.31
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libssh-devel >= 0.6.3-1.4
  • libssh-devel-doc >= 0.6.3-1.4
  • libssh4 >= 0.6.3-1.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libssh-devel-0.6.3-1.4
SUSE Linux Enterprise Workstation Extension 12 GA libssh4-0.6.3-1.4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libssh-devel >= 0.6.3-12.6.1
  • libssh-devel-doc >= 0.6.3-12.6.1
  • libssh4 >= 0.6.3-12.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libssh-devel-0.6.3-12.6.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libssh-devel >= 0.8.7-1.31
  • libssh-devel-doc >= 0.6.3-12.6.1
  • libssh4 >= 0.8.7-1.31
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libssh-devel-0.8.7-1.31
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libssh-devel >= 0.6.3-8.1
  • libssh-devel-doc >= 0.6.3-8.1
  • libssh4 >= 0.6.3-8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libssh-devel-0.6.3-8.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libssh-devel >= 0.6.3-11.1
  • libssh-devel-doc >= 0.6.3-11.1
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libssh-devel-0.6.3-11.1
SUSE Linux Enterprise Software Development Kit 12
  • libssh-devel >= 0.6.3-1.4
  • libssh-devel-doc >= 0.6.3-1.4
  • libssh4 >= 0.6.3-1.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libssh-devel-0.6.3-1.4
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libssh4 >= 0.6.3-8.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libssh4-0.6.3-8.1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libssh4 >= 0.6.3-11.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libssh4-0.6.3-11.1
SUSE Linux Enterprise Workstation Extension 12
  • libssh4 >= 0.6.3-1.4
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libssh4-0.6.3-1.4
openSUSE Leap 15.0
  • libssh4 >= 0.7.5-lp150.4.1
  • libssh4-32bit >= 0.7.5-lp150.4.1
Patchnames:
openSUSE Leap 15.0 GA libssh4-0.7.5-lp150.4.1
openSUSE Tumbleweed
  • libssh-devel >= 0.7.2-2.1
  • libssh-devel-doc >= 0.7.2-2.1
  • libssh4 >= 0.7.2-2.1
  • libssh4-32bit >= 0.7.2-2.1
Patchnames:
openSUSE-Tumbleweed-2024-10036


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12 SP5 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 libssh Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 15-ESPOS libssh Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP3 libssh Released
SUSE Linux Enterprise Desktop 11 SP4 libssh Affected
SUSE Linux Enterprise Desktop 12 libssh Already fixed
SUSE Linux Enterprise Desktop 12 SP1 libssh Already fixed
SUSE Linux Enterprise Desktop 12 SP2 libssh Already fixed
SUSE Linux Enterprise Desktop 12 SP3 libssh Already fixed
SUSE Linux Enterprise Desktop 12 SP4 libssh Already fixed
SUSE Linux Enterprise Desktop 15 libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15 libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS libssh Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS libssh Already fixed
SUSE Linux Enterprise Module for Basesystem 15 libssh Already fixed
SUSE Linux Enterprise Server 11 SP3 libssh Released
SUSE Linux Enterprise Server 11 SP4 libssh Affected
SUSE Linux Enterprise Server 12 libssh Already fixed
SUSE Linux Enterprise Server 12 SP1 libssh Already fixed
SUSE Linux Enterprise Server 12 SP2 libssh Already fixed
SUSE Linux Enterprise Server 12 SP3 libssh Already fixed
SUSE Linux Enterprise Server 12 SP4 libssh Already fixed
SUSE Linux Enterprise Server 12 SP4-ESPOS libssh Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS libssh Already fixed
SUSE Linux Enterprise Server 15 libssh Already fixed
SUSE Linux Enterprise Server 15-LTSS libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libssh Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP3 libssh Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libssh Affected
SUSE Linux Enterprise Software Development Kit 12 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP1 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP2 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 libssh Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP4 libssh Already fixed
SUSE Linux Enterprise Workstation Extension 12 libssh Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP1 libssh Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP2 libssh Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP3 libssh Already fixed
SUSE OpenStack Cloud 9 libssh Already fixed
SUSE OpenStack Cloud Crowbar 9 libssh Already fixed


SUSE Timeline for this CVE

CVE page created: Fri Feb 28 15:16:02 2014
CVE page last modified: Sat Jun 15 22:04:58 2024