LibreOffice.org Quick Start

SUSE Linux Enterprise Desktop 11 SP3

Publication Date 10 Jun 2013


Contents

1. Compatibility
2. LibreOffice Modules
3. Starting LibreOffice
4. LibreOffice Writer
5. LibreOffice Calc
6. Other LibreOffice Modules
7. For More Information
8. Legal Notice
9. GNU Free Documentation License

Abstract

LibreOffice—formerly known as OpenOffice.org—is a powerful open-source office suite that provides tools for all types of office tasks such as writing texts, working with spreadsheets, creating graphics and presentations, or designing scientific formulas. With LibreOffice, you can use the same data across different computing platforms. You can also open and edit files in other formats, including Microsoft Office, then save them back to this format.

For a full list of new core features available with LibreOffice 3.4, refer to http://www.libreoffice.org/download/3-4-new-features-and-fixes/.

1. Compatibility

LibreOffice can work with documents, spreadsheets, presentations, and databases in many other formats, including Microsoft Office™. They can be seamlessly opened like other files and saved back to the original format. Though some work has already been invested in interoperability, occasionally there are still formatting issues. If you have problems with your documents, consider opening them in the original application and resaving them in an open format such as RTF for text documents. In case of migration problems with spreadsheets however, it is advisable to resave them as Excel files and use this as intermediate format (with CSV format you would lose all cell formatting and CSV sometimes leads to incorrect cell type detection for spreadsheets).

2. LibreOffice Modules

LibreOffice consists of several application modules (subprograms), which are designed to interact with each other. All modules feature the same graphical user interface and similar functionality.

Table 1. The LibreOffice Modules

Module

Usage

Writer

Text document module

Calc

Spreadsheet module

Impress

Presentation module

Base

Database module

Draw

Vector graphics module

Math

Mathematical equation module


3. Starting LibreOffice

To start the LibreOffice suite, press Alt+F2, type libreoffice and press Enter. In the Welcome dialog, select the module you want to open. If an LibreOffice application is open, you can start any of the other applications by clicking File+New+Name of Application.

3.1. Saving LibreOffice Files

  1. To save a new file, select File+Save or Save as from the Menu Bar or use the shortcut Ctrl+Shift+S.

  2. Select the directory where you want to save the file.

  3. Enter the filename in the Name box.

  4. From the File Type box, select the format in which you want to save the file.

In all modules you can save your documents as native LibreOffice files, LibreOffice templates, Microsoft files and StarOffice files.

3.2. Navigator and Navigation Shortcuts

The Navigator tool displays information about the contents of a document. It also lets you quickly jump to different elements. For example, you can use the Navigator to get a quick overview of all images included in the document. To open the Navigator, click View+Navigator or with F5. The elements listed in the Navigator vary according to the LibreOffice module being used.

You can also navigate your files with the following shortcuts:

Table 2. Navigation Shortcuts

Action

Shortcut

Delete to the End of the Word

Ctrl+Del

Delete to the Beginning of the Word

Ctrl+<—

End of Document

Ctrl+End

End of Line

End

Select All

Ctrl+A

Start of Line

Home

Top of Document

Ctrl+Home

Word Left

Ctrl+

Word Right

Ctrl+


3.3. Using and Creating Templates

LibreOffice comes with a set of predefined templates, and you can find additional templates on the Internet. If you want to create your own templates, you need to determine what you want the document to look like and create the styles you need in that template.

For text document, spreadsheets, presentations, and drawings, you can easily create a template from an existing document as follows:

  1. Start LibreOffice and open or create a document that contains the styles that you want to use as a template.

  2. Click File+Templates+Save.

  3. Specify a name for the template.

  4. In the Categories box, click the category where you want to place the template.

  5. Click OK.

4. LibreOffice Writer

LibreOffice Writer is a full-featured word processor with page and text-formatting capabilities. It also includes some features that are usually found only in expensive desktop publishing applications. Many of the LibreOffice Writer features apply also to other LibreOffice modules.

4.1. Creating a New Document

LibreOffice Writer allows you to create a new document in one of the following ways:

  • From Scratch.  To create a document from scratch, click File+New+Text Document and a new empty Writer document is created.

  • Wizard.  To use a standard format and predefined elements for your own documents use a wizard. Click File+Wizards+Letter... and follow the steps.

  • Templates.  To use a template, click File+New+Templates and Documents and choose one of the many folders (for example, Business Correspondence) and a new document based on the style of your selected template is created.

To use a standard format and predefined elements for your own documents, try a wizard (a small utility that lets you make some basic initial decisions and then produces a ready-made document from a template). For example, to create a business letter, click File+Wizards+Letter. With the wizard's dialogs, you can create a basic document that uses a standard format.

Enter text in the document window as desired. Use the Formatting toolbar or the Format menu to adjust the appearance of the document. Use the File menu or the relevant buttons in the toolbar to print and save your document. With the options under Insert, add extra items to your document, such as a table, picture, or chart.

4.2. Customizing LibreOffice

With LibreOffice you can customize the default settings with the Format menu.

Below is a list of the most popular options available in most modules:

Customizing Character Settings

To set all character elements at the same time, select Format+Character.

Customizing Paragraph Settings

To format paragraphs, select Format+Paragraph and select the appropriate tabs for making changes.

Customizing Alignment

To modify the alignment, select Format+Paragraph and choose the alignment you want.

Inserting Headers and Footers

If you want to add headers and footers, click Insert and select either Header or Footer.

Inserting Special Characters

If you want to insert special characters, select Insert+Special Character.

Inserting Footnotes

If you want to insert footnotes, click Insert and select Footnote.

Inserting Columns

If you want to insert columns, click Insert and select Section. Then in the Columns tab, specify the number of columns to use for the current section.

Inserting Indexes and Table of Contents

If you want to insert indexes or a table of contents, click Insert and select Indexes and Tables.

The Object Toolbar offers additional text formatting options.

Inserting Comments

If you want to comment your text for others or for yourself, click Insert+Comment.

4.3. Using Master Documents

If you are working with a very large document (such as a book), you might find it easier to manage the book with a master document, rather than keeping the book in a single file. A master document enables you to quickly apply formatting changes to a large document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for multiple Writer files. You can maintain chapters or other subdocuments as individual files collected in the master document. Master documents are also useful if multiple people are working on a document. You can separate each person’s relevant part of the document into subdocuments, allowing multiple writers to work on their subdocuments at the same time without the danger of overwriting each other’s work.

  1. Click New+Master Document.

    or

    Open an existing document and click File+Send+Create Master Document.

  2. Insert subdocuments.

  3. Click File Save.

The LibreOffice help files contain more complete information about working with master documents. Look for the topic entitled Working with Master Documents and Subdocuments.

4.4. Using Writer as HTML Editor

In addition to being a full-featured word processor, Writer also functions as an HTML editor. Writer includes HTML tags that can be applied the same way as any other style in a Writer document. You can view the document as it will appear online, or you can directly edit the HTML code.

  1. Click File+New+HTML Document.

  2. Press F11 to open the Styles and Formatting window.

  3. Click the arrow at the bottom of the Styles and Formatting window.

  4. Select HTML Styles.

  5. Create your HTML document, using the styles to tag your text.

  6. Click File+Save As.

  7. Select the location where you want to save your file, name the file, and select HTML Document (.html) from the File Type list.

  8. Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created when you edited the HTML file as a Writer document, click View+HTML Source. In HTML Source mode, the Formatting and Styles list is not available. The first time you switch to HTML Source mode, you are prompted to save the file as HTML, if you have not already done so.

4.5. Tables

You can include tabular data in the Writer, Impress and Draw module. Insert basic tables directly into your document either with the following menus items or by using the toolbar:

  • Insert+Table,

  • Table+Insert+Table,

  • or use the Table icon.

To enter data, select a cell with your mouse pointer and begin typing. To move around cells, use the arrow keys. →| moves to the next cell, skipping over the contents of the cell and Shift+→| moves backwards.

You can use Table menu or the Table toolbar to modify the table.

5. LibreOffice Calc

Calc is the LibreOffice spreadsheet and data-plotting module. Spreadsheets consist of a number of sheets, containing cells which can be filled with elements like text, numbers, or formulas. A formula can manipulate data from other cells to generate a value for the cell into which it is inserted. Calc also allows you to define ranges, filter and sort the data, or create charts from the data to present it graphically. By using DataPilots, you can combine, analyze or compare larger amounts of data.

As with the entire LibreOffice suite, Calc can be used across a variety of platforms. It provides a number of exchange formats (including export to PDF documents), and can also read and save files in Microsoft Excel's format.

5.1. Creating a New Document

Start LibreOffice and select File+New+Spreadsheet to create a new spreadsheet. Access the individual sheets by clicking the respective tabs at the bottom of the window.

Enter data in the cells as desired. To adjust appearance, either use the Formatting toolbar or the Format menu—or define styles. Use the File menu or the relevant buttons in the toolbar to print and save your document.

5.2. Customizing LibreOffice Calc

Calc comes with a few built-in cell and page styles to improve the appearance of your spreadsheets and reports. Although these built-in styles are adequate for many uses, you will probably find it useful to create styles for your own frequently-used formatting preferences.

Procedure 17. Creating a Style

  1. Click Format+Styles and Formatting.

  2. In the Styles and Formatting window, click one of the icons representing either Paragraph Styles, Character Styles, or Page Styles icon.

  3. Right-click in the Styles and Formatting window, then click New.

  4. Specify a name for your style and use the various tabs to set the desired formatting options.

  5. Click OK.

Procedure 18. Modifying a Style

  1. Click Format+Styles and Formatting.

  2. In the Styles and Formatting window, click either the Cell Styles or the Page Styles icon.

  3. Right-click the name of the style you want to change, then click Modify.

  4. Change the desired formatting options.

  5. Click OK.

6. Other LibreOffice Modules

Besides LibreOffice Writer and LibreOffice Calc, LibreOffice also includes the modules Impress, Base, Draw, and Math. With these you can create presentations, design databases, draw up graphics and diagrams and create mathematical formulas.

6.1. Using Presentations with Impress

Use LibreOffice Impress to create presentations for screen display or printing, such as slide shows or transparencies. If you have used other presentation software, you can move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can exchange presentations with Powerpoint users, as long as you save your presentations in Powerpoint format.

LibreOffice allows you to use 3D transitions for your slides. Access the available transitions by selecting Slide Show+Slide Transitions.

You can either create a brand new presentation (without any preformatted slides) or use an existing template or presentation for your new document. Impress uses styles and templates the same way other LibreOffice modules do. A wizard leads you through the options available for creating new presentations.

6.2. Using Databases with Base

LibreOffice includes a database module (Base). Use Base to design a database to store many different kinds of information, from a simple address book or recipe file to a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or using convenient wizards. For example, the Table Wizard contains a number of common fields for business and personal use. A wizard guides you through the steps to create a new database.

LibreOffice Base comes with several predefined database fields to help you create a database. A wizard guides you through the steps to create a new database. The following steps are specific to creating an address book using predefined fields, but it should be easy to use the predefined fields for any of the built-in database options. The process for creating a database can be broken into several subprocesses:

Procedure 19. Creating a Database

  1. Click File+New+Database.

  2. Select Create a new database Next.

  3. Click Yes, register the database for me to make your database information available to other LibreOffice modules, select both check boxes in the bottom half of the dialog, then click Finish.

  4. Browse to the directory where you want to save the database, specify a name for the database, then click OK.

Procedure 20. Setting Up the Database Table

  1. In the Table Wizard, click Personal.

  2. The Sample tables list changes to show the predefined tables for personal use. If you had clicked Business, the list would contain predefined business tables.

    In the Sample tables list, click Addresses. The available fields for the predefined address book appear in the Available fields menu.

  3. In the Available fields menu, click the fields you want to use in your address book.

    You can select one item at a time, or you can shift-click multiple items to select them.

  4. Click the single arrow icon to move the selected items to the Selected fields menu.

    To move all available fields to the Selected fields menu, click the double right- arrow.

  5. Use the arrow keys to adjust the order of the selected fields.

    The fields appear in the table and forms in the order in which they are listed.

6.3. Creating Graphics with Draw

Use LibreOffice Draw to create graphics and diagrams. You can save your drawings in today’s most common formats and import them into any application that lets you import graphics, including the other LibreOffice modules. You can also create Flash versions of your drawings.

LibreOffice allows you to import Scalable Vector Graphics (*.svg) and WordPerfect Graphics (*.wpg). Select File+Open and use the Filter drop-down list to view which file formats can be opened.

Procedure 21. Creating a Graphic

  1. Click Alt+F2 and enter oodraw to open LibreOffice Draw.

  2. Use the toolbar at the bottom of the window to create a graphic.

  3. Save the graphic.

To embed an existing Draw graphic into an LibreOffice document, select Insert+Object+OLE Object. Select Create from file and click Search to navigate to the Draw file to insert. If you insert a file as OLE object, you can easily edit the object later by double-clicking it.

Procedure 22. Opening Draw From Other LibreOffice Modules

One particularly useful feature of Draw is the ability to open it from other LibreOffice modules so you can create a drawing that is automatically imported into your document.

  1. From an LibreOffice module (for example, from Writer), click Insert+Object+OLE Object+LibreOffice 3.x Drawing+OK. This opens Draw.

  2. Create your drawing.

  3. Click in your document, outside the Draw frame.

    The drawing is automatically inserted into your document.

6.4. Creating Mathematical Formulas with Math

It is usually difficult to include complex mathematical formulas in your documents. The LibreOffice Math equation editor lets you create formulas using operators, functions, and formatting assistants. You can then save those formulas as objects that can be imported into other documents. Math functions can be inserted into other LibreOffice documents like any other graphic object.

Using Math, you can enter your equation in three different ways:

  • Type markup in the equation editor,

  • Right-click on the equation editor and select the symbol from the context menu,

    or

  • Select a symbol from the Selection toolbox.

[Note]

Math is not a calculator. The functions it creates are graphical objects. Even if they are imported into Calc, these functions cannot be evaluated.

7. For More Information

This guide gave you a short introduction to the LibreOffice suite. To discover more, refer to Application Guide (↑Application Guide) and the other manuals available for SUSE Linux Enterprise Desktop at http://www.suse.com/doc/sled11/.

LibreOffice also contains extensive online help. In addition, a large community of users and developers support it. For more details, see the following links:

http://www.libreoffice.org/download/3-4-new-features-and-fixes/

A list of all new features available with LibreOffice.

http://www.libreoffice.org/get-help/documentation/

Official LibreOffice support page, provides manuals and other documentation

http://www.taming-openoffice-org.com/

Taming LibreOffice: Books, news, tips and tricks.

8. Legal Notice

Copyright© 2006–2013 SUSE LLC and contributors. All rights reserved.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or (at your option) version 1.3; with the Invariant Section being this copyright notice and license. A copy of the license version 1.2 is included in the section entitled GNU Free Documentation License.

For SUSE and Novell trademarks, see the Novell Trademark and Service Mark list http://www.novell.com/company/legal/trademarks/tmlist.html. All other third party trademarks are the property of their respective owners. A trademark symbol (®, ™ etc.) denotes a SUSE or Novell trademark; an asterisk (*) denotes a third party trademark.

All information found in this book has been compiled with utmost attention to detail. However, this does not guarantee complete accuracy. Neither SUSE LLC, its affiliates, the authors, nor the translators shall be held liable for possible errors or the consequences thereof.

9. GNU Free Documentation License

Copyright (C) 2000, 2001, 2002 Free Software Foundation, Inc. 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA. Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document "free" in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The "Document", below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as "you". You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, "Title Page" means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

  1. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.

  2. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.

  3. State on the Title page the name of the publisher of the Modified Version, as the publisher.

  4. Preserve all the copyright notices of the Document.

  5. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

  6. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.

  7. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.

  8. Include an unaltered copy of this License.

  9. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled "History" in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

  10. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the "History" section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

  11. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.

  12. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.

  13. Delete any section Entitled "Endorsements". Such a section may not be included in the Modified Version.

  14. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title with any Invariant Section.

  15. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of your Modified Version by various parties--for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original documents, forming one section Entitled "History"; likewise combine any sections Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete all sections Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License "or any later version" applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents
   Copyright (c) YEAR YOUR NAME.
   Permission is granted to copy, distribute and/or modify this document
   under the terms of the GNU Free Documentation License, Version 1.2
   or any later version published by the Free Software Foundation;
   with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
   A copy of the license is included in the section entitled “GNU
   Free Documentation License”.
  

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

   with the Invariant Sections being LIST THEIR TITLES, with the
   Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.
  

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.