# Contents

## About This Guide

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>vii</td>
</tr>
</tbody>
</table>

## Part I Introduction

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Getting Started with the GNOME Desktop</td>
</tr>
<tr>
<td>2</td>
<td>Working with Your Desktop</td>
</tr>
</tbody>
</table>

### 1 Getting Started with the GNOME Desktop

<table>
<thead>
<tr>
<th>Subsection</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1 Logging In and Selecting a Desktop</td>
<td>3</td>
</tr>
<tr>
<td>1.2 Logging Out</td>
<td>6</td>
</tr>
<tr>
<td>1.3 Desktop Basics</td>
<td>7</td>
</tr>
</tbody>
</table>

### 2 Working with Your Desktop

<table>
<thead>
<tr>
<th>Subsection</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1 Using the Main Menu</td>
<td>13</td>
</tr>
<tr>
<td>2.2 Managing Folders and Files with Nautilus</td>
<td>17</td>
</tr>
<tr>
<td>2.3 Accessing Floppy Disks, CDs, or DVDs</td>
<td>22</td>
</tr>
<tr>
<td>2.4 Searching for Files</td>
<td>22</td>
</tr>
<tr>
<td>2.5 Moving Text Between Applications</td>
<td>28</td>
</tr>
<tr>
<td>2.6 Managing Internet Connections</td>
<td>28</td>
</tr>
<tr>
<td>2.7 Exploring the Internet</td>
<td>28</td>
</tr>
<tr>
<td>2.8 E-mail and Scheduling</td>
<td>29</td>
</tr>
<tr>
<td>2.9 Opening or Creating Documents with OpenOffice.org</td>
<td>30</td>
</tr>
<tr>
<td>2.10 Controlling Your Desktop’s Power Management</td>
<td>30</td>
</tr>
<tr>
<td>2.11 Creating, Displaying, and Decompressing Archives</td>
<td>36</td>
</tr>
<tr>
<td>2.12 Taking Screen Shots</td>
<td>41</td>
</tr>
<tr>
<td>2.13 Viewing PDF Files</td>
<td>41</td>
</tr>
<tr>
<td>2.14 Controlling Sound</td>
<td>42</td>
</tr>
<tr>
<td>2.15 Using the Fingerprint Reader</td>
<td>44</td>
</tr>
<tr>
<td>2.16 Obtaining Software Updates</td>
<td>44</td>
</tr>
<tr>
<td>2.17 For More Information</td>
<td>44</td>
</tr>
</tbody>
</table>
3 Customizing Your Settings

3.1 The Control Center ................................................................. 46
3.2 Hardware ................................................................. 48
3.3 Look and Feel ................................................................. 52
3.4 Personal ................................................................. 71
3.5 System ................................................................. 73

4 Assistive Technologies ................................................................. 85

4.1 General Accessibility Features ................................................................. 85
4.2 Mobility Impairments ................................................................. 88
4.3 Orca ................................................................. 91

Part II Internet Connectivity, Files and Resources ................................................................. 95

5 Accessing Network Resources ................................................................. 97

5.1 Connecting to Your Network ................................................................. 98
5.2 General Notes on File Sharing and Network Browsing ................................................................. 98
5.3 Accessing Network Shares ................................................................. 99
5.4 Sharing Folders ................................................................. 100
5.5 Managing Windows Files ................................................................. 102
5.6 Configuring and Accessing a Windows Network Printer ................................................................. 103

6 Searching with Beagle ................................................................. 105

6.1 Using Beagle ................................................................. 105
6.2 Search Tips ................................................................. 106
6.3 Performing a Property Search ................................................................. 107
6.4 Setting Search Preferences ................................................................. 109
6.5 Indexing Other Directories ................................................................. 110
6.6 Preventing Files and Directories from Being Indexed ................................................................. 111
6.7 Selecting Data Sources to Index ................................................................. 112
6.8 Disabling Beagle ................................................................. 112
6.9 For More Information ................................................................. 112

7 Managing Printers ................................................................. 113

7.1 Installing a Printer ................................................................. 113
7.2 Modifying Printer Settings ................................................................. 115
7.3 Canceling Print Jobs ................................................................. 115
7.4 Deleting a Printer ................................................................. 115
A GNU Licenses

A.1 GNU General Public License .................................................. 117
A.2 GNU Free Documentation License ........................................... 120
About This Guide

This manual introduces you to the GNOME graphical desktop environment as implemented in openSUSE® and shows you how to configure it to meet your personal needs and preferences. It also introduces you to several programs and services. It is intended for users who have some experience using a graphical desktop environment such as Macintosh*, Windows*, or other Linux desktops.

The manual is subdivided into two parts:

Introduction
Get to know your GNOME desktop and learn how to cope with basic and daily tasks, using the central GNOME applications and some small utilities. Get an impression of the possibilities GNOME offers to modify and individualize your desktop according to your needs and wishes. Learn how to use assistive technologies to improve accessibility in case of vision or mobility impairment.

Internet Connectivity, Files and Resources
Find vital information concerning the management and exchange of data on your system: how to share files on the network and how to use an integrated collaboration environment, how to effectively search for data, and how to manage printers and back up your data.

Many chapters in this manual contain links to additional documentation resources. This includes additional documentation that is available on the system as well as documentation available on the Internet.

For an overview of the documentation available for your product and the latest documentation updates, refer to http://www.novell.com/documentation or to the following section.
1 Available Documentation

We provide HTML and PDF versions of our books in different languages. The following manuals for users and administrators are available on this product:

Start-Up (Start-Up)
Guides you through the installation and basic configuration of your system. For newcomers, the manual also introduces basic Linux concepts such as the file system, the user concept and access permissions and gives an overview of the features openSUSE offers to support mobile computing. Provides help and advice in troubleshooting.

Introduces the KDE desktop of openSUSE. It guides you through using and configuring the desktop and helps you perform key tasks. It is intended mainly for users who want to make efficient use of KDE as their default desktop.

GNOME User Guide (page 1)
Introduces the GNOME desktop of openSUSE. It guides you through using and configuring the desktop and helps you perform key tasks. It is intended mainly for end users who want to make efficient use of GNOME desktop as their default desktop.

Application Guide (Application Guide)
Learn how to use and configure key desktop applications on openSUSE. This guide introduces browsers and e-mail clients as well as office applications and collaboration tools. It also covers graphics and multimedia applications.

Reference (Reference)
 Gives you a general understanding of openSUSE and covers advanced system administration tasks. It is intended mainly for system administrators and home users with basic system administration knowledge. It provides detailed information about advanced deployment scenarios, administration of your system, the interaction of key system components and the set-up of various network and file services openSUSE offers.

Security Guide (Security Guide)
Introduces basic concepts of system security, covering both local and network security aspects. Shows how to make use of the product inherent security software like Novell AppArmor (which lets you specify per program which files the program
may read, write, and execute) or the auditing system that reliably collects information about any security-relevant events.

*Lessons For Lizards*
A community book project for the openSUSE distribution. A snapshot of the manual written by the open source community is released on an equal footing with the Novell/SUSE manuals. The lessons are written in a cook book style and cover more specific or exotic topics than the traditional manuals. For more information, see [http://developer.novell.com/wiki/index.php/Lessons_for_Lizards](http://developer.novell.com/wiki/index.php/Lessons_for_Lizards).

In addition to the comprehensive manuals, several quick start guides are available:

**KDE Quick Start** *(↑KDE Quick Start)*
Gives a short introduction to the KDE desktop and some key applications running on it.

**GNOME Quick Start** *(↑GNOME Quick Start)*
Gives a short introduction to the GNOME desktop and some key applications running on it.

**Novell AppArmor Quick Start**
Helps you understand the main concepts behind Novell® AppArmor.

Find HTML versions of most openSUSE manuals in your installed system under `/usr/share/doc/manual` or in the help centers of your desktop. Find the latest documentation updates at [http://www.novell.com/documentation](http://www.novell.com/documentation) where you can download PDF or HTML versions of the manuals for your product.

For information where to find the books on your installation media, refer to the Release Notes of this product. The Release Notes are available from your installed system under `/usr/share/doc/release-notes/` or in the help centers of your KDE or GNOME desktop.

## 2 Feedback

Several feedback channels are available:
• To report bugs for a product component or to submit enhancements requests, please use https://bugzilla.novell.com/. If you are new to Bugzilla, you might find the Submitting Bug Reports article—available under http://en.opensuse.org/Submitting_Bug_Reports helpful. Frequently asked questions on reporting bugs are available under http://en.opensuse.org/Bug_Reporting_FAQ.

• We want to hear your comments and suggestions about this manual and the other documentation included with this product. Please use the User Comments feature at the bottom of each page of the online documentation and enter your comments there.

3 Documentation Conventions

The following typographical conventions are used in this manual:

• /etc/passwd: directory names and filenames

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to a chapter in another manual.
4 About the Making of This Manual

This book is written in Novdoc, a subset of DocBook (see http://www.docbook.org). The XML source files were validated by xmllint, processed by xsltproc, and converted into XSL-FO using a customized version of Norman Walsh's stylesheets. The final PDF is formatted through XEP from RenderX.

5 Source Code

The source code of openSUSE is publicly available. To download the source code, proceed as outlined under http://www.novell.com/products/suselinux/source_code.html. If requested we send you the source code on a DVD. We need to charge a $15 or €15 fee for creation, handling and postage. To request a DVD of the source code, send an e-mail to sourcedvd@suse.de or mail the request to:

SUSE Linux Products GmbH Product Management openSUSE Maxfeldstr. 5 D-90409 Nürnberg Germany

6 Acknowledgments

With a lot of voluntary commitment, the developers of Linux cooperate on a global scale to promote the development of Linux. We thank them for their efforts—this distribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar. Special thanks, of course, goes to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
Part I. Introduction
Getting Started with the GNOME Desktop

This section describes the conventions, layout, and common tasks of the GNOME desktop as implemented in your product.

GNOME is an easy-to-use graphical interface that can be customized to meet your needs and personal preferences. This section describes the default configuration of GNOME. If you or your system administrator modifies the defaults, some aspect might be different, such as appearance or keyboard shortcuts.

1.1 Logging In and Selecting a Desktop

If more than one user account is configured on your computer, generally all users must authenticate—unless Auto Login is enabled for a specific user. Auto login lets a user automatically log in to the desktop environment when the system starts. This feature can be enabled or disabled during installation or at any time using the YaST User Management module. For more information, refer to Chapter 5, Managing Users with YaST (↑Start-Up). If your computer is running in a network environment and you are not the only person using the machine, you are usually prompted to enter your username and password when you start the system.

The program managing the login process is specific to the desktop environment installed on your system. For GNOME, it is GDM. If the KDE desktop is also installed on your system, it can be KDM.
The GDM login screen has the following items:

- **Domain Menu** If you authenticate against an Active Directory server, choose the Windows* Domain to which you want to login. For all other authentication methods, choose *Local Login*.

- **Login Window** *Shut Down, Restart* or *Suspend* your machine or login to the system. Select an existing user from the list or choose *Other...* to manually enter a username. Type in the password and press Enter to login. Once a username is selected or entered, additional menus become available in the panel:

  - **Language Menu** Select a language for your session.
  
  - **Keyboard Menu** Select a keyboard layout for your session.
  
  - **Session Menu** Select the desktop to run during your session. If other desktops are installed, they appear in the list.
  
  - **Display Settings Menu** Change display settings such as resolution and refresh rate here.
  
  - **Access Preferences** Configure the use of assistive technologies using this menu. For details please refer to Chapter 4, *Assistive Technologies* (page 85).

1.1.1 Session Management

A *session* is the period of time that you are actively logged in. During a session, you can use applications, print, browse the Web and so on.

The login screen offers several login options. For example, you can select the language of your session so that text that appears in the interface is presented in that language.

After your username and password are authenticated, the Session Manager starts. The Session Manager lets you save certain settings from each session. It also lets you save the state of your most recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:

  - Appearance and behavior settings, such as fonts, colors, and mouse settings.
• Applications that you were running, such as a file manager or an OpenOffice.org program.

**TIP**

You cannot save and restore applications that Session Manager does not manage. For example, if you start the Vi editor from the command line in a terminal window, Session Manager cannot restore your editing session.

For information on configuring session preferences, see Section 3.5.8, “Managing Sessions” (page 80).

### 1.1.2 Switching Desktops

If you installed both the GNOME and the KDE desktops, use the following instructions to switch desktops.

1. Click *Computer > Logout > Log Out.*

   In KDE, click the *main menu* button, then click *Leave > Logout.*

2. In KDE, click *Session* on the login screen and select the desktop you want. In GNOME, first select or enter a user and then choose a desktop from the *Session* menu.

3. Type your username, then press Enter.

4. Type your password, then press Enter.

### 1.1.3 Locking Your Screen

To lock the screen, you can do either of the following:

• Click *Computer > Lock Screen.*

• If the *Lock* button is present on a panel, click it.

   To add the *Lock* button to a panel, right-click the panel, then click *Add to Panel > Lock Screen.*
When you lock your screen, a screen saver starts, locking the screen. To unlock the screen, move your mouse or press a key to display the locked screen dialog. Enter your password, then press Enter.

For information on configuring your screen saver see Section 3.3.4, “Configuring the Screen Saver” (page 56).

1.2 Logging Out

When you are finished using the computer, you can log out (leaving the system running), restart or shut down the computer. If your system provides power management you can also suspend your computer, making the next session start much faster than with a complete reboot.

1.2.1 Logging Out or Switching Users

1. Click *Computer > Logout*.

2. Select one of the following options:

   - **Log Out** Logs you out of the current session and returns you to the Login screen.
   - **Switch User** Suspends your session, allowing another user to log in and use the computer.

1.2.2 Restarting or Shutting Down the Computer

1. Click *Computer > Shutdown*.

2. Select one of the following options:

   - **Shutdown** Logs you out of the current session, then turns off the computer.
   - **Restart** Logs you out of the current session, then restarts the computer.
**Suspend**  Puts your computer in a temporary state that conserves minimal power (“Suspend to RAM”). The state of your session is preserved, however, including all applications you have running and all documents you have open.

**Hibernate**  Suspends your session, using no power until the computer is restarted (“Suspend to Disk”). The state of your session is preserved, however, including all applications you have running and all documents you have open.

### 1.3 Desktop Basics

As with other common desktop products, the main components of the GNOME desktop are icons that link to files, folders, or programs, as well as the panel at the bottom of the screen (similar to the Task Bar in Windows). Double-click an icon to start its associated program. Right-click an icon to access additional menus and options. You can also right-click any empty space on the desktop to access additional menus for configuring or managing the desktop itself.

![Figure 1.1 GNOME Desktop](image-url)
By default, the desktop features two key icons: your personal Home folder and a trash can for deleted items. Other icons may also be present on the desktop, such as icons representing devices on your computer. If you double-click your Home folder, the Nautilus file manager starts and displays the contents of your home directory (where your personal files and configurations are stored). For more information about using Nautilus, see Section 2.2, “Managing Folders and Files with Nautilus” (page 17).

Right-clicking an icon displays a menu that offers file operations such as copying, cutting or renaming. Selecting Properties from the menu displays a configuration dialog. On the Basic tab, you can change the name of the icon as well as the icon itself (by clicking on it and selecting a file with a different one). Various information about the object represented by the icon is also shown here. The Emblems tab lets you add up to four graphically descriptive symbols to the icon. The Permissions tab lets you set access permissions for the selected files. The Notes tab lets you manage comments. The menu for the trash can also features the Empty Trash option, which deletes its contents.

A link is a special type of file that points to another file or folder. When you perform an action on a link, the action is performed on the file or folder to which the link points. However, when you delete a link, you delete only the link file and not the file that the link is referencing.

To create a desktop link to a folder or a file, access the object in File Manager by right-clicking the object and then clicking Make Link. Drag the link from the File Manager window and drop it onto the desktop.

### 1.3.1 Default Desktop Icons

To remove an icon from the desktop, simply drag it onto the trash can. The Home icon cannot be removed.

---

**WARNING**

Be careful with this option - if you move folder or file icons to the trash can and you empty the trash can, the actual data is deleted. If the icons only represent links to a file or to a directory, only the links are deleted.
1.3.2 Desktop Menu

Right-clicking an empty spot on the desktop displays a menu with various options. Click Create Folder to create a new folder. Create a launcher icon for an application with Create Launcher. Provide the name of the application and the command for starting it, then select an icon to represent it. Align the desktop icons by name with Clean Up by Name. With Keep Aligned checked, icons are always arranged in a grid. You can also change the desktop background with this menu or open a terminal window.

Figure 1.2  GNOME Desktop Menu

1.3.3 Bottom Panel

The desktop includes a panel across the bottom of the screen. The bottom panel contains the main menu (similar to the Start menu in Windows*), the taskbar showing the icons of all applications currently running as well as easy access to applications and applets. If you click the name of a program in the taskbar, the program's window is moved to the foreground. If the program is already in the foreground, a mouse click minimizes it. Clicking a minimized application reopens the respective window to foreground status.

Figure 1.3  GNOME Bottom Panel

The Show Desktop icon is on the right side of the bottom panel. This icon minimizes all program windows and displays the desktop. Or, if all windows are already minimized, it reopens them.
If you right-click an empty spot in the panel, a menu opens, offering the options listed in the following:

**Table 1.1 Panel Menu Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to Panel</td>
<td>Opens a menu of applications and applets that can be added to the panel.</td>
</tr>
<tr>
<td>Properties</td>
<td>Modifies the properties for selected panel.</td>
</tr>
<tr>
<td>Delete This Panel</td>
<td>Removes the panel, along with all panel settings, from the desktop.</td>
</tr>
<tr>
<td>Allow Panel to be Moved/Lock Panel Position</td>
<td>Lets you drag the panel to another side of the screen, or locks the panel in its current position.</td>
</tr>
<tr>
<td>New Panel</td>
<td>Creates a new panel and adds it to the desktop.</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the Help Center.</td>
</tr>
<tr>
<td>About Panels</td>
<td>Opens information window about the panel application.</td>
</tr>
</tbody>
</table>

### 1.3.4 Adding Applets and Applications to the Panel

You can add applications and applets to the bottom panel for quick access. An applet is a small program, while an application is usually a more robust stand-alone program. Adding applets puts useful tools where you can easily access them.

The GNOME desktop comes with many applets. You can see a complete list by right-clicking the bottom panel and selecting *Add to Panel*. 
Some useful applets include the following:

**Table 1.2  Some Useful Applets**

<table>
<thead>
<tr>
<th>Applet</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dictionary Lookup</td>
<td>Look up a word in an online dictionary.</td>
</tr>
<tr>
<td>Force Quit</td>
<td>Terminate an application. This is especially useful if you want to</td>
</tr>
<tr>
<td></td>
<td>terminate an application that is no longer responding.</td>
</tr>
<tr>
<td>Search for Files</td>
<td>Find files, folders, and documents on the computer.</td>
</tr>
<tr>
<td>Sticky Notes</td>
<td>Create, display, and manage sticky notes on your desktop.</td>
</tr>
<tr>
<td>Traditional Main Menu</td>
<td>Access programs from a menu like the one in previous versions of GNOME.</td>
</tr>
<tr>
<td></td>
<td>This is especially useful for people who are accustomed to earlier versions of GNOME.</td>
</tr>
<tr>
<td>Applet</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Volume Control</td>
<td>Increase or decrease the sound volume.</td>
</tr>
<tr>
<td>Weather Report</td>
<td>Display current weather information for a specified city.</td>
</tr>
<tr>
<td>Workspace Switcher</td>
<td>Access additional work areas (or workspaces) through virtual desktops. For example, you can open applications in different workspaces and use them on their own desktops without the clutter from other applications.</td>
</tr>
</tbody>
</table>
Working with Your Desktop

Now you can now start to work with your desktop. In this chapter you will learn how to start applications, manage and search files and burn CDs. You will get familiar with the power management concept of GNOME and find out how to perform regular tasks with your desktop.

2.1 Using the Main Menu

Click Computer on the far left of the bottom panel to main menu with recently used applications. You can also click Documents to display your recent documents, or click Places to display your favorite places (such as your home directory or the Desktop). Click More Applications to access additional applications, listed in categories. Use the options on the right to access Help, install additional software, open the GNOME Control Center, lock your screen, log out of the desktop or check the status of your hard drive and network connections.
**Figure 2.1  Main Menu**

The *main menu* contains several elements:

### 2.1.1 Search Bar

The search bar helps you find applications and files on your system. Enter your search terms in the *Search* field, then press Enter. The results are displayed in the Desktop Search dialog box.

For more information about using Beagle, GNOME desktop’s search function, see Chapter 6, *Searching with Beagle* (page 105).

### 2.1.2 Main Menu Tabs

You can determine which icons appear in the main menu by clicking the *Applications*, *Documents* or *Places* tabs.

**Favorite Applications**

By default, Favorite Applications shows icons for four commonly used applications. Customize this view to show the applications you use most often.
To add an item to your Favorite Applications:

1. Click *Computer > More Applications*.
2. Right-click the application you want to add.
3. Select *Add to Favorites*.

The selected application is added to your Favorite Applications.

To remove an item from your Favorite Applications:

1. Click *Computer*.
2. Make sure that your Favorite Applications appear in the main menu. If *Favorite Applications* does not appear on the main menu, click *Applications*.
3. Right-click the item you want to remove.
4. Select *Remove from Favorites*.

**Recent Applications**

Recent Applications shows the last two to four applications you have started, provided they do not already appear under Favorite Applications.

**Recent Documents**

Click the *Documents* tab to display Favorite and Recent Documents. Use this view to quickly locate the documents you worked on most often or most recently. Click *More Documents* to open the File Browser. You may move a document from the Recent to the Favorite Documents section by right clicking it and choosing *Add to Favorites*.

**Recent Places**

Click the *Places* tab to display the last several places you have opened. Use this view to quickly locate the places you worked on most recently. Click *More Places* to open the File Browser.
2.1.3 System

System provides shortcuts to several system applications.

Table 2.1 System Shortcuts

<table>
<thead>
<tr>
<th>Application</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>Opens the Help Center, which provides online documentation for your system.</td>
</tr>
<tr>
<td>Control Center</td>
<td>Allows you to customize and configure your desktop. For more information, see Chapter 3, Customizing Your Settings (page 45).</td>
</tr>
<tr>
<td>YaST</td>
<td>Allows you to customize and configure your system.</td>
</tr>
<tr>
<td>Install Software</td>
<td>Opens the Software Installer, which guides you through the process of installing new software.</td>
</tr>
<tr>
<td>Lock Screen</td>
<td>Locks your system so that nobody can access it while you are away. Enter your password to unlock the system.</td>
</tr>
<tr>
<td>Log Out</td>
<td>Opens the Log Out dialog, where you can log out or switch users.</td>
</tr>
<tr>
<td>Shutdown</td>
<td>Opens the Shutdown dialog, where you can shut down or restart your system. You can also suspend your computer from this shortcut.</td>
</tr>
</tbody>
</table>

2.1.4 Status

Status displays information about your hard drive and network connection, including the amount of available space on your hard disk and the type of network connection you are using.
2.2 Managing Folders and Files with Nautilus

Use the Nautilus File Manager to create (or view) folders and documents, run scripts and create CDs of your data. In addition, the File Manager provides support for Web and file viewing.

You can open the File Manager in the following ways:

- Click `Computer > Nautilus File Browser`.
- Double-click your Home directory icon on the desktop.
- Click `Computer > More Applications > System > Home Folder` or `Nautilus File Browser`.

*Figure 2.2  File Manager*

The elements of the Nautilus window include the following:

**Menu**  Lets you perform most tasks in the file manager. You can also open a context sensitive pop-up menu from a file manager window by right-clicking inside it. The items in this menu depend on where you right-click. For example, if you right-click a file or folder, you can select items related to the file or folder. If you right-click the background of a view pane, you can select items related to the display of items in the view pane.
**ToolBar**  Lets you quickly navigate among files and folders, and provides access to them. The toolbar contains Back, Forward, Up, Stop, Reload, Home, Computer, and Search buttons.

**Location Bar**  Lets you locate files, folders, and URI sites. The location bar supports two different views: the traditional text-based view (where you can enter or edit a path) and the button view (where each folder is displayed as a button). Navigate to a location by pressing a button.

**Side Pane**  Lets you navigate or display information about the selected file or folder. Use the drop-down list to customize what is shown in the pane. The list includes ways to view information about files, perform actions on files, add emblems to files, view a history of recently visited sites and display your files in the Tree system. To close the side pane, click the X at the top right of the side pane. To display the side pane, click View > Side Pane or press F9.

**View Pane**  Displays folders and files. Use the options in the View menu to zoom the content or choose from different sorting options. You can also display items as a detailed list, a compact list or as icons.

**Status Bar**  Displays the number of items in a folder and gives the available free space. When a file is selected, the status bar displays the filename and size.

### 2.2.1 File Manager Navigation Shortcuts

Some simple shortcuts for navigating in the File Manager include the following:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;— or Alt + ↑</td>
<td>Opens the parent folder.</td>
</tr>
<tr>
<td>Arrow key</td>
<td>Selects an item.</td>
</tr>
<tr>
<td>Alt + ↓ or Enter</td>
<td>Opens an item.</td>
</tr>
<tr>
<td>Shift + Alt + ↓</td>
<td>Opens an item and closes the current folder.</td>
</tr>
<tr>
<td>Shortcut</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------------------</td>
</tr>
<tr>
<td>Shift + Alt + ↑</td>
<td>Opens the parent folder and closes the current folder.</td>
</tr>
<tr>
<td>Shift + Ctrl + W</td>
<td>Closes all parent folders.</td>
</tr>
<tr>
<td>Ctrl + L</td>
<td>Toggles the location bar view from the button view to the text-based view.</td>
</tr>
<tr>
<td>Alt + Home</td>
<td>Opens your home directory.</td>
</tr>
</tbody>
</table>

For more information, click *Help > Contents* in the File Manager.

### 2.2.2 Archiving Folders

If you have files you would like to archive, you can compress the files into tape archive format (TAR).

1. In the Nautilus view pane, right-click the folder you want to archive, then click *Create Archive*.

![Create Archive dialog box](image)

2. Accept the default archive filename or provide a new one.

3. Select a file extension from the drop-down list (use *tar.gz* for the most common archive form or *.zip* to ensure compatibility with Windows).

4. Specify a location for the archive file, then click *Create*.

To extract an archived file, right-click the file, then select *Extract Here*. 
2.2.3 Creating a CD/DVD

If your system has a CD or DVD read/write drive, you can use the Nautilus file manager to burn CDs and DVDs.

1. Click Computer > More Applications > Multimedia > GNOME CD/DVD Creator, or insert a blank disc and click Make Data CD/DVD or Make Audio CD/DVD.

2. Drag and drop the files you want to put on the disc into the Nautilus CD/DVD Creator window.

3. Click Write to Disc.

4. Modify the information in the Write to Disc dialog box or accept the defaults, then click Write.

The files are burned to the disc. This could take a few minutes, depending on the amount of data being burned and the speed of your burner.

To burn an iso image, right-click on the iso image file in Nautilus and choose Open with CD/DVD Creator. Modify the information in the Write to Disc dialog box or accept the defaults, then click Write.

You can also use the burning application Brasero to burn CDs or DVDs. See Chapter 26, Burning CDs and DVDs With Brasero (↑Application Guide) for more information.
2.2.4 Using Bookmarks

Use the Nautilus Bookmarks feature to mark your favorite folders.

1. Select the folder or item for which you want to create a bookmark.

2. Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the folder name as the bookmark name. When you bookmark a file, it is the folder that is actually bookmarked.

3. To select an item from your Bookmarks list, click Bookmarks, then click the desired bookmark in the list.

You can also organize your Bookmarks list by clicking Bookmarks > Edit Bookmarks and making your selections in the dialog box.

To change the order of your bookmarks, click a bookmark and drag it to the desired location.

2.2.5 File Manager Preferences

You can change the File Manager preferences by clicking Edit > Preferences. For more information, see Section 3.3.7, “Configuring File Management Preferences” (page 60).

2.2.6 Accessing Remote Files

You can utilize Nautilus to access files on remote servers. For more information see Chapter 5, Accessing Network Resources (page 97).
2.3 Accessing Floppy Disks, CDs, or DVDs

To access floppy disks, CDs or DVDs, insert the medium into the appropriate drive. An icon for the medium is automatically created on the desktop. For many types of removable media, a File Manager window pops up automatically when the media is inserted or attached to the computer. If File Manager does not open, double-click the icon for that drive to view the contents.

**WARNING**

Do not simply remove disks from the drive after using them. Floppy disks, CDs, and DVDs must always be unmounted from the system first. Close all applications still accessing the medium, then right-click the icon for the medium and select *Eject Volume* or *Unmount Volume* from the menu. Then safely remove the floppy disk, CD, or DVD when the tray automatically opens.

Floppy disks can be formatted by clicking *Computer > More Applications > System > Floppy Formatter*. In the Floppy Formatter dialog, select the density of the floppy disk and the file system settings: Linux native (ext2), the file system for Linux or DOS (FAT) to use the floppy with Windows systems.

2.4 Searching for Files

Using *Search for File* on the *Computer > More Applications > System* menu, you can locate files on your computer or on a network share using any number of search criteria.
**Figure 2.3 Search for Files Dialog**

*Search for Files* uses the find, grep and locate UNIX commands. All searches are case insensitive.

You can also open the *Search for Files* dialog by entering the following command into the Run Application dialog (started with Alt + F2):

```bash
gnome-search-tool
```

### 2.4.1 Performing a Basic Search

1. Start *Search for Files*.

2. Type the search text in the *Name contains* field.

   The search text can be a filename or partial filename, with or without wild cards, as shown in the following table:
<table>
<thead>
<tr>
<th>Search Text</th>
<th>Example</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full or partial filename</td>
<td>myfile.txt</td>
<td>Searches for all files that contain “myfile.txt” in the filename.</td>
</tr>
<tr>
<td>Partial filename combined with wild cards (* [ ])</td>
<td>*.ch</td>
<td>Searches for all files that have a .c or .h extension.</td>
</tr>
</tbody>
</table>

3. In the *Look in folder* field, choose the directory where you want *Search for Files* to begin the search.

4. Click *Find*.

### 2.4.2 Adding Search Options

Use *Select more options* to search by file content, dates, owner or file size.

1. Start *Search for Files*.

2. Type the search text in the *Name contains* field.

3. In the *Look in folder* field, type the path to the directory where you want Search for Files to begin the search.

4. Click *Select more options*, then click *Available options*.

5. Select a search option that you want to apply, then click *Add*.

The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains the text</td>
<td>Searches for a file by filename. Type a full filename or a partial filename with wild cards in the field provided. Use an asterisk (*) to indicate a sequence of characters. Use a question mark (?)</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Date modified less than</strong></td>
<td>Searches for files that were modified within the period specified (in days).</td>
</tr>
<tr>
<td><strong>Date modified more than</strong></td>
<td>Searches for files that were modified before the period specified (in days).</td>
</tr>
<tr>
<td><strong>Size at least</strong></td>
<td>Searches for files that are equal to or larger than the size specified (in kilobytes).</td>
</tr>
<tr>
<td><strong>Size at most</strong></td>
<td>Searches for files that are smaller than or equal to the size specified (in kilobytes).</td>
</tr>
<tr>
<td><strong>File is empty</strong></td>
<td>Searches for empty files.</td>
</tr>
<tr>
<td><strong>Owned by user</strong></td>
<td>Searches for files that are owned by the user specified. Type the name of the user in the text box provided.</td>
</tr>
<tr>
<td><strong>Owned by group</strong></td>
<td>Searches for files that are owned by the group specified. Type the name of the group in the text box provided.</td>
</tr>
<tr>
<td><strong>Owner is unrecognized</strong></td>
<td>Searches for files that are owned by a user or group that is unknown to the system.</td>
</tr>
<tr>
<td><strong>Name does not contain</strong></td>
<td>Searches for filenames that do not contain the string that you enter. Enter a full filename or a partial filename with wild cards in the field provided. Use an asterisk (*) to indicate a sequence of characters. Use a question mark (?) to indicate a single character. The search is case sensitive.</td>
</tr>
<tr>
<td><strong>Name matches regular expression</strong></td>
<td>Searches for files that contain the specified regular expression in their directory path or filename.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Option</td>
<td>Type the regular expression in the text box provided.</td>
</tr>
<tr>
<td>Regular expressions are special text strings used to describe a search pattern. For more information, see <a href="http://www.regular-expressions.info">http://www.regular-expressions.info</a>.</td>
<td></td>
</tr>
<tr>
<td>Show hidden and backup files</td>
<td>Includes hidden and backup files in the search.</td>
</tr>
<tr>
<td>Follow symbolic links</td>
<td>Follows symbolic links when searching for files.</td>
</tr>
<tr>
<td>Include other file systems</td>
<td>Searches in directories that are not in the same file system as the start directory.</td>
</tr>
</tbody>
</table>

6 Specify the required search information for the search option.

7 To remove a search option from the current search, click the Remove button next to the option.

8 Click Find.

**2.4.3 Using the Search Results List**

You can use the Search Results list to open or delete a file found during a search, or you can save the search results to a file.
To open a file displayed in the Search Results list, right-click the file, then click *Open* or double-click the file. To open the folder that contains a file displayed in the Search Results list, right-click the file and click *Open Folder*.

To delete a file displayed in the Search Results list, right-click the file and click *Move to Trash*.

To save the results of the last search that *Search for Files* performed, right-click anywhere in the Search results list and click *Save Results As*. Type a name for the file that will contain your Search results and click *Save*.

### 2.4.4 Disabling Quick Searches

By default, *Search for Files* tries to speed up some searches by using the `locate` command. `locate` provides a secure way to index and quickly search for files. Because `locate` relies on a file index, the Search Results list might not be up to date. To disable quick searches, run the following command in a terminal window:

```
# gconftool-2 --type=bool --set /apps/gnome-search-tool/disable_quick_search 1
```
2.5 Moving Text Between Applications

To copy text between applications, select the text, then move the mouse cursor to the position where you want the text pasted. Click the center button on the mouse or the scroll wheel to paste the text.

When copying information between programs, you must keep the source program open and paste the text before closing it. When a program closes, any content from that application that is on the clipboard is lost.

2.6 Managing Internet Connections

To surf the Internet or send and receive e-mail messages, you must have configured an Internet connection with YaST. Depending on your environment, in YaST select whether to use NetworkManager. In GNOME, you can then establish Internet connections with NetworkManager as described in Section “Using GNOME NetworkManager Applet” (Chapter 10, Using NetworkManager, ↑Start-Up).

For a list of criteria to help you to decide whether to use NetworkManager, refer to Section “Use Cases for NetworkManager” (Chapter 10, Using NetworkManager, ↑Start-Up).

2.7 Exploring the Internet

The GNOME desktop includes Firefox, a Mozilla*-based Web browser. You can start it by clicking Computer > Firefox.

You can type an address into the location bar at the top or click links in a page to move to different pages, just like in any other Web browser.

For more information, see Chapter 17, Browsing with Firefox (↑Application Guide).
2.8 E-mail and Scheduling

For reading and managing your mail and events, openSUSE offers you Novell® Evolution™, a groupware program that makes it easy to store, organize and retrieve your personal information.

Evolution seamlessly combines e-mail, a calendar, an address book, and a memo and task list in one easy-to-use application. With its extensive support for communications and data interchange standards, Evolution can work with existing corporate networks and applications, including Microsoft® Exchange.

To start Evolution, click **Computer > More Applications > Office > Evolution Mail and Calendar**.

The first time you start Evolution, it prompts you with a few questions as it sets up a mail account and helps you import mail from your old mail client. Then it shows you how many new messages you have and lists upcoming appointments and tasks. The calendar, address book and mail tools are available in the shortcut bar on the left.

For more information, see Chapter 6, *Evolution: E-Mail and Calendaring* (↑Application Guide).
2.9 Opening or Creating Documents with OpenOffice.org

For creating and editing documents, OpenOffice.org is installed with the GNOME desktop. OpenOffice.org is a complete set of office tools that can both read and save Microsoft Office file formats. OpenOffice.org has a word processor, a spreadsheet, a database, a drawing tool and a presentation program.

To get started, click Computer > OpenOffice.org Writer or select an OpenOffice.org module by clicking Computer > More Applications > Office and selecting the module you want to open.

A number of sample documents and templates are included with OpenOffice.org. You can access the templates by clicking File > New > Templates and Documents. In addition, you can use wizards, which guide you through the creation of letters and other typical documents.

For more information, see Chapter 1, The OpenOffice.org Office Suite (↑Application Guide) or view the Help in any OpenOffice.org program.

2.10 Controlling Your Desktop’s Power Management

GNOME Power Manager is a session daemon for the GNOME desktop that manages the power settings for your laptop or desktop computer. When running on battery, the GNOME Power Manager displays a battery icon showing the battery state in the panel. When hovering the mouse over the icon, a pop-up with more information is shown. To view detailed information about the batteries current state, left-click the icon and choose Laptop Battery. On certain events, such as a critically low battery state, the GNOME Power Manager will display notifications informing you about the event.

GNOME Power Manager is usually started automatically when GNOME starts, but you can manually start GNOME Power Manager by using the following command:

```
gnome-power-manager --verbose --no-daemon
```
2.10.1 Viewing Power Statistics

The statistics program lets you view the power consumption of your laptop hardware in graphic form. To access the statistics graphs, right-click the battery icon and choose Power History, or click Computer > More Applications > System > Power Statistics.

*Figure 2.5  Power History Going From Battery Power to AC*

The Power History graph shows the power history charge used by the composite primary battery. The line represents the amount of power that is either being used to charge the batteries in the system or the power being used by the system from the batteries. You should see the line go up when processor intensive tasks are performed, and go down when the system is at idle (or when the screen is dimmed). A legend is shown with this graph when data events have been received.

You will not receive rate data from your computer if it is not charging or discharging, or if the computer is suspended. This is due to hardware limitations (where the rate is only sent from the battery management chip, rather than the power management chip on the motherboard).

Depending on your hardware, other graphs will be available from the Graph Type menu. You might also see additional hardware that can be accessed via the optional Devices button.
2.10.2 Modifying Power Management Preferences

The Power Management Preferences dialog box lets you control the LCD brightness when your system is on AC or battery power, the idle time for the screen power-down and suspend action, the actions to perform when the laptop lid is closed and the notification area icon policy.

To access Power Management Preferences, right-click the battery icon and choose Preferences, or click Computer > More Applications > System > Power Management.

On AC Power Preferences

Use the options on the On AC Power dialog box to automatically put your computer to sleep when it has been inactive for a specified amount of time. When your computer is asleep, it is turned on but in a low power mode (suspend to RAM). It takes less time for a computer to wake up from sleep than it does for the computer to start up after being turned off.

You can also set only the display to sleep and adjust the display brightness. If your computer is in the middle of a task (for example, burning a DVD) that you want to finish while you are away, set only the display to sleep.

Figure 2.6  GNOME Power Manager On AC Power Preferences
On Battery Power Preferences

Use the options on the On Battery Power dialog box to automatically put your computer to sleep when it has been inactive for a specified amount of time, to specify what happens when the laptop lid is closed, and what happens when battery power is critically low.

When your computer is asleep, it is turned on but in a low power mode (suspend to RAM). It takes less time for a computer to wake up from sleep than it does for the computer to start up after being turned off.

You can also set only the display to sleep. If your computer is in the middle of a task (for example, burning a DVD) that you want to finish while you are away, set only the display to sleep.

Figure 2.7 GNOME Power Manager On Battery Power Preferences

General Preferences

Use the options on the General Power Management Preference dialog box to configure miscellaneous options related to GNOME Power Manager’s behavior, such as the actions to perform when the power or suspend buttons are pressed, if an icon is displayed in the Notification area and if sound is used to notify you in the event on an error.
Figure 2.8  GNOME Power Manager General Preferences

Scheduling a Wakeup

Use the Scheduling tab on the General Power Management Preference dialog box to configure an automatic wake up from a suspend state. Specify a time of day and a day of the week for the wake up.

Figure 2.9  GNOME Power Manager Scheduling Preferences
2.10.3 Session and System Idle Times

gnome-screensaver is a session daemon that monitors user input (if the mouse has or has not been moved and if the keyboard has or has not been pressed) then starts a timeout. When the value of this timeout reaches the value set in Screensaver Preferences (using the *Regard the computer as idle after* option), then the login is marked as “session idle.”

As soon as the session is marked idle, GNOME Power Manager starts its own system timer. When the timeout set in GNOME Power Manager Preferences is reached, and the CPU load is idle, then the idle action is performed (such as turning off the screen, suspending or hibernating the computer).

To make this clearer, the sliders in GNOME Power Manager Preferences are set to start at the value of the session-timeout + 1 minute, as GNOME Power Manager Preferences cannot logically trigger before the session is marked as idle. If you adjust the value of the session idle timeout in Screensaver Preferences, the start time of the sliders in GNOME Power Manager Preferences will change accordingly.

*Figure 2.10 Changing the Session Idle Timeout in Screensaver Preferences*
To access the screen saver preferences, click **Computer > More Applications > System > Screensaver**. For more information, see Section 3.3.4, “Configuring the Screen Saver” (page 56).

### 2.11 Creating, Displaying, and Decompressing Archives

You can use the Archive Manager application (also known as File Roller) to create, view, modify or unpack an archive. An archive is a file that acts as a container for other files. An archive can contain many files, folders and subfolders, usually in compressed form. Archive Manager application supports common formats such as **zip**, **tar.gz**, **tar.bz2**, **lzh**, and **rar**. You can use Archive Manager to create, open and extract a compressed non-archive file.

To start Archive Manager, click **Computer > More Applications > Utilities > File Roller**. If you already have a compressed file, double-click the filename in the Nautilus file manager to view the contents of the archive in Archive Manager.

**Figure 2.11 Archive Manager**
2.11.1 Opening an Archive

1. In Archive Manager, click Archive > Open.

2. Select the archive you want to open.

3. Click Open.

Archive Manager automatically determines the archive type, and displays the following:

- The archive name in the window title bar.
- The archive contents in the display area.
- The total number of files in the archive and the size of the archive when uncompressed, in the status bar.

To open another archive, click Archive > Open again. Archive Manager opens each archive in a new window. To open another archive in the same window, you must first click Archive > Close to close the current archive, then click Archive > Open.

If you try to open an archive that was created in a format that Archive Manager does not recognize, the application displays an error message.

2.11.2 Creating Archives

1. In Archive Manager, click Archive > New.

2. Specify the name and location of the new archive.

3. Select an archive type from the Archive type drop-down list.
4 Click New.

Archive Manager creates an empty archive, but does not yet write the archive to disk. Archive Manager writes a new archive to disk only when the archive contains at least one file. If you create a new archive and quit Archive Manager before you add any files to the archive, Archive Manager deletes the archive.

5 Add files and folders to the new archive:

5a Click Edit > Add Files or Edit > Add a Folder and select the files or folders you want to add.

5b Click Add.

Archive Manager adds the files to the current folder in the archive.

You can also add files to an archive in a file manager window without opening Archive Manager. See Section 2.2.2, “Archiving Folders” (page 19) for more information.

### 2.11.3 Extracting Files From an Archive

1 In Archive Manager, select the files that you want to extract.

2 Click Archive > Extract.

3 Specify the folder where Archive Manager will extracts the files.

4 Choose from the following extract options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All files</td>
<td>Extracts all files from the archive.</td>
</tr>
<tr>
<td>Selected files</td>
<td>Extracts the selected files from the archive.</td>
</tr>
<tr>
<td>Files</td>
<td>Extracts from the archive all files that match the specified pattern.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Re-create folders     | Reconstructs the folder structure when extracting the specified files.  
For example, you specify `/tmp` in the Filename text box and choose to extract all files. The archive contains a subfolder called `doc`. If you select the Re-create folders option, Archive Manager extracts the contents of the subfolder to `/tmp/doc`. If you do not select the Re-create folders option, Archive Manager does not create any subfolders. Instead, Archive Manager extracts all files from the archive, including files from subfolders, to `/tmp`. |
| Overwrite existing files | Overwrites any files in the destination folder that have the same name as the specified files.  
If you do not select this option, Archive Manager does not extract the specified file if an existing file with the same name already exists in the destination folder. |
| Do not extract older files | Extracts the specified file only if the destination folder does not contain the specified file or if the destination folder contains an older version of the specified file. Archive Manager uses the modification date to determine which file is the most recent.  
If the version of the file in the archive is older, Archive Manager does not extract the specified file to the destination folder.  
This option is only available if the Overwrite existing files option is selected. |
This option is available only if the archive type supports encryption. Currently, only `.zip` and `.arj` archives support encryption.

If the archive contains encrypted files, enter the required password in the *Password* field to decrypt the specified files during the extraction process. The required password is the encryption password that was specified when the archive was created.

Displays the contents of the destination folder in a file manager window after the extraction of the specified files is completed.

5 Click *Extract*.

If all of the files in the archive are protected by a password (and you have not specified the password) Archive Manager displays an error dialog.

If some but not all of the files in the archive are protected by a password (and you have not specified the password) Archive Manager does not display an error dialog. However, Archive Manager extracts only the unprotected files to the new archive.

To extract an archived file in a file manager window without opening Archive Manager, right-click the file and select *Extract Here*.

The Extract operation extracts a copy of the specified files from the archive. The extracted files have the same permissions and modification date as the original files that were added to the archive.

The Extract operation does not change the contents of the archive.
2.12 Taking Screen Shots

You can take a snapshot of your screen or an individual application window using the Take Screenshots utility. Start it by pressing Print to take a screen shot of the entire desktop or by pressing Alt + Print to take a screen shot of the currently active window or dialog box. You may also start the application via Computer > More Applications > System > Take Screenshot.

When you take a screen shot, the Save Screenshot dialog box opens. To save the screen shot as an image file, enter the filename for the screen shot and choose a location from the drop-down list.

Figure 2.12  Save Screenshot Dialog Box

You can also use The GIMP to take screen shots. In The GIMP, click File > Create > Screenshot, select an area, choose a delay and then click Snap.

2.13 Viewing PDF Files

Documents that need to be shared or printed across platforms can be saved as PDF (Portable Document Format) files. openSUSE ships with the Evince PDF Viewer.
To open Evince, double-click a PDF file in a file manager window (or Web site) or press Alt + F2, type evince and press Enter.

To view a PDF file in Evince, click File > Open, locate the desired PDF file and click Open.

Use the navigation icons at the top of the window or the thumbnails in the left panel to navigate through the document. If your PDF document provides bookmarks, you can access them in the left panel of the viewer.

### 2.14 Controlling Sound

YaST automatically identifies and configures the sound cards in your computer. You can also use the YaST Hardware module to configure your sound card manually. When your sound card has been configured, you can control the volume and balance of the sound with the GNOME Volume Control mixer.
GNOME uses the PulseAudio sound server by default. PulseAudio allows to control audio “streams” of different programs with one GUI. This makes it able to, for example, use two different programs generating audio output at the same time by sending their output to different devices such as headphones and speakers.

If the mixer icon (a loudspeaker symbol) is not visible in the panel on your desktop, press Alt + F2 and enter `gnome-volume-control`, or click `Computer > More Applications > Multimedia > Volume Control`.

Left-click on the mixer icon and move the slider up or down to change the overall volume. Right-click and choose `Open Volume Control` for a detailed configuration dialog.

**Figure 2.14 GNOME Volume Control Dialog Box**

![Volume Control Dialog Box](image)

The GNOME Volume Control dialog box contains the following tabs:

**Playback**
- Shows all playback streams currently active. You may adjust the volume of a stream or mute it. Right-click on a stream to either terminate it or to move it to another sound device (if available).

**Recording**
- Shows applications that are currently recording sound. Right-click to choose the stream that will be recorded.

**Output Devices**
- Lists output devices. Right-click on a device to make it the default output device.
Input Devices
Lists input devices. Right-click on a device to make it the default input device.

2.15 Using the Fingerprint Reader

If your system includes a fingerprint reader, users can log in to the system either by swiping a finger on the fingerprint reader or by typing in a password. For more information, refer to Chapter 7, Using the Fingerprint Reader (↑Security Guide).

2.16 Obtaining Software Updates

When you connect to the Internet, the openSUSE Updater automatically checks whether software updates for your system are available. An openSUSE Updater applet in the system tray of your panel informs you of the availability of updates and lets you easily install them with just a few clicks. The applet icon changes color and appearance depending on the availability of updates for your system.

For detailed information on how to install software updates with openSUSE Updater and how to configure openSUSE Updater, refer to the chapter about installing and removing software in Section “Keeping the System Up-to-date” (Chapter 3, Installing, Removing and Updating Software, ↑Start-Up).

2.17 For More Information

Along with the applications described in this chapter for getting started, GNOME can run many other applications. Find detailed information about these important applications in the other parts of this manual and in the Application Guide (↑Application Guide).

To learn more about GNOME and GNOME applications, see http://www.gnome.org and http://gnomefiles.org.

To report bugs or add feature requests, go to http://bugzilla.gnome.org.
Customizing Your Settings

You can change the way the GNOME desktop looks and behaves to suit your own personal tastes and needs. Some of the settings you might want to change include:

• Keyboard and mouse configuration, as described in Section 3.2.1, “Modifying Keyboard Preferences” (page 48) and Section 3.2.2, “Configuring the Mouse” (page 49)

• Desktop background, as described in Section 3.3.1, “Changing the Desktop Background” (page 53)

• Screen saver, as described in Section 3.3.4, “Configuring the Screen Saver” (page 56)

• Password, as described in Section 3.4.1, “Changing Your Password” (page 71)

• Sounds, as described in Section 3.5.10, “Setting Sound Preferences” (page 82)

These settings and others can be changed in the Control Center.
3.1 The Control Center

To access the Control Center, click Computer > Control Center. The Control Center is divided into the following four categories:

*Hardware*
Allows you to configure hardware components such as graphics cards, monitors, printers or keyboard layout, and to set up your network devices and configure your network connection. For more information, see Section 3.2, “Hardware” (page 48).

*Look and Feel*
Contains settings for the desktop background, the screen saver and the fonts appearing on the desktop. You can modify themes, window behavior and styles of desktop elements such as menus and scroll bars. You can also configure 3D desktop effects (Compiz). For more information see Section 3.3, “Look and Feel” (page 52).

*Personal*
Go here to change your login password or to configure keyboard shortcuts and keyboard accessibility settings. For more information see Section 3.4, “Personal” (page 71).

*System*
Lets you configure system settings such as date and time, language, sound or power management. Define how GNOME handles sessions on login or shutdown and modify the Beagle search settings. For more information see Section 3.5, “System” (page 73).
In order to change some system-wide settings, Control Center will prompt you for the root password and start YaST. This is mostly the case for administrator settings (including most of the hardware, the graphical user interface, Internet access, security settings, user administration, software installation and system updates and information). Follow the instructions in YaST to configure these settings. For information about using YaST, refer to the integrated YaST help texts or refer to Start-Up (↑Start-Up).

This chapter focuses on individual settings you can change directly in the GNOME Control Center (without YaST interaction).
3.2 Hardware

In the following sections you will find examples of how to configure some hardware aspects of your GNOME desktop, including keyboard or mouse preferences, handling of removable drives (and other media) or screen resolution.

3.2.1 Modifying Keyboard Preferences

To modify some keyboard settings (such as autorepeat preferences or typing break sessions) click Computer > Control Center > Hardware > Keyboard.

**Figure 3.2  Keyboard Preferences Dialog**

1. On the *Keyboard* tab you can set some general keyboard preferences, such as enabling keyboard repeat with individual delay and speed options or enabling or disabling the blinking of the cursor and defining the speed. For more information about the individual options, click *Help*.

2. To select your keyboard model click the *Layouts* tab and select your model from the *Keyboard model* list.
3 To add a new language layout, click Add and choose a language layout to add to the list. You can select different layouts to suit different locales. Select one layout as Default.

4 On the Typing Break tab you can set typing break preferences. For more information about the individual options click Help.

5 If all options are set according to your wishes, click Close.

For configuration of keyboard accessibility options refer to the Section “Configuring an Accessible Keyboard” (page 90).

3.2.2 Configuring the Mouse

To modify some mouse options click Computer > Control Panel > Hardware > Mouse to open the Mouse Preferences.

**Figure 3.3** Mouse Preferences Dialog

1 The General tab is divided into several sections. Use the radio buttons in the Mouse Orientation section to specify if the mouse buttons are configured for left-hand or right-hand use.

2 Check the option in the Locate Pointer section on the General tab to enable a mouse pointer animation when you press and release Ctrl. This feature can help you locate the mouse pointer.
3 Use the sliders in the *Pointer Speed* section on the *General* tab to define the *Acceleration* and *Sensitivity* of your mouse pointer.

4 Use the slider in the *Drag and Drop* section on the *General* tab to modify the distance that you must move an item with the pointer before the action is interpreted as a drag and drop action.

5 Use the slider in the *Double-Click Timeout* section on the *General* tab to define the maximum delay between the two clicks of a double-click. If the interval between two clicks is greater than the interval specified here, the action is interpreted as two separate clicks instead of a double-click. Use the light bulb icon to check double-click sensitivity: the light will light up briefly for a click, but stay lit for a double-click.

6 If all options are set according to your wishes, click *Close*.

For configuration of mouse accessibility options refer to Section 4.2.1, “Configuring Mouse Behavior” (page 88).

### 3.2.3 Installing and Configuring Printers

The Printing module lets you connect to any available local or remote CUPS server and configure printers.

1 To start the Printers module, click *Computer > Control Center > Hardware > Printing*.

2 The CUPS server to which you are connected is shown in the status bar. To connect to a different CUPS server, click *Server > Connect*, enter URL of the CUPS server and press *Connect*. The printers available at the server are shown in the main window. Update the list of available printers with the *Refresh* button.

3 To add a new printer press *New* in the toolbar and follow the configuration wizard.

4 To configure printer properties, set it as the default printer or view its print queue, right-click the printer's icon and select appropriate option from the menu.
3.2.4 Configuring Screens

To specify the resolution, refresh rate and orientation for your screen or to configure multiple screens, click Computer > Control Center > Hardware > Screen Resolution and modify the options.

1. Press Detect Displays to detect all monitors connected to your computer.

2. To set options for any monitor, click on the monitor's icon in the blue preview area and set its Resolution, Refresh Rate, and Rotation (orientation) using the drop-down lists underneath.

3. If you use multiple monitors, you can set their respective positions by dragging their icons in the blue preview area to the appropriate location. Alternatively, you can configure your monitors to show the same image by checking Mirror Screens.

4. To show an applet icon in your system tray which enables you to rotate your screens, check Show Displays in Panel.
3.2.5 Configuring a Touchpad

Use the Touchpad module to configure the behavior of a touchpad. This module is only available on computers containing touchpads, such as laptops. In most cases the default behavior should remain unchanged. Click Computer > Control Center > Hardware > Touchpad to start the Touchpad module. This allows you to enable or disable the touchpad or to set its sensitivity, tapping and scrolling behaviour. This module also controls mouse-pointer acceleration.

3.3 Look and Feel

In the following sections find examples of how to configure some look and feel aspects of your GNOME desktop, like the desktop background and screensaver, 3D desktop effects, themes, window behavior or menus.
3.3.1 Changing the Desktop Background

The desktop background is the image or color that is applied to your desktop. You can customize the desktop background in the following ways:

- Select an image for the desktop background. The image is superimposed on the desktop background color. The desktop background color is visible if you select a transparent image or if the image does not cover the entire desktop.

- Select a color for the desktop background. You can select a solid color or create a gradient effect with two colors. A gradient effect is a visual effect where one color blends gradually into another color.

To change the desktop preferences:

1. Click Computer > Control Center > Look and Feel > Appearance > Background.

2. To change the picture on the background select one of the Wallpapers from the list and select the Style in which to arrange the image on the desktop. Your desktop immediately updates to show the new settings.

3. To use a custom picture, click Add and select an image file from the file system.
4 If you do not want a picture on the background, select No Wallpaper from the Wallpaper list and specify a color scheme using the options in the Color drop-down list and the color selector buttons. Your desktop immediately changes to show the new settings.

5 When you are satisfied with your choices, click Close.

### 3.3.2 Configuring Fonts

To select the fonts to use in your applications, windows, terminals and desktop, click Computer > Control Center > Look and Feel > Appearance > Fonts.

**Figure 3.6  Font Preferences Dialog**

The upper part of the dialog shows the fonts selected for applications, documents, the desktop, window titles and a fixed-width font for terminals. Click one of the buttons to open a selection dialog where you can set the font family, style and size. For more information on the individual options, click Help.

In the Rendering section, you can the way fonts are rendered on the screen. There are four basic options: Monochrome (monochrome rendering without any smoothing), Best Shapes (rendering optimized for precise character shapes), Best Contrast (rendering optimized for high contrast) and Subpixel Smoothing (taking advantage of LCD subpixel structure). Advanced options for display resolution, smoothing, hinting and subpixel order are available after clicking on Details.
3.3.3 Configuring Menus and Toolbars

You can configure the appearance and behavior of menus and toolbars. Click Computer > Control Center > Look and Feel > Appearance > Interface.

If you want icons to appear in menus, select Show icons in menus. Not all menu items have icons.

If you want to be able to define new keyboard shortcuts for menu items, select Editable menu shortcut keys. When this option is enabled, you can change an application shortcut key by placing the mouse pointer over the menu item you want to change and pressing the new key combination. To remove a shortcut key combination, place the mouse pointer over the menu item, then press ← or Del.

**IMPORTANT: New Keyboard Combinations Can Change Defaults**

If you assign a new keyboard combination that was previously assigned to something else, you are not warned. The previous assignment is removed and replaced by the new one. There is no automatic way to restore the default keyboard shortcut for a command. You must manually reassign the keyboard shortcut.

This feature does not maintain shortcuts that are normally assigned to all applications, such as Ctrl + C for copy. This might lead to inconsistencies in your GNOME applications.

Select one of the following options to specify how toolbar button labels display in your GNOME-compliant applications:

*Text below icons*
  
  Displays icon labels below the icons for each button.

*Text beside icons*
  
  Displays icons on the toolbar, with text beside the most important icons.

*Icons only*
  
  Displays icons only, without any text labels.

*Text only*
  
  Displays text labels on each button, without icons.
A preview of the selected option appears in the dialog.

### 3.3.4 Configuring the Screen Saver

A screen saver is a program that blanks the screen or displays graphics when the computer is not used for a specified amount of time. Screen savers originally protected monitors from having images burned into them. Now they are used primarily for entertainment or security.

To configure a screen saver click **Computer > Control Center > Look and Feel > Screensaver**.

**Figure 3.7**  *Screensaver Preferences Dialog*

From the list on the left select the screen saver theme you like. You can also select **Random** for a random selection of a screen savers or just a **Blank Screen**. A preview of the currently selected screen saver appears on the right or, by pressing the **Preview** button, you can test the selected screen saver in a fullscreen mode.

Use the slider to specify the amount of time that the computer is to be idle before the screen saver is activated. If you want the screen saver to be activated after the specified time the **Activate screensaver when computer is idle** checkbox should be checked. If
you also want the screen to lock automatically when the screen saver is activated the
Lock screen when screensaver is active checkbox should be checked.

3.3.5 Choosing a Theme

A theme is a group of coordinated settings that specifies the visual appearance of a part
of the desktop. You can choose themes to change the appearance of the desktop. Use
the Theme tab of the Appearance tool to select from a list of preinstalled themes. The
list of available themes includes several themes for users with accessibility requirements.

To choose a theme, click Computer > Control Center > Look and Feel > Appearance
> Theme.

Basic appearance and color settings for the desktop and applications are controlled using
themes. You can choose from a variety of preinstalled themes. Selecting a style from
the list overview applies it automatically. Customize opens another dialog where you
can customize the style of single desktop elements like window content, window borders,
and icons. Making changes and leaving the dialog by clicking Close causes the theme
to switch to Custom Theme. Click Save Theme to save your modified theme under a
custom name. The Internet and other sources provide many additional themes for
GNOME as .tar.gz files. Install these with Install.

The Customize Theme dialog has the following tabs and options:

Controls
The controls setting for a theme determines the visual appearance of windows,
panels and applets. It also determines the visual appearance of the GNOME-com-
pliant interface items that appear on windows, panels and applets (such as menus,
icons and buttons). Some of the control settings that are available are designed for
special accessibility needs. You can select a control setting in the Controls tab of
the Customize Theme dialog.

Colors
The colors of the text in windows, input boxes, selected items and tooltips (as well
as color of the text background) can be configured in the Colors tab of the Customize
Theme dialog.
Window Border
The window border setting for a theme determines the appearance of the borders around windows (window decorations). You can select the window border settings in the Window Border tab of the Customize Theme dialog.

Icons
The icon setting for a theme determines the appearance of the icons on panels and the desktop background. You can select the icon settings in the Icons tab of the Customize Theme dialog.

Pointer
The style and size of the mouse pointer can be configured in the Pointer tab of the Customize Theme dialog.

Procedure 3.1  Creating a Custom Theme

The themes that are listed in the Theme Preferences tool are different combinations of control settings, window frame options and icon options. You can create a custom theme that employs different combinations of options. To create a custom theme:

1 Click Computer > Control Center > Look and Feel > Appearance > Theme.

2 Select a theme from the list of themes and click Customize.

3 Select the controls option you want to use in the custom theme from the list in the Controls tabbed page.

4 Click the Colors tab, then select colors you want to use for windows, input boxes, text and other parts of the interface. Some control themes do not support setting custom colors.

5 Click the Window Border tab and select the window frame option that you want to use in the custom theme.

6 Click the Icons tab and select the icons option that you want to use in the custom theme.

7 Click the Pointer tab and select the mouse pointer option that you want to use in the custom theme.
8. **Click** Close > Save As.

A *Save Theme* dialog is displayed.

9. Type a name and a short description for the custom theme in the dialog, then click Save. The custom theme now appears in your list of available themes.

**Procedure 3.2 Installing a New Theme**

You can add a theme to the list of available themes. The new theme must be a compressed archive file (a *.tar.gz* file).

1. **Click** Computer > Control Center > Look and Feel > Appearance > Theme.

2. **Click** Install.

3. Select the file and click Open.

4. If you want to apply the new theme immediately click Apply New Theme. You can also Keep Current Theme.

### 3.3.6 Customizing Window Behavior

Use the *Window Preferences* tool to customize window behavior for the desktop. You can determine how a window reacts to contact with the mouse pointer or to double-clicks on its title bar and you can define which key to hold for moving an application window.

To customize window behavior click Computer > Control Center > Look and Feel > Windows.
When several application windows populate the desktop, the active window by default is the one last clicked. Change this behavior by activating *Select Windows When the Mouse Moves over Them*. If desired, activate *Raise Selected Window after an Interval* and adjust the latency with the slider. This raises the window a short time after the window receives focus.

Under *Titlebar Action*, it is possible to specify an action that is performed when the window's title bar is clicked. Select the desired action from the drop-down list. Possible actions include minimizing the window, maximizing it in one or both directions or rolling it up, leaving only the title bar visible. The default behavior is for the title bar to maximize in both directions.

Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt or the Windows key).

### 3.3.7 Configuring File Management Preferences

The file management preference include settings for the GNOME file manager Nautilus as well as the settings for handling of removable media. You can access the preferences in the Control Center by clicking *Computer > Control Center > Look and Feel > File Management* or directly from Nautilus by clicking *Edit > Preferences*. 
1 On the Views tab define options for various Nautilus views. For example, select if Nautilus should show hidden files and backup files.

2 On the Behavior tab define several options such as to open files or folders in Nautilus upon single or double mouse-click, or to include a Delete menu item in Nautilus which deletes files or folders directly from your file system instead of moving them to the trash.

3 On the Display tab configure the date format and the way icon captions appear in Nautilus.

4 Switch to the List Columns tab to configure the columns that appear in Nautilus, as well as the order in which they appear.

5 Click the Preview tab to specify for which files to show previews in Nautilus and if folders should show the number of items they contain.
6 Click the Media tab to specify actions that should be performed automatically whenever media such as audio CDs, video DVDs, blank disks, media players, digital cameras and other devices are connected. In general, you do not need to change these settings unless you want to change the behavior of a device when connected. If you attach a device for the first time and it behaves in an unexpected or undesired way, change the settings for the particular device.

7 For more information on the available options click Help.

8 Click Close when you are ready to apply changes.

3.3.8 Locking Desktop Functions

openSUSE ships with a graphical lockdown editor (pessulus package) that lets you disable (lockdown) certain desktop functions. This is useful if you want to restrict the actions that users can perform on a computer. For example, you might want to prevent command line operations on a computer that is for public use at a trade show.

If the pessulus package is already installed, start the Lockdown Editor from the main menu with Computer > Control Center > Look and Feel > Lockdown Editor or press Alt + F2 and enter pessulus.

Figure 3.10 General Lockdown Editor Settings
When the Lockdown Editor starts, it tries to connect to the GConf mandatory configuration source (xml:merged:$prefix/etc/gconf/gconf.xml.mandatory).

If you run pessulus as root, you have access to this configuration source and a lock icon is displayed next to the checkbox for each setting. Click the lock to specify if the setting is mandatory. If the setting is mandatory, regular users will not be able to change or override the setting. If you do not have access to the mandatory configuration source, the lock icon does not appear. In this case, all disabled settings are stored in the user's default configuration source and can be modified later using other tools such as gconf-editor or gconftool-2. For more information about GConf and mandatory configuration sources see “Using GConf” [http://library.gnome.org/admin/system-admin-guide/stable/] in the GNOME Desktop System Administration Guide.

Click a category on the left to view the settings for this category that can be disabled.

1. To disable access to the command line, saving to disk and printing (or prevent the user from modifying print settings) set the relevant options in the General category.

2. Use the options in the Panel category to lock down the panel, disable the panel applets you specify and disable the force quit, lock screen and log out options.

3. Use the options in the Epiphany Web Browser category to control access to features in Epiphany.

4. Use the options in the GNOME Screensaver category to lock the screen (when the screen saver goes active), enable or disable the logout (after a delay option in the unlock dialog box) and to enable or disable the switch user option in the unlock dialog box.

5. For more information on the available options of each category, click Help.

6. If all options are set according to your wishes, click Close to apply the changes.
3.3.9 Customizing the Main Menu

Use the *Main Menu* tool to customize the traditional GNOME main menu. The traditional GNOME menu is not enabled by default, but you can add it to your GNOME panel by right-clicking it and choosing *Add to Panel > Traditional Main Menu > Add > Close*. To customize the traditional GNOME main menu, use *Computer > Control Center > Look and Feel > Main Menu*.

*Figure 3.11  Main Menu Editor*

The current main menu submenus are displayed on the left of the main window, the items belonging to the selected submenu are shown on the right. Groups in a submenu are nested below that submenu. To find an item, click the arrow next to a submenu in the *Menus* list, select the group containing that item and locate the item in the *Items* list.

**NOTE: Implications of Main Menu Changes**

Changes you make to the main menu are not overwritten during a subsequent system update. Changes are applied after the latest menu view is generated.
**Procedure 3.3  Editing the Main Menu**

You can change the order in which items appear in the main menu, rename menu items, show (or hide) menu items, delete items from the menu or add new menu items. For example, you might want to place your frequently used applications at the top of the menu or at the top of their groups to make them easier to find. Adding new items to the main menu is helpful when you install an application, but it is also useful if you have other applications that do not currently appear on the menu. You can also add a directory, a link or another type of item to the menu.

1. To move a menu item click the menu item in the *Items* list on the right and drag it to a new location in the menu. You can move the item to a new location in the same menu or drop it on an item in the *Menus* list (to move it to a new menu or group). Use the *Move Up* and *Move Down* buttons to change an item's location in the menu.

2. To rename an existing menu item right-click the item in the *Items* list, select *Properties* and enter a new name.

3. To hide an item (so it does not appear in the menu) deactivate the checkbox next to the item in the *Items* list. An activated checkbox indicates that the item is currently shown in the menu. When an item is hidden it still remains in the *Items* list and can be shown at any time you decide you want it to (re)appear in the menu.

4. To delete an item from the *Items* list right-click the item and click *Delete*. If you want to show a deleted item in the menu again you must add it like you would a new application.

5. To add a new item, proceed as follows:
   
   5a  In the *Menus* list click the arrow next to the menu containing the group where you want to add the application, then select the group. The contents of that group appear in the *Items* list.

   5b  Click *New Item* and select the *Type* of menu item to add. For example, to add an application select *Application*.

   5c  Click *Browse* and select the item to add.

   5d  Enter a *Name* for the new menu item.
If you want a short description to appear in the main menu during a hover state enter the description in the Comment field.

If you want to assign an icon to the new item, click the image frame on the left, then select an icon for the item. If you do not select an icon, the item appears in the menu without an icon.

If you want to restore the default menu layout click Revert.

If all options are set according to your wishes click Close to apply your changes.

NOTE

The first time you use the Main Menu application to edit the menu, changes do not take effect until your next login. Subsequent changes appear immediately.

3.3.10 Configuring Desktop Effects

Compiz is a compositing window manager for the X Window System that uses 3D graphics hardware to create fast compositing desktop effects for window management. Effects are implemented as loadable plugins. Compiz lets you turn your desktop into a rotating 3D cube, tile windows so they do not overlap and switch tasks while viewing live thumbnails. You can enable translucent or transparent windows, zoom in and out of the desktop screen, and use other window effects such as shadows, fading and transformations. You can also configure windows to snap to other windows and screen edges when they are moved.
Enabling Desktop Effects

To enable desktop effects you need a graphics adapter capable of providing 3D support and the graphics driver that Linux uses to operate the graphics adapter. This driver must be able to handle OpenGL (or 3D) requests from the Linux kernel. If your configuration is compatible with desktop effects it will be enabled by default. If your configuration does not support desktop effects you will be warned upon activation.

To enable or disable desktop effects follow these steps:

1. Click Computer > Control Center.
2. Click Desktop Effects in the Look and Feel group.
3 If your system is configured for desktop effects check *Enable Desktop Effects*. To keep desktop effects enabled press *Yes* in the dialog that opens. Otherwise, the desktop effects will be deactivated automatically in ten seconds.

To disable desktop effects uncheck the *Enable Desktop Effects* option.

4 The default set of desktop effects is now enabled. You can change the enabled effects and their settings on the several tabs of the *Desktop Effects* dialog or just select a *Profile* from the dropdown list. To activate the selected profile press the green button.

**Modifying Desktop Effects**

A simplified configuration tool for desktop effects is included in the *Look and Feel* section of GNOME Control Center. Open *Desktop Effects* tool from the main menu by clicking **Computer > Control Center > Look and Feel > Desktop Effects**.
1 Use the *Info* tab to get general information about the current desktop effect settings.

2 Use the options on the *Animations* tab to specify what happens when you open, close, focus or minimize windows.

3 Use the options on the *Effects* tab to specify what type of *Switcher* to use. This is the desktop effect activated when switching between windows using the Alt + → | combination. This is where you can set various desktop effects like opacity of the desktop cube or wobbling windows.

4 Use the options on the *Desktop* tab to configure the representation of virtual desktops you want to use (three dimensional *Desktop Cube* or planar *Desktop Wall*) and to set how many virtual desktops you want to use.

5 Use the options on the *Accessibility* tab to configure screen and area zoom.

6 Use the *Edges* tab to configure functions associated with active screen edges.

7 For more information on the individual options, click *Help.*
8 If all options are set according to your wishes, click Close to apply the changes.

**NOTE: Advanced Configuration Tool**

An advanced configuration tool can be started from a terminal emulator with command `ccsm`. This offers a greater selection of configuration options than the simplified tool in GNOME Control Center.

You can also use gconf-editor to change desktop effects settings.

1 Click *Computer > More Applications > System > GNOME Configuration Editor* or press Alt + F2 and enter `gconf-editor`.

2 Navigate to the `apps/compiz/general` and `apps/compiz/plugins` registry folders and make the desired changes.

3 Click *File > Quit* to close the *Configuration Editor*.

**Desktop Effects Shortcuts**

The following table contains a list of the default keystrokes and mouse movements you can use to perform desktop effects. To change any of these shortcuts, see use the advanced configuration tool (*ccsm*). The shortcuts for zoom function can be configured in the *Desktop Effects* tool available from GNOME Control Center.

**Table 3.1 Desktop Effects Shortcuts**

<table>
<thead>
<tr>
<th>Effect</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panoramic view of all desktops (if the desktop cube effect is enabled)</td>
<td>Ctrl + Alt + ↓ (use the Left and Right arrows to scroll)</td>
</tr>
<tr>
<td>Rotate desktop cube (if the desktop cube effect is enabled) or switch desktops (if the desktop wall effect is enabled)</td>
<td>Ctrl + Alt + ← or → (↑ or ↓ keys can be used in case of desktop wall effect with multiple rows)</td>
</tr>
<tr>
<td>Rotate desktop cube manually (if the desktop cube effect is enabled)</td>
<td>Ctrl + Alt + left-click the desktop and drag the mouse pointer</td>
</tr>
<tr>
<td>Effect</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Rotate desktop cube (if the desktop cube effect is enabled) or switch desktops (if the desktop wall effect is enabled) while keeping the current active window with you</td>
<td>Ctrl + Alt + Shift + ← or →</td>
</tr>
<tr>
<td>Switch windows (thumbnail view)</td>
<td>Alt + →</td>
</tr>
<tr>
<td>Wobbly window (if the wobbly effect is enabled)</td>
<td>Left-click the window and drag</td>
</tr>
<tr>
<td>Zoom in manually (if the screen zoom is enabled)</td>
<td>Super key (Windows key) and scroll wheel up</td>
</tr>
<tr>
<td>Zoom out manually (if the screen zoom is enabled)</td>
<td>Super key (Windows key) and scroll wheel down</td>
</tr>
<tr>
<td>Zoom in area under mouse pointer (if the area zoom is enabled)</td>
<td>Shift, super key (Windows key) and scroll wheel up</td>
</tr>
<tr>
<td>Zoom out area under mouse pointer (if the area zoom is enabled)</td>
<td>Shift, Super key (Windows key) and scroll wheel down</td>
</tr>
</tbody>
</table>

### 3.4 Personal

In the following sections find examples of how to configure some personal aspects of your GNOME desktop, like your password or keyboard shortcuts. For configuration of assistive technologies refer to Chapter 4, *Assistive Technologies* (page 85).

#### 3.4.1 Changing Your Password

For security reasons, it is a good idea to change your login password from time to time.

To change your password:

1. Click *Computer > Control Center > Personal > Change Password.*
2 Type your old (current) password.

3 Type your new password.

4 Confirm your new password by typing it again, then click OK.

### 3.4.2 Customizing Keyboard Shortcuts

A keyboard shortcut is a key or combination of keys that provides an alternative to standard ways of performing an action. You can customize the keyboard shortcuts for a number of actions.

To open the Keyboard Shortcuts tool click **Computer > Control Center > Personal > Keyboard Shortcuts**.

**Figure 3.14  Keyboard Shortcuts Dialog**

To change the shortcut keys for an action, select the action and then press the keys you want to associate with the action. To disable the shortcut keys for an action, click the shortcut for the action, then press `<—`. 
3.5 System

In the following sections you will find examples of how to configure some system aspects of your GNOME desktop like language settings, power management, preferred applications, session (and session sharing) preferences, Beagle search options and audio preferences.

3.5.1 Configuring Language Settings

openSUSE can be configured to use any of a number of languages. The language setting determines the language of dialogs and menus and can also determine the keyboard and clock layout.

You can set the following language settings:

- Primary language
- Whether the keyboard language setting should correlate to the primary language
- Whether the time zone should correlate to the primary language
- Secondary languages

To configure your language settings:

1. Click Computer > Control Center > System > Language.

2. Enter the root password.

   If you do not know the root password contact your system administrator. You cannot continue without the root password.

3. Specify the primary language, whether you want to adapt the keyboard layout or time zone to the primary language, and any secondary languages you need to support on the computer.
4 Click Accept.

The language configuration settings are written to several configuration files. This process can take a few minutes. The new settings take effect immediately after they are written to the configuration files.

### 3.5.2 Configuring Network Proxies

The Network Proxy Configuration tool lets you configure how your system connects to the Internet. You can configure the desktop to connect to a proxy server and specify the details of the server. A proxy server is a server that intercepts requests to another server and fulfills the request itself, if it can. You can specify the Domain Name Service (DNS) name or the Internet Protocol (IP) address of the proxy server. A DNS name is a unique alphabetic identifier for a computer on a network. An IP address is a unique numeric identifier for a computer on a network.

Click *Computer > Control Center > System > Network Proxy*.

**Figure 3.15 Network Proxy Configuration Dialog**

For more information on the individual options, click *Help*. 
3.5.3 Configuring Bluetooth Settings

The Bluetooth module lets you set the visibility of your machine over Bluetooth, the name of your machine used for Bluetooth communication and whether you want to show the Bluetooth applet in your panel. To configure Bluetooth connectivity, follow these steps:

1. Click `Computer > Control Center > System > Bluetooth` or right-click the Bluetooth icon in GNOME panel and select `Preferences`.

2. On the `General` tab set the visibility of the Bluetooth applet icon in the Notification area of the GNOME panel. Right-click the applet icon to set connections with Bluetooth devices and file transfers.

3. On the `General` tab use options under `Power switches` for switching the Bluetooth adapter on and off. The available options depend on the hardware used.

4. If the Bluetooth hardware is available and switched on, there is another available tab. Under `Visibility setting` set the visibility of the machine over a Bluetooth network. If the `Temporary visible` option is chosen use the slider to set the visibility period. The `Friendly name` option specifies the name of the computer in the Bluetooth network.

5. The `Known devices` section lists all known Bluetooth devices. Use the button with the plus icon to configure a new device connection.

6. Click `Close`.

To configure file sharing over Bluetooth, follow these steps:

1. Click `Computer > Control Center > System > Personal File Sharing`.

2. In the `Share Files over Bluetooth` section configure the sharing of files in your `~/Public` directory. Use `Share Public files over Bluetooth` to activate or deactivate sharing of this directory. Specify whether remote devices can delete public files and whether they are required to bond with your computer.

3. In the `Receive Files over Bluetooth` section specify whether to accept files sent over Bluetooth, from which devices and whether you want to be notified about received files.
4 Click Close.

### 3.5.4 Configuring Power Management

The Power Management module lets you manage your system's power-saving options. It is especially useful for extending the life of a laptop’s battery charge. However, several options also help to save electricity when you are using a computer that is plugged in to an electrical power outlet.

Sleep mode shuts down the computer when it is dormant for a specified period of time. Whether you are using battery or AC power, you can specify the period of time that the computer remains dormant before it is put to sleep. You can also put the computer’s display to sleep without shutting down the computer, saving the power required by the display.

Sleep mode is especially important when the computer is operating under battery power. Both the screen and the computer draw power from the battery, so you can save a significant amount of battery power by shutting down one or both. It is common to put the display to sleep after a shorter period of time. Then, if the computer remains dormant for an additional period of time, it is also put to sleep.

There are several sleep modes or actions you can set in the Power Management module:

- **Do nothing**
  The computer does not shut down or automatically go into any kind of power-saving mode. If you have a laptop, the laptop continues to run normally when the lid is closed.

- **Blank screen**
  The screen is blanked, reducing power consumption.

- **Suspend**
  Suspend mode turns off power-consuming computer components such as the display and the hard drive without saving the contents of RAM. Any unsaved data is lost.

- **Hibernate**
  The computer saves the contents of RAM to the hard disk and shuts down. When you turn the computer on again, the saved data is put back into RAM, restoring your computer to its previous state. Hibernate requires an amount of free hard disk space equal to the amount of RAM installed on the computer.
To open the Power Management module, click Computer > Control Center > System > Power Management.

**Procedure 3.4  Specifying Your Computer's Sleep Settings**

1. Click the tab for the type of power you are using: if your computer uses AC power click *On AC Power*. If your computer runs on battery power click *On Battery Power*. If your computer operates on both AC and battery power, you can configure the settings on both tabs.

2. Use the sliders to set the amount of inactive time that passes before the display and computer go into sleep mode.

   When the display is in sleep mode the computer continues to run. When the computer is in sleep mode, power to the display and hard disk is shut off and the computer uses only the power needed to maintain the contents of RAM.

3. If the computer is a laptop, set the actions you want taken when the laptop lid is closed.

4. If you configure how a laptop manages battery power, specify the action you want taken if battery power reaches a critical level.

   Choose the option you prefer by selecting it from the menu. If you have sufficient free disk space, *Hibernate* is the best choice.

5. On the *General* tab you can set further options, for example the action to take when the power button is pressed or the sleep type to use when the computer is inactive. The options available there depend on the type of computer you use (laptop or other computer).

6. You can also define when and how to display the power icon in the notification area and whether to use sound alarm in event of an error.

7. On the *Scheduling* tab you can set automatic wakeups of the computer in specified time on specified days of the week.

8. When all options are set according to your wishes, click *Close*. The options you selected go into effect immediately.
3.5.5 Setting Preferred Applications

The Preferred Applications module allows you change the default application for various common tasks such as browsing the internet, sending mails or transferring data with FTP.

**Figure 3.16  Preferred Applications**

1. Click *Computer > Control Center > System > Preferred Applications*.

2. Click the tab for the type of application you want to set.

3. Select one of the available applications from the *Select* menu or enter the command used to start the application.

4. Click *Close*.

The changes take effect immediately.
3.5.6 Setting Session Sharing Preferences

The *Remote Desktop Preference* dialog box lets you share a GNOME desktop session between multiple users and set session-sharing preferences.

**IMPORTANT: Sharing Desktop Sessions Affects System Security**

Be aware that sharing desktop sessions can be a security risk. Use the restriction options available. If you need to adjust the options to a lower security level, do not forget to switch back to a higher security level as soon as possible.

1. Click *Computer > Control Center > System > Remote Desktop*.

![Remote Desktop Preferences dialog box](image)

2. To share your desktop session with other users activate *Allow other users to view your desktop*. All keyboard, pointer and clipboard events from the remote user are ignored.

3. If you want or need to allow other users to access and control your session from a remote location, activate *Allow other users to control your desktop*. Click the highlighted text below to send the system address by e-mail to a remote user.

4. Make use of the security options available. If *Ask you for confirmation* is activated, remote users require your confirmation before they can connect to your session. To achieve a higher security level, activate *Require the user to enter this password* (if authentication is used).
3.5.7 Configuring Search with Beagle Settings

Beagle is the search engine used on the GNOME desktop. By default, Beagle is configured to start automatically and index your home directory. If you want to change these settings, specify the number of results displayed after a search or change the Beagle privacy settings, click *Computer > Control Center > System > Search Settings*.

*Figure 3.17  Search Preferences*

For more information, see Section 6.4, “Setting Search Preferences” (page 109) and Section 6.6, “Preventing Files and Directories from Being Indexed” (page 111).

3.5.8 Managing Sessions

This module lets you manage your sessions. A session occurs between the time that you log into the desktop environment and the time that you log out. You can set session preferences and specify which applications to start when you begin a session. You can configure sessions to save the state of applications and then restore the state when you start another session.

You can also use this preference tool to manage multiple sessions. For example, you might have a mobile session which starts applications you use most frequently when traveling, a demo session that starts applications used to present a demonstration or
slide show to a customer and a work session that uses a different set of applications when you are working in the office.

Click Computer > Control Center > System > Sessions.

**Figure 3.18  Sessions Preferences**

![Sessions Preferences](image)

**Procedure 3.5  Setting Session Preferences**

1. On the *Startup Programs* tab you can add programs to start automatically when beginning a session. Click *Add* and specify the command that runs this application. The commands are executed automatically when you log in.

   You can also *Remove* a startup application or *Edit* it to change the command, name or description of a startup application.

2. Use the *Options* tab to set, whether or not running applications should be remembered when you log out. You can also save the currently running applications by pressing *Remember Currently Running Application*.

**3.5.9 Setting Software Updates**

The *Software Updates* tool lets you configure the frequency of update checking, automatic updates and update notifications.
1 Click **Computer > Control Center > System > Software Updates** to open the **Software Updates Preferences** tool.

2 In the *Update Settings* section, set the frequency of update checking and whether updates should be installed automatically. You can limit automatic installation to security updates.

3 In the *Display Notification* section, set whether you want to be notified when updates are available or when long tasks have been completed.

4 Click **Close**.

### 3.5.10 Setting Sound Preferences

The *Sound Preferences* tool lets you manage sound devices. You can also specify which sounds to play when particular events occur.

Click **Computer > Control Center > System > Sound** to open the *Sound Preferences* tool.

#### Setting Sound Devices

Use the *Devices* tab to configure the device to use for various types of sounds.

*Figure 3.19  Setting Sound Devices*
Click the drop-down list for each type of sound and select the device to use. In most cases *Autodetect* is the best choice, unless you want to use a specific device. Press *Test* to test the sound output.

**Setting Sound Events**

Use the *Sounds* tab to configure sound event functions.

*Figure 3.20  Setting Sound Events Preferences*

Check *Play alerts and sound effects* to play sounds when particular events occur in the desktop. To enable sounds when buttons are clicked, check *Play sound effects when buttons are clicked*. To enable sound alerts check *Play alert sound*.

Finally, select the *Sound Theme* to use or set the sound of each event individually.
3.5.11 Configuring Administrative Settings with YaST

For your convenience, YaST is available from the Control Panel as well as the Applications menu. For information about using YaST, refer to Start-Up (↑Start-Up).
Assistive Technologies

The GNOME user interface incorporates many accessibility features and specially designed assistive technologies which contribute greatly to the accessibility of the GNOME desktop.

This chapter describes several assistive technology applications designed to meet the needs of users with physical disabilities such as low vision or impaired motor skills.

4.1 General Accessibility Features

A number of technologies can be of assistance to people with different types of disabilities. These are covered in this section.

4.1.1 Desktop Appearance Enhancement

There are several ways to customize the appearance of the GNOME desktop to suit your specific needs. Themes are the most effective way to change the appearance of the desktop in a consistent manner. You can also customize different components of the desktop to achieve the display settings that you require. You can configure the desktop and applications in addition to using themes or as an alternative to themes. For details, see Chapter 3, Customizing Your Settings (page 45).
Customizing Specific Components of the Desktop

This section describes how to customize the font settings for the desktop and frequently-used applications.

If you have difficulty with the default font type and size on the desktop and desktop background, you can customize the font settings to suit your needs.

The Appearance Preferences tool allows you to specify the default fonts for the desktop. To start the Appearance Preferences tool, choose System > Control Center > Appearance. The Fonts tab contains the following options:

Application Font
Click on this button to select a default font to use for the text that is displayed on the desktop, including the text displayed on the windows and dialogs associated with GNOME-compliant applications.

Document Font
Click on this button to select a font to use for displaying documents.

Desktop Font
Click on this button to select a font to use for the text that is displayed on the desktop background only.

Window Title Font
Click on this button to select a font to use for the text that is displayed in the title bar area of windows.

Fixed Width Font
Click on this button to select a font to use for editing documents.

Font Rendering
To specify how to render fonts on the desktop select either:

• Monochrome,

• Best Shapes,

• Best Contrast

• or Subpixel Smoothing.
If you use large fonts, you may need to change the size of panes in some applications, such as the file manager and Help browser.

By default, GNOME applications use the default font specified in the Appearance Preference tool. Some applications allow this default font to be customized.

**Customizing Desktop Contrast**

To achieve a high-contrast or low-contrast desktop, perform the following steps:

1. Use the Appearance Preference tool to select the high-contrast or low-contrast desktop theme that you require from the Theme tab.

2. Use the Background tab to customize your desktop background as follows:
   - Set the Desktop Wallpaper to No Wallpaper.
   - Set the Desktop Colors to “Solid Color”.
   - Select a background color that suits your needs.

3. Ensure that the Use colors from system theme option is selected in the Colors tabbed section of the Editing Profile dialog.

4. In the gedit text editor, ensure that the Use default theme colors option is selected in the Colors & Fonts tabbed section of the Control Center dialog.

**Customizing Desktop Fonts**

To achieve a large-print desktop, perform the following steps:

1. Use the Appearance Preferences tool to select the Large Print theme.

2. Click on the Apply Font button to increase the size of the font that is used on the desktop and on window frames.

3. Use the Desktop Font option to achieve a large-print desktop.
If the Use default theme font option is selected in the gedit (Text Editor) Control Center dialog, gedit uses the font size that is specified in the large-print theme that you selected.

If you use applications that use panes, such as the file manager and help browser, you may need to change the size of panes to accommodate the large print. See the online help for the appropriate application for more information.

### 4.2 Mobility Impairments

Mobility impairments can have many causes. Poor muscle control or weakness can make using standard keyboards and mouse devices difficult. For instance, some people are unable to type two keys simultaneously, while others tend to hit multiple keys or to bounce keys when pressing or releasing them. People who are able to use only one hand likewise have difficulties with some keyboard and mouse tasks.

#### 4.2.1 Configuring Mouse Behavior

The following sections describe how to modify the behavior of the mouse to suit your needs. To open the Mouse Preferences tool, choose System > Control Center > Mouse.

**Mouse for Left-Handed Use**

To configure the mouse for left-handed use, click on the Buttons tab in the Mouse Preferences dialog and select the Left-handed mouse option. When you select this option, the system swaps the functions of the left and the right mouse button immediately.

**Double-Click Behavior**

If you have difficulty double-clicking, you can increase the period of time that the system allows to elapse between the first click and the second click of a double-click. For example, if the double-click timeout setting is 0.4 seconds, you must perform the second click of a double-click within 0.4 seconds of the first click. If the second click occurs more than 0.4 seconds after the first click, the system interprets the two clicks as two single clicks.
To configure the double-click timeout setting perform the following steps:

1. Click on the Buttons tab in the Mouse Preferences dialog.

2. Use the Timeout slider to specify the timeout in seconds that the system allows between the two clicks of a double-click. Moving the slider to the right will increase the timeout interval.

3. Double-click on the light bulb to the right of the slider to test the setting. If you perform the two clicks of the double-click within the timeout specified, the light bulb lights up fully to display a yellow glow around the bulb. If you do not double-click within the timeout specified, the light bulb does not light fully. You should increase the timeout setting and try again. When the light bulb lights, the timeout setting is suitable for your needs.

**Mouse Pointer Size**

To change the size of the mouse pointer that is displayed on the desktop, click on the Pointers tab in the Mouse Preferences dialog. This will display a list of pointer themes and sizes available.

By default, GNOME does not include mouse pointer themes. For details on how to install and use pointer themes see Section 3.3.5, “Choosing a Theme” (page 57).

**Mouse Speed and Sensitivity**

To configure the speed and sensitivity of the mouse, perform the following steps:

1. Click on the Motion tab in the Mouse Preferences dialog.

2. In the Pointer Speed section, use the Acceleration slider to specify the speed at which the mouse pointer moves around the screen when you move the mouse.

   If you select a low setting, the mouse pointer moves at a speed similar to the speed at which you are physically moving the mouse. This means that you need to physically move the mouse larger distances to cover the screen area. If you select a high setting, the mouse pointer moves at a faster speed than the speed at which you physically move the mouse. This means that you need to physically move the mouse smaller distances to cover the screen area.
3 Use the Sensitivity slider to specify how responsive the mouse pointer is to movements of the mouse. Moving the slider to the right will increase sensitivity and moving it to the left will decrease sensitivity.

4 Use the slider in the Drag and Drop section to modify the distance that you must move an item with the pointer before the action is interpreted as a drag and drop action.

Configuring an Accessible Keyboard

Use the Keyboard Preference tool to configure the keyboard accessibility options. To open the Keyboard Preference tool, choose System > Control Center > Keyboard. Accessibility options can be enabled by selecting the Accessibility tab.

Configuring an Accessible Mouse

Use the Mouse Preferences tool to configure the mouse accessibility options. To open the Mouse Preferences tool, choose System > Control Center > Mouse. Accessibility options can be enabled by selecting the Accessibility tab.

4.2.2 GNOME On-Screen Keyboard

The GNOME On-Screen Keyboard (GOK) displays virtual keyboards on your desktop. You can use the standard mouse pointer or alternative pointing device to operate the virtual keyboards. GOK displays the following types of keyboards:

- Composer Keyboards enable you to compose text. To type alphanumeric characters, select the characters on the composer keyboard.

- Dynamic Keyboards reflect the applications that are currently running on the desktop. For example, On-Screen Keyboard generates dynamic keyboards that contain keys to represent the applications that are running on your desktop or the menus that are contained in an application.

You must enable assistive technology services before you are able to use many of the available Accessibility tools.

1 Choose System > Control Center > Assistive Technologies.
2 Select *Enable assistive technologies* and press *Close* and *Log Out*.

3 Log back in. Assistive technology services are now activated.

### 4.2.3 Maximizing Application Windows

If you are an On-Screen Keyboard user, you cannot use any application in Full-Screen mode because the application window obscures the On-Screen Keyboard display.

To resize the window for use with the On-Screen Keyboard application, perform the following steps:

1. Do not enable the Full-Screen mode in the application.

2. Give focus to the application window.

3. Press F10 to maximize the application.

### 4.3 Orca

Visual limitations range from low vision to blindness. Users with visual disabilities encounter problems when seeing text or images on a computer screen and when performing tasks that require eye-hand coordination, such as moving a computer mouse. Text size and color can make a big difference in legibility for people with low vision.

Orca is a flexible, extensible, and powerful assistive technology for people with visual impairments. Using various combinations of speech synthesis, braille and magnification, the Orca Screen Reader and Orca Magnifier application enable users with limited or no vision to use the GNOME desktop and associated applications. The screen reader also supports Braille.
### 4.3.1 Running Orca

For a text-only guided setup, open a *Run* dialog with Alt + F2, enter `Orca text-setup` and press Enter.

The first time Orca is launched you will be presented with a list of languages from which to choose. Enter the ID number of your language (for example, 7 for American English) and press Enter.

When you run Orca for the first time, it will automatically enter setup mode. If you want to run setup at some later point, you can pass the `setup` option to Orca the next time you run it. Furthermore, while Orca is running you can press Ins + Space to bring up Orca's configuration GUI. Finally, Orca provides a text setup utility that you can start by passing the `--text-setup` option to Orca. All of these options will create a `~/.orca/user-settings.py` file that holds your Control Center and will also enable the accessibility infrastructure. You need to log out and log back in for the new setting to take effect.

Start Orca by typing `orca` in a terminal session window. You can do so from a virtual console window if you do not yet have access to the GUI. With the GUI installed you can also press Alt + F2 to bring up the *Run* dialog and then type the command `orca` (followed by any optional parameters) and press Enter. Orca will automatically enter text setup mode if you run it from a virtual console window or if your GUI environment is not yet set up for accessibility.

To quit Orca press Ins + Q (or CapsLock + Q in laptop layout mode). A *Confirmation* dialog will appear.

### 4.3.2 Braille Page

The braille page allows you to customize various aspects of braille usage.

The first control on the braille page is the *Enable braille support* check box. This check box toggles whether or not Orca will make use of a braille display.

Orca's braille monitor provides an on-screen representation of what takes place on the braille display. This feature is mostly for demonstration purposes, but is also useful for Orca developers who do not have access to a braille display.
The *Abbreviated role names* check box determines the manner in which role names are displayed and can be used to help conserve real estate on the braille display.

When checked, this feature tells Orca to not present the $1$ string at the end of a line.

The *verbosity* radio button group determines the amount of information that will be, in certain situations, converted to braille.

### 4.3.3 Magnifier Page

The magnifier page allows you to enable/disable magnification and specify how magnification is performed.

The first control on the magnifier page is the *Enable magnifier* check box. This check box toggles whether or not Orca will provide magnification. This option, along with the ability to enable speech and to enable braille support, allows Orca to be tailored to meet the needs of a wide variety of users.

Two zoomer GUI controls determine magnification characteristics: *Scale factor*, which sets magnification power and *Position*, which sets the location and size of the magnifier window.
Part II. Internet Connectivity, Files and Resources
Accessing Network Resources

From your desktop, you can access files and directories or certain services on remote hosts or make your own files and directories available to other users in your network. openSUSE® offers the following ways of accessing and creating network shared resources.

- **Network Browsing:** Your file manager, Nautilus, lets you browse your network for shared resources and services. Learn more about this in Section 5.3, “Accessing Network Shares” (page 99).

- **Sharing Folders in Mixed Environments:** Using Nautilus, configure your files and folders to share with other members of your network. Make your data readable or writable for users from any Windows or Linux workstation. Learn more about this in Section 5.4, “Sharing Folders” (page 100).

- **Managing Windows Files:** openSUSE can be configured to integrate into an existing Windows network. Your Linux machine then behaves like a Windows client. It takes all account information from the Active Directory domain controller, just as the Windows clients do. Learn more about this in Section 5.5, “Managing Windows Files” (page 102).

- **Configuring and Accessing a Windows Network Printer:** You can configure a Windows network printer through the GNOME Control Center. Learn how to configure this in Section 5.6, “Configuring and Accessing a Windows Network Printer” (page 103).
5.1 Connecting to Your Network

You can connect to a network with wired and wireless connections. To view your network connection status, click Computer. In the Status area of the main menu, the Network Connections icon shows your network connection status. Click the icon to open the YaST Network Settings module. You can use this module to configure your network setup method or to edit your network card configuration.

5.2 General Notes on File Sharing and Network Browsing

Whether and to which extent you can use file sharing and network browsing on your machine and in your network highly depends on the network structure and on the configuration of your machine. Before setting up either of them, contact your system administrator to make sure that your network structure supports this feature and to check whether your company's security policies permit it.

Network browsing, be it SMB browsing for Windows shares or SLP browsing for remote services, relies heavily on the machine's ability to send broadcast messages to all clients in the network. These messages and the clients' replies to them enable your machine to detect any available shares or services. For broadcasts to work effectively, your machine must be part of the same subnet as all other machines it is querying. If network browsing does not work on your machine or the detected shares and services do not meet with your expectations, contact your system administrator to ensure that you are connected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open to send and receive network messages that provide details on the network and the availability of shares and services. The standard openSUSE is configured for tight security and has a firewall that protects your machine against the Internet. To adjust the firewall configuration, you would either need to ask your system administrator to put your interface into the internal zone or to tear down the firewall entirely (depending on your company's security policy). If you try to browse a network with a restrictive firewall running on your machine, Nautilus warns you that your security restrictions are not allowing it to query the network.
5.3 Accessing Network Shares

Networking workstations can be set up to share folders. Typically, files and folders are marked to allow users remote access. These are called network shares. If your system is configured to access network shares, you can use your file manager to access these shares and browse them just as easily as if they were located on your local machine. Your level of access to the shared folders (whether read-only or write access, as well) is dependent on the permissions granted to you by the owner of the shares.

To access network shares, open Nautilus and click Network from the Places pane. Nautilus displays the servers and networks that you can access. Double-click on a server or network to access its shares. You might be required to authenticate to the server by providing a username and password. Common network shares are SFTP accessible resources (SSH File Transfer Protocol) or Windows shares.

Figure 5.1  Network File Browser

5.3.1 Adding a Network Place

1 Click Computer > Nautilus File Browser > File > Connect to Server.
2 Select a service type, then specify the required information for your type of service.

3 Specify the name you want displayed for this connection, then click Connect.

An icon for the network place is added to the desktop.

5.4 Sharing Folders

Sharing and exchanging documents is a must-have in corporate environments. Nautilus offers you file sharing, which makes your files and folders available to both Linux and Windows users.

5.4.1 Enabling Sharing on the Computer

Before you can share a folder, you must enable sharing on your computer. To enable sharing:

1 Start the YaST from the main menu.

2 Enter the root password.

3 Click Network Services.

4 Click Windows Domain Membership.

5 Click Allow Users to Share Their Directories, then click OK.
5.4.2 Enabling Sharing for a Folder

To configure file sharing for a folder:

1. Open Nautilus.

2. Right-click a folder, then select Sharing Options from the context menu.

3. Select Share this folder.

4. (Optional) If you want other people to be able to write to the folder, select Allow other people to write in this folder.

5. (Conditional) If the folder does not already have the permissions that are required for sharing, click Add the permissions automatically.

The folder icon changes to indicate that the folder is now shared.

IMPORTANT: Samba Domain Browsing

Samba domain browsing only works if your system's firewall is configured accordingly. Either disable the firewall entirely or assign the browsing interface to the internal firewall zone. Ask your system administrator about how to proceed.
5.5 Managing Windows Files

With your openSUSE machine being an Active Directory client, you can browse, view and manipulate data located on Windows servers. The following examples are just the most prominent ones:

Browsing Windows Files with Nautilus
Use Nautilus' network browsing features to browse your Windows data.

Viewing Windows Data with Nautilus
Use Nautilus to display the contents of your Windows user folder just as you would for displaying a Linux directory. Create new files and folders on the Windows server.

Manipulating Windows Data with GNOME Applications
Many GNOME applications allow you to open files on the Windows server, manipulate them and save them back to the Windows server.

Single-Sign-On
GNOME applications, including Nautilus, support Single-Sign-On. This means that to access other Windows resources, such as Web servers, proxy servers or groupware servers like MS Exchange, you do not need to reauthenticate. Authentication against all these is handled silently in the background using the username and password you provided on login.

To access your Windows data using Nautilus, proceed as follows:

1. Open Nautilus and click Network in the Places pane.
2. Double-click Windows Network.
3. Double-click the icon of the workgroup containing the computer you want to access.
4. Click the computer’s icon (and authenticate if prompted to do so) and navigate to the shared folder on that computer.

To create folders in your Windows user folder using Nautilus, proceed as you would when creating a Linux folder.
5.6 Configuring and Accessing a Windows Network Printer

Being part of a corporate network and authenticating against a Windows Active Directory server, you can access corporate resources such as printers. GNOME allows you to configure printing from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, proceed as follows:

1. Start the GNOME Control Center from the main menu.

2. Select Hardware > Printing.


4. Select Windows Printer via SAMBA.

5. Open the SMB Browser with Browse and select a workgroup, a server and the printer. Either enter the authentication credentials or choose to be prompted for authentication each time when accessing the printer. Click Forward.

6. Choose the printer's manufacturer and the printer model from the list and select a driver. The one that is marked with recommended normally produces the best results. Proceed with Forward and provide a name, a description and a location for the printer. Click Apply.

7. Adding a printer requires root privileges, so you must enter the root password as the final step to adding it.

To print to the Windows network printer configured above, select it from the list of available printers.
Searching with Beagle

Beagle is a search tool that indexes your personal information space (normally your home directory) in order to carry out search requests. Using Beagle, you can find documents, e-mails and attachments, Web history, IM/IRC conversations, address book contacts, calendar appointments, notes, source code, images, music (and video) files, archives (and their contents) and applications.

6.1 Using Beagle

To use Beagle, click *Computer*, enter your search terms in the *Search* field, then press Enter. The results are displayed in the Desktop Search dialog box.

*Figure 6.1  Desktop Search Dialog Box*
You can use the results lists to open a file, forward it via e-mail or display it in the file manager. Simply right-click an item in the results list and select desired option. The options available for an item in the results list are determined by its filetype. Selecting a file in the list displays a preview of the file and information such as the title, path, and date the file was last accessed or modified.

Figure 6.2  Desktop Search Dialog Box With a File Selected

Use the Find In menu to limit your search to files in a specific location (such as your address book or Web pages) or to display only a specific type of file in your results list. The View menu lets you sort the items in your results list according to name, relevance or the date the file was last modified.

You can also access Desktop Search by clicking Computer > More Applications > System > Search.

6.2 Search Tips

• You can use both uppercase and lowercase letters in search terms. Searches are not case-sensitive.

• To search for optional terms, use OR (for example, apples OR oranges).
IMPORTANT

The OR has to be capitalized when used to indicate optional search terms.

- To exclude search terms, use a minus sign (−) in front of the term you want to exclude (for example, apples -oranges will find results containing apples but not oranges).

- The root form of a search term is used when searching (for example, a search for driving will match drive, drives, and driven).

- To search for an exact phrase or word, put quotation marks (" ") around the phrase or word.

- Common words such as "a", “the” and “is” are ignored.

6.3 Performing a Property Search

By default, the Beagle search tool looks for search terms in the text of documents and in their metadata. To search for a word in a particular property, use property:query. For example, author:john searches for files that have “john” listed in the Author property.

Table 6.1  Supported Property Keywords

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Applies to</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>album</td>
<td>Music files</td>
<td>Name of album</td>
</tr>
<tr>
<td>artist</td>
<td>Music file</td>
<td>Name of artist</td>
</tr>
<tr>
<td>author</td>
<td>Document</td>
<td>Author of the document (same as Creator of the Document)</td>
</tr>
<tr>
<td>creator</td>
<td>Document</td>
<td>Creator of the document, mapped to dc:creator (for example, creator of PDF files)</td>
</tr>
<tr>
<td>email</td>
<td>Address book</td>
<td>E-mail address</td>
</tr>
<tr>
<td>Keyword</td>
<td>Applies to</td>
<td>Property</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>emblem</td>
<td>File</td>
<td>Emblem used in Nautilus</td>
</tr>
<tr>
<td>extension or ext</td>
<td>File</td>
<td>File extension (for example, extension:jpeg or ext:mp3). Use extension: or ext: to search in files with no extension.</td>
</tr>
<tr>
<td>genre</td>
<td>Music file</td>
<td>Genre of music</td>
</tr>
<tr>
<td>imagecomment</td>
<td>Image file</td>
<td>Comments and descriptions found in images that have an IPTC caption or Exif comment</td>
</tr>
<tr>
<td>imagemodel</td>
<td>JPEG image</td>
<td>Model of camera (for example, EOS2D)</td>
</tr>
<tr>
<td>imagetag</td>
<td>Image file</td>
<td>F-Spot and DigiKam image tags, and IPTC keywords</td>
</tr>
<tr>
<td>inarchive</td>
<td>File</td>
<td>Use inarchive:true for files inside an archive</td>
</tr>
<tr>
<td>inattachment</td>
<td>File</td>
<td>Use inattachment:true for email attachments.</td>
</tr>
<tr>
<td>mailfrom</td>
<td>E-mail</td>
<td>Name of sender</td>
</tr>
<tr>
<td>mailfromaddr</td>
<td>E-mail</td>
<td>E-mail address of sender</td>
</tr>
<tr>
<td>mailinglist</td>
<td>E-mail</td>
<td>Id of mailing list (for example, dashboard-hackers.gnome.org)</td>
</tr>
<tr>
<td>mailto</td>
<td>E-mail</td>
<td>Name of recipient</td>
</tr>
<tr>
<td>mailtoaddr</td>
<td>E-mail</td>
<td>E-mail address of recipient</td>
</tr>
<tr>
<td>speakingto</td>
<td>Chat</td>
<td>Speaker</td>
</tr>
<tr>
<td>title</td>
<td>Document</td>
<td>Title of document, mapped to dc:title (for example, title tag of HTML files)</td>
</tr>
</tbody>
</table>
Property searches follow the rules mentioned in Section 6.2, “Search Tips” (page 106). You can use property searches as an OR query or as an exclusion query, and phrases can be used as query. For example, the following line will search for all PDF or HTML documents containing the word “apple” whose author property contains “john” and whose title does not contain the word “oranges”:

apple ext:pdf OR ext:html author:john -title:oranges

6.4 Setting Search Preferences

Use the Search Preferences dialog box to set search preferences for Beagle.

1 Click Computer > More Applications > System > Search Settings.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Choose from the following options:

**Start search & indexing services automatically:** Select this option if you want the search daemon to start automatically when you log in to your session (this option is selected by default). If you want to use Beagle's Search functionality, the daemon must be running.
Index data while on battery power: Select this option if you want your data to be indexed when your computer is operating on battery power. Disabling this option is particularly useful if you are using openSUSE on a laptop and you want to stop indexing when your laptop is running on battery power.

Index more aggressively while the screen saver is running: If the screen saver is running, it is assumed that you are not using computer actively and more resources are dedicated to indexing. This option does not apply if computer is running on battery power.

Automatically start searching after the user has stopped typing: Select this option if you want Beagle to start searching as soon as you stop entering text in the Find field in the Desktop Search window. This option has no effect on the Search field in the main menu.

Display the search window by pressing: Choose the keystrokes that will display the Desktop Search window by specifying any combination of Ctrl, Alt and a function key. F12 is the default keystroke.

3 Click OK.

6.5 Indexing Other Directories

By default, Beagle indexes your home directory only. If you do not want your home directory to be indexed, uncheck the Index my home directory option on the Indexing tab of the Search Preferences dialog box. If you want to index additional folders, follow these steps:

1 Click Computer > More Applications > System > Search Settings.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Click the Indexing tab.
3 Click Add in the General section of the dialog box.

4 Select the directory you want to index and click Open.

   Make sure you have rights to the directories you add.

5 If you want to remove a directory from the list of indexed directories, select it in the list, then click Remove.

6 Click OK.

6.6 Preventing Files and Directories from Being Indexed

Use the Search Preferences dialog box to specify resources that you do not want indexed. These resources can include directories, patterns, mail folders, or types of objects.

1 Click Computer > More Applications > System > Search Settings.

2 Click the Indexing tab.

3 Click Add in the Privacy section.
Select a resource to exclude from indexing, then specify the path to the resource or filename pattern.

Click OK twice.

6.7 Selecting Data Sources to Index

Beagle can index various data sources, data from various applications (for example Evolution mails, memos and tasks, Pidgin conversations, Tomboy notes or Nautilus metadata), files, applications, documentation, man pages and others. To select which data sources Beagle should index, follow these steps:

2. Click the Data Sources tab.
3. Check the data sources you want to be indexed.
4. Click OK.

6.8 Disabling Beagle

On low-end computers, Beagle may use too much resources. To disable Beagle, click Computer > More Applications > System > Search Settings > Searching and uncheck the Start search & indexing services automatically option.

You can also disable Beagle by editing configuration files in the /etc/beagle/crawl-rules/ directory. To disable Beagle, set option CRAWL_ENABLED to no in all crawl-* files in the directory.

6.9 For More Information

More information about Beagle can be found on the following Web site:

- Beagle Home Page [http://beagle-project.org/]
Managing Printers

openSUSE® makes it easy to print your documents, whether your computer is connected directly to a printer or linked remotely on a network. This chapter describes how to set up printers in SLED and manage print jobs.

7.1 Installing a Printer

Before you can install a printer, you need to know the root password and have your printer information ready. Depending on how you connect to the printer, you might also need the printer URI, TCP/IP address or host, and the driver for the printer. A number of common printer drivers ship with openSUSE. If you cannot find a driver for the printer, check the printer manufacturer's Web site.

7.1.1 Installing a Network Printer

1. Click **Computer > Control Center > Printing > New > Printer**.

2. Select one of the following entries from the list:

   - **AppSocket/HP JetDirect**: A printer connected directly to the network instead of to a computer.

   - **Internet Printing Protocol (ipp)**: A printer attached to a different Linux system on the same network running CUPS or a printer configured on another operating system to use IPP.
**LPD/LPR Host or Printer:**
A printer or print server attached to a different UNIX system that can be accessed over a TCP/IP network.

**Windows Printer via SAMBA:**
A printer attached to a different system which is sharing a printer over a SMB network (for example, a printer attached to a Microsoft Windows machine). Please refer to Section 5.6, “Configuring and Accessing a Windows Network Printer” (page 103) for configuration details.

3 Specify the printer's information and click **Forward**.

4 If applicable, select the printer driver for this printer, then click **Apply**. You can also install a printer driver from a disk (**Provide PPD file**), or visit the printer manufacturer's Web site to download the latest driver (**Search for a printer driver to download**).

5 Specify desired options for the printer (such as a description or location) in the Properties dialog box and click **Apply**.

6 Enter the **root** password.

The installed printer appears in the Printers panel. You can now print to the printer from any application.

### 7.1.2 Installing a Local Printer

1 Connect the printer cable to your computer and connect the printer's power supply. The printer dialog should open. If it does not, click **Computer > Control Center > Printing > New > Printer** to open it.

2 Click **Local Printer** and proceed with **Forward**.

3 Select the printer driver for this printer and click **Apply**. You can also install a printer driver from a disk (**Provide PPD file**) or visit the printer manufacturer's Web site to download the latest driver (**Search for a printer driver to download**).

4 Specify desired options for the printer (such as a description or location) in the Properties dialog box, then click **Close**.
Enter the root password.

The installed printer appears in the Printers dialog box. You can now print to the printer from any application.

### 7.2 Modifying Printer Settings

1. Click **Computer > Control Center > Printing**
2. Double-click the printer you want to modify.
3. Modify the properties and click **Close**.

### 7.3 Canceling Print Jobs

1. Click **Computer > Control Center > Printing**.
2. Right-click the printer where you sent the job and click **View Print Queue**.
3. Right-click the print job and click **Cancel**.

   If the print job does not appear in the list, the print job might have been printed already.

### 7.4 Deleting a Printer

1. Click **Computer > Control Center > Printing**.
2. Right-click the printer you want to delete and choose **Delete**. Confirm with **OK**.
3. Type the root password and click **Authenticate**.
GNU Licenses

This appendix contains the GNU General Public License and the GNU Free Documentation License.

GNU General Public License

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.
GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The “Program”, below, refers to any such program or work, and a “work based on the Program” means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, then you may choose to distribute the Program just as if the conditions had never been imposed on you, i.e. by excluding any relevant passage ofetrodictum.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and “any later version”, you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

**NO WARRANTY**

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

**END OF TERMS AND CONDITIONS**

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

_**one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author**_
This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w'. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c'
for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision'
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License [http://www.fsf.org/licenses/lgpl.html] instead of this License.

GNU Free Documentation License

Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondly, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.
We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

**APPLICABILITY AND DEFINITIONS**

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.

The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”, “Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

**VERBATIM COPYING**

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical means to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

**COPYING IN QUANTITY**

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.
If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N. Do not retitile any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your Modified Version by various parties—for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.
The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

Copyright (c) YEAR YOUR NAME.