SUSE-SU-2012:0793-1

Security update for libxml2

SUSE Security Update: Security update for libxml2
Announcement ID: SUSE-SU-2012:0793-1
Rating: moderate
References: #764538
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Linux Enterprise Software Development Kit 11 SP1
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Server 11 SP1 for VMware
  • SUSE Linux Enterprise Server 11 SP1
  • SUSE Linux Enterprise Server 10 SP4
  • SUSE Linux Enterprise Desktop 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP1
  • SUSE Linux Enterprise Desktop 10 SP4

  • An update that fixes one vulnerability is now available.

    Description:


    Specially crafted XML could have caused a denial of service
    via an out-of-bounds write (application crash) to
    applications that are linked against libxml2
    (CVE-2011-3102). This has been fixed.

    Security Issue references:

    * CVE-2011-3102
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp1-libxml2-6365
    • SUSE Linux Enterprise Software Development Kit 11 SP1:
      zypper in -t patch sdksp1-libxml2-6365
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp1-libxml2-6365
    • SUSE Linux Enterprise Server 11 SP1 for VMware:
      zypper in -t patch slessp1-libxml2-6365
    • SUSE Linux Enterprise Server 11 SP1:
      zypper in -t patch slessp1-libxml2-6365
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp1-libxml2-6365
    • SUSE Linux Enterprise Desktop 11 SP1:
      zypper in -t patch sledsp1-libxml2-6365

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • libxml2-devel-2.7.6-0.17.1
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (ppc64 s390x x86_64):
    • libxml2-devel-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64 s390x x86_64):
    • libxml2-devel-2.7.6-0.17.1
    • SUSE Linux Enterprise Software Development Kit 11 SP1 (ppc64 s390x x86_64):
    • libxml2-devel-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • libxml2-2.7.6-0.17.1
    • libxml2-doc-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP2 (ppc64 s390x x86_64):
    • libxml2-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP2 (ia64):
    • libxml2-x86-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):
    • libxml2-2.7.6-0.17.1
    • libxml2-doc-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64):
    • libxml2-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):
    • libxml2-2.7.6-0.17.1
    • libxml2-doc-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64):
    • libxml2-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 11 SP1 (ia64):
    • libxml2-x86-2.7.6-0.17.1
    • SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):
    • libxml2-2.6.23-15.31.4
    • libxml2-devel-2.6.23-15.31.4
    • SUSE Linux Enterprise Server 10 SP4 (s390x x86_64):
    • libxml2-32bit-2.6.23-15.31.4
    • libxml2-devel-32bit-2.6.23-15.31.4
    • SUSE Linux Enterprise Server 10 SP4 (ia64):
    • libxml2-x86-2.6.23-15.31.4
    • SUSE Linux Enterprise Server 10 SP4 (ppc):
    • libxml2-64bit-2.6.23-15.31.4
    • libxml2-devel-64bit-2.6.23-15.31.4
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):
    • libxml2-2.7.6-0.17.1
    • SUSE Linux Enterprise Desktop 11 SP2 (x86_64):
    • libxml2-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):
    • libxml2-2.7.6-0.17.1
    • SUSE Linux Enterprise Desktop 11 SP1 (x86_64):
    • libxml2-32bit-2.7.6-0.17.1
    • SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):
    • libxml2-2.6.23-15.31.4
    • libxml2-devel-2.6.23-15.31.4
    • SUSE Linux Enterprise Desktop 10 SP4 (x86_64):
    • libxml2-32bit-2.6.23-15.31.4
    • libxml2-devel-32bit-2.6.23-15.31.4

    References:

  • http://support.novell.com/security/cve/CVE-2011-3102.html
  • https://bugzilla.novell.com/764538
  • http://download.suse.com/patch/finder/?keywords=7b174cf04bc60f0775dbbdbb0c987eb1
  • http://download.suse.com/patch/finder/?keywords=850fa3835152c3c596cbd2ee604d57f6