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SMT - Error: Unable to request next job: 500 Access to 'http' URIs has been disabled

This document (7023373) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 15
Subscription Management Tool

Situation

The SMT (Subscription Management Tool) server is reporting the following error message related to the jobs:

Error: Unable to request next job: 500 Access to 'http' URIs has been disabled-

The above error will also show on the Client when the smt-agent command is launched manually.

Resolution

A configuration file must be changed on the Client so the first step is to create a backup copy of the file:

- On SUSE Linux Enterprise Server (SLES) 11 based Clients run:

# cp -p /etc/suseRegister.conf /etc/suseRegister.conf.BCK

- On SLES 12 and 15 based Clients run:

# cp -p /etc/SUSEConnect /etc/SUSEConnect.BCK

Then edit the file and change "http" for "https" (without the quotation marks) in the "url" line, so after the change the line should look as follows:

- On SLES 11 based Clients:

url=https://<YOUR-SMT-FQDN-HERE>/center/regsvc

- On SLES 12 and 15 based Clients:

url: https://<YOUR-SMT-FQDN-HERE>/

Save the changes and exit the editor.

Finally run the smt-agent command on the Client to check if the error is still showing up:

# smt-agent

If working the above command will not show any output.

Cause

Communication via HTTP for the SMT servers jobs is disabled by default, hence the error. All communications must be only via HTTPS and cannot be changed to work with HTTP.

The registration of the Client was done using HTTP or the configuration file was changed manually to use HTTP, verify the procedure and commands being used to register Clients against the SMT server and be sure to always use the SMT's FQDN (Fully Qualified Domain Name) and HTTPS instead of HTTP.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023373
  • Creation Date: 25-Sep-2018
  • Modified Date:03-Mar-2020
    • Subscription Management Tool

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