システム起動時にアプリケーションが正常に起動しない

このドキュメント (00100064) の最後に記載の 免責条項 に基づき提供されています。

環境

SUSE Linux Enterprise Server 12 SP2

原因

サービスで開始するアプリケーションで生成するプロセスやスレッドの数がTasksMaxで定義する値512を超えている
LVMの構成で512個以上のPVを使用した時の例では、/var/log/messagesにFailed to handle a client connection.のようなメッセージが幾つも出力されます。

解決策

SLES12SP2のsystemdではシステムを保護する目的からPIDs cgroup Controllerの機能を含んでいます。
この機能で設定することができるオプションのひとつにTasksMaxがあり、設定した数値を基準としてサービスが起動する時に生成するプロセスやスレッドの上限値の定義を行うことができます。
SLES12SP2のTasksMaxのデフォルト値は512です。

TasksMaxのデフォルト値は/etc/systemd/system.confのDefaultTasksMax=nに定義して変更することができます。
またサービスで起動するアプリケーション毎に定義する場合は、TasksMax=nをsystemdのユニットファイルの[Service]セクションに直接定義して使用することができます。

下記も合わせて参照ください。
2.3.2 Support for PIDs cgroup Controller
https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12-SP2/#fate-320358

免責条項

このサポート ナレッジベースは、NetIQ/Novell/SUSE顧客、および弊社製品およびそのソリューションに関心のあるパーティへ、情報やアイデアの取得およびそれらの知識を得る為の有効なツールを提供します。 本文書の商品性、および特定目的への適合性について、いかなる黙示の保証も否認し、排除します。

  • ドキュメント ID:00100064
  • 作成年月日:12-MAY-17
  • 修正年月日:12-MAY-17
    • SUSESUSE Linux Enterprise Server 12 SP2

このドキュメントはあなたの問題を解決しましたか? フィードバックを送る

SUSEサポートフォーラム

経験豊富なシステムオペレーターへの質問を投稿したり、他のSUSEコミュニティのエキスパートと交流したりすることができます。

コミュニティに参加

サポートリソース

このガイドラインでは、SUSEサブスクリプション、Premium Support、教育機関向けプログラム、またはパートナープログラムで提供されるテクニカルサポートの活用方法について説明します。


SUSE Technical Support Handbook Update Advisories
サポートに関するFAQ

インシデントを開く

テクニカルサポートへのインシデントの報告、サブスクリプションの管理、パッチのダウンロード、ユーザーアクセスの管理を行うことができます。

カスタマーセンターにアクセス