Upstream information

CVE-2023-45683 at MITRE

Description

github.com/crewjam/saml is a saml library for the go language. In affected versions the package does not validate the ACS Location URI according to the SAML binding being parsed. If abused, this flaw allows attackers to register malicious Service Providers at the IdP and inject Javascript in the ACS endpoint definition, achieving Cross-Site-Scripting (XSS) in the IdP context during the redirection at the end of a SAML SSO Flow. Consequently, an attacker may perform any authenticated action as the victim once the victim’s browser loaded the SAML IdP initiated SSO link for the malicious service provider. Note: SP registration is commonly an unrestricted operation in IdPs, hence not requiring particular permissions or publicly accessible to ease the IdP interoperability. This issue is fixed in version 0.4.14. Users unable to upgrade may perform external validation of URLs provided in SAML metadata, or restrict the ability for end-users to upload arbitrary metadata.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.1 7.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1216308 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Module for Package Hub 15 SP4 grafana Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 grafana Not affected
SUSE Manager Client Tools Beta for SLE 12 grafana Not affected
SUSE Manager Client Tools Beta for SLE 15 grafana Not affected
SUSE Manager Client Tools for SLE 12 grafana Not affected
SUSE Manager Client Tools for SLE 15 grafana Not affected
SUSE Manager Tools 12 grafana Not affected
SUSE Manager Tools 15 grafana Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 grafana Not affected
SUSE OpenStack Cloud 8 grafana Not affected
SUSE OpenStack Cloud 9 grafana Not affected
SUSE OpenStack Cloud Crowbar 8 grafana Not affected
SUSE OpenStack Cloud Crowbar 9 grafana Not affected
Products at an unknown state of their lifecycle.
SUSE Manager Tools 12-BETA grafana Not affected
SUSE Manager Tools 15-BETA grafana Not affected
Container Status
ses/7.1/ceph/grafana
ses/7/ceph/grafana
grafanaNot affected


SUSE Timeline for this CVE

CVE page created: Mon Oct 16 22:00:37 2023
CVE page last modified: Wed Jan 24 19:36:28 2024