Upstream information

CVE-2023-3114 at MITRE

Description

Terraform Enterprise since v202207-1 did not properly implement authorization rules for agent pools, allowing the workspace to be targeted by unauthorized agents. This authorization flaw could potentially allow a workspace to access resources from a separate, higher-privileged workspace in the same organization that targeted an agent pool. This vulnerability, CVE-2023-3114, is fixed in Terraform Enterprise v202306-1.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5 5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1212647 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 terraform Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 terraform Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP5 terraform Not affected
SUSE Linux Enterprise Server 15 SP5 terraform Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 terraform Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 terraform Not affected
SUSE Manager Proxy 4.3 terraform Not affected
SUSE Manager Retail Branch Server 4.3 terraform Not affected
SUSE Manager Server 4.3 terraform Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 terraform Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 terraform Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 terraform Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 terraform Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP4 terraform Not affected
SUSE Linux Enterprise Server 15 SP2 terraform Not affected
SUSE Linux Enterprise Server 15 SP3 terraform Not affected
SUSE Linux Enterprise Server 15 SP4 terraform Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 terraform Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 terraform Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 terraform Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 terraform Not affected
SUSE Enterprise Storage 6 terraform Not affected
SUSE Enterprise Storage 7 terraform Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP1 terraform Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP2 terraform Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP3 terraform Not affected
SUSE Linux Enterprise Server 15 SP1 terraform Not affected
SUSE Manager Proxy 4.0 terraform Not affected
SUSE Manager Proxy 4.1 terraform Not affected
SUSE Manager Proxy 4.2 terraform Not affected
SUSE Manager Retail Branch Server 4.0 terraform Not affected
SUSE Manager Retail Branch Server 4.1 terraform Not affected
SUSE Manager Retail Branch Server 4.2 terraform Not affected
SUSE Manager Server 4.0 terraform Not affected
SUSE Manager Server 4.1 terraform Not affected
SUSE Manager Server 4.2 terraform Not affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 23 02:00:50 2023
CVE page last modified: Thu Feb 1 01:45:11 2024