Upstream information

CVE-2023-28938 at MITRE

Description

Uncontrolled resource consumption in some Intel(R) SSD Tools software before version mdadm-4.2-rc2 may allow a priviledged user to potentially enable denial of service via local access.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.4 3.4
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:L CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required High High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1214245 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle-micro-rancher/5.4:latest
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
  • mdadm >= 4.1-150300.24.33.1
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • mdadm >= 4.1-4.29.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3953
SUSE Linux Enterprise Micro 5.1
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2023-3953
SUSE Linux Enterprise Micro 5.2
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2023-3953
SUSE Linux Enterprise Micro 5.3
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Micro-5.3-2023-3953
SUSE Linux Enterprise Micro 5.4
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Micro-5.4-2023-3953
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • mdadm >= 4.1-4.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2023-3691
SUSE Manager Proxy 4.2
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-3953
SUSE Manager Retail Branch Server 4.2
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2023-3953
SUSE Manager Server 4.2
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-3953
openSUSE Leap 15.4
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
openSUSE-SLE-15.4-2023-3953
openSUSE Leap Micro 5.3
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
openSUSE-Leap-Micro-5.3-2023-3953
openSUSE Leap Micro 5.4
  • mdadm >= 4.1-150300.24.33.1
Patchnames:
openSUSE-Leap-Micro-5.4-2023-3953


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 mdadm Released
SUSE Linux Enterprise Desktop 15 SP5 mdadm Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 mdadm Released
SUSE Linux Enterprise High Performance Computing 15 SP5 mdadm Already fixed
SUSE Linux Enterprise Micro 5.1 mdadm Released
SUSE Linux Enterprise Micro 5.2 mdadm Released
SUSE Linux Enterprise Micro 5.3 mdadm Released
SUSE Linux Enterprise Micro 5.4 mdadm Released
SUSE Linux Enterprise Micro 5.5 mdadm Already fixed
SUSE Linux Enterprise Micro for Rancher 5.2 mdadm Released
SUSE Linux Enterprise Micro for Rancher 5.3 mdadm Released
SUSE Linux Enterprise Micro for Rancher 5.4 mdadm Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 mdadm Already fixed
SUSE Linux Enterprise Real Time 15 SP3 mdadm Released
SUSE Linux Enterprise Server 12 SP5 mdadm Released
SUSE Linux Enterprise Server 15 SP5 mdadm Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mdadm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 mdadm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 mdadm Already fixed
SUSE Manager Proxy 4.3 mdadm Released
SUSE Manager Retail Branch Server 4.3 mdadm Released
SUSE Manager Server 4.3 mdadm Released
openSUSE Leap Micro 5.3 mdadm Released
openSUSE Leap Micro 5.4 mdadm Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 mdadm Released
SUSE Linux Enterprise High Performance Computing 15 mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 mdadm Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS mdadm Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS mdadm Released
SUSE Linux Enterprise High Performance Computing 15 SP4 mdadm Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS mdadm Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS mdadm Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS mdadm Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS mdadm Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 mdadm Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP3 mdadm Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 mdadm Released
SUSE Linux Enterprise Server 12 SP2-BCL mdadm Unsupported
SUSE Linux Enterprise Server 15 SP2 mdadm Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 15 SP3 mdadm Affected
SUSE Linux Enterprise Server 15 SP3-LTSS mdadm Released
SUSE Linux Enterprise Server 15 SP4 mdadm Released
SUSE Linux Enterprise Server 15 SP4-LTSS mdadm Affected
SUSE Linux Enterprise Server for SAP Applications 15 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 mdadm Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 mdadm Unsupported
SUSE CaaS Platform 4.0 mdadm Unsupported
SUSE Enterprise Storage 6 mdadm Unsupported
SUSE Enterprise Storage 7 mdadm Unsupported
SUSE Linux Enterprise Desktop 12 SP2 mdadm Unsupported
SUSE Linux Enterprise Desktop 12 SP3 mdadm Unsupported
SUSE Linux Enterprise Desktop 12 SP4 mdadm Unsupported
SUSE Linux Enterprise Desktop 15 mdadm Unsupported
SUSE Linux Enterprise Desktop 15 SP1 mdadm Unsupported
SUSE Linux Enterprise Desktop 15 SP2 mdadm Unsupported
SUSE Linux Enterprise Desktop 15 SP3 mdadm Affected
SUSE Linux Enterprise Micro 5.0 mdadm Unsupported
SUSE Linux Enterprise Module for Basesystem 15 mdadm Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 mdadm Unsupported
SUSE Linux Enterprise Real Time 15 SP2 mdadm Unsupported
SUSE Linux Enterprise Real Time 15 SP4 mdadm Affected
SUSE Linux Enterprise Server 11 SP4 mdadm Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS mdadm Unsupported
SUSE Linux Enterprise Server 11 SP4-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP2 mdadm Unsupported
SUSE Linux Enterprise Server 12 SP2-ESPOS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP3 mdadm Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL mdadm Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP4 mdadm Unsupported
SUSE Linux Enterprise Server 12 SP4-ESPOS mdadm Unsupported
SUSE Linux Enterprise Server 12 SP4-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 15 mdadm Unsupported
SUSE Linux Enterprise Server 15 SP1 mdadm Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL mdadm Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS mdadm Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL mdadm Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL mdadm Affected
SUSE Linux Enterprise Server 15-LTSS mdadm Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 mdadm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mdadm Unsupported
SUSE Manager Proxy 4.0 mdadm Unsupported
SUSE Manager Proxy 4.1 mdadm Unsupported
SUSE Manager Proxy 4.2 mdadm Released
SUSE Manager Retail Branch Server 4.0 mdadm Unsupported
SUSE Manager Retail Branch Server 4.1 mdadm Unsupported
SUSE Manager Retail Branch Server 4.2 mdadm Released
SUSE Manager Server 4.0 mdadm Unsupported
SUSE Manager Server 4.1 mdadm Unsupported
SUSE Manager Server 4.2 mdadm Released
SUSE OpenStack Cloud 7 mdadm Unsupported
SUSE OpenStack Cloud 8 mdadm Unsupported
SUSE OpenStack Cloud 9 mdadm Unsupported
SUSE OpenStack Cloud Crowbar 8 mdadm Unsupported
SUSE OpenStack Cloud Crowbar 9 mdadm Unsupported
openSUSE Leap 15.3 mdadm Released
openSUSE Leap 15.4 mdadm Released
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Desktop 15 SP4-LTSS mdadm Affected
Container Status
suse/sle-micro/5.5
suse/sles/15.5/libguestfs-tools:0.58.0
mdadmAlready fixed
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro-rancher/5.4
mdadmReleased
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.4/libguestfs-tools:0.49.0
mdadmIn progress


SUSE Timeline for this CVE

CVE page created: Fri Aug 11 06:04:50 2023
CVE page last modified: Tue Feb 6 13:52:30 2024