Upstream information

CVE-2021-32626 at MITRE

Description

Redis is an open source, in-memory database that persists on disk. In affected versions specially crafted Lua scripts executing in Redis can cause the heap-based Lua stack to be overflowed, due to incomplete checks for this condition. This can result with heap corruption and potentially remote code execution. This problem exists in all versions of Redis with Lua scripting support, starting from 2.6. The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14. For users unable to update an additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1191306 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Server Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • redis >= 6.0.14-6.8.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-3772
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Server Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • redis >= 6.0.14-6.8.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3772
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Server Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • redis >= 6.2.6-150400.1.5
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA redis-6.2.6-150400.1.5
openSUSE Leap 15.3
  • redis >= 6.0.14-6.8.1
Patchnames:
openSUSE-SLE-15.3-2021-3772
openSUSE Tumbleweed
  • redis >= 6.2.6-1.1
Patchnames:
openSUSE Tumbleweed GA redis-6.2.6-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Enterprise Storage 7 redis Released
SUSE Enterprise Storage 7.1 redis Released
SUSE Linux Enterprise High Performance Computing 15 SP2 redis Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS redis Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS redis Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 redis Released
SUSE Linux Enterprise High Performance Computing 15 SP4 redis Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 redis Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 redis Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 redis Already fixed
SUSE Linux Enterprise Real Time 15 SP2 redis Affected
SUSE Linux Enterprise Real Time 15 SP3 redis Affected
SUSE Linux Enterprise Server 15 SP2 redis Released
SUSE Linux Enterprise Server 15 SP2-BCL redis Affected
SUSE Linux Enterprise Server 15 SP2-LTSS redis Affected
SUSE Linux Enterprise Server 15 SP3 redis Released
SUSE Linux Enterprise Server 15 SP4 redis Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 redis Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 redis Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 redis Already fixed
SUSE Manager Proxy 4.1 redis Released
SUSE Manager Proxy 4.2 redis Released
SUSE Manager Proxy 4.3 redis Already fixed
SUSE Manager Retail Branch Server 4.1 redis Released
SUSE Manager Retail Branch Server 4.2 redis Released
SUSE Manager Retail Branch Server 4.3 redis Already fixed
SUSE Manager Server 4.1 redis Released
SUSE Manager Server 4.2 redis Released
SUSE Manager Server 4.3 redis Already fixed


SUSE Timeline for this CVE

CVE page created: Mon Oct 4 23:00:57 2021
CVE page last modified: Thu Dec 1 00:09:52 2022