Upstream information

CVE-2019-13456 at MITRE

Description

In FreeRADIUS 3.0 through 3.0.19, on average 1 in every 2048 EAP-pwd handshakes fails because the password element cannot be found within 10 iterations of the hunting and pecking loop. This leaks information that an attacker can use to recover the password of any user. This information leakage is similar to the "Dragonblood" attack and CVE-2019-9494.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.9
Vector AV:A/AC:M/Au:N/C:P/I:N/A:N
Access Vector Adjacent Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 5.3
Vector CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Adjacent Network Adjacent Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3
SUSE Bugzilla entries: 1144524 [RESOLVED / FIXED], 1166858 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1018
SUSE Enterprise Storage 5
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-Storage-5-2020-1018
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • freeradius-server >= 3.0.16-3.6.1
  • freeradius-server-devel >= 3.0.16-3.6.1
  • freeradius-server-krb5 >= 3.0.16-3.6.1
  • freeradius-server-ldap >= 3.0.16-3.6.1
  • freeradius-server-libs >= 3.0.16-3.6.1
  • freeradius-server-mysql >= 3.0.16-3.6.1
  • freeradius-server-perl >= 3.0.16-3.6.1
  • freeradius-server-postgresql >= 3.0.16-3.6.1
  • freeradius-server-python >= 3.0.16-3.6.1
  • freeradius-server-sqlite >= 3.0.16-3.6.1
  • freeradius-server-utils >= 3.0.16-3.6.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1023
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • freeradius-server >= 3.0.16-3.6.1
  • freeradius-server-doc >= 3.0.16-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1023
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • freeradius-server >= 3.0.16-3.6.1
  • freeradius-server-devel >= 3.0.16-3.6.1
  • freeradius-server-krb5 >= 3.0.16-3.6.1
  • freeradius-server-ldap >= 3.0.16-3.6.1
  • freeradius-server-libs >= 3.0.16-3.6.1
  • freeradius-server-mysql >= 3.0.16-3.6.1
  • freeradius-server-perl >= 3.0.16-3.6.1
  • freeradius-server-postgresql >= 3.0.16-3.6.1
  • freeradius-server-python >= 3.0.16-3.6.1
  • freeradius-server-sqlite >= 3.0.16-3.6.1
  • freeradius-server-utils >= 3.0.16-3.6.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-1023
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-2391
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-2391
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-2391
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-2391
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1018
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1018
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1018
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1018
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • freeradius-server >= 3.0.19-3.3.1
  • freeradius-server-doc >= 3.0.19-3.3.1
  • freeradius-server-krb5 >= 3.0.19-3.3.1
  • freeradius-server-ldap >= 3.0.19-3.3.1
  • freeradius-server-libs >= 3.0.19-3.3.1
  • freeradius-server-mysql >= 3.0.19-3.3.1
  • freeradius-server-perl >= 3.0.19-3.3.1
  • freeradius-server-postgresql >= 3.0.19-3.3.1
  • freeradius-server-python >= 3.0.19-3.3.1
  • freeradius-server-sqlite >= 3.0.19-3.3.1
  • freeradius-server-utils >= 3.0.19-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1020
SUSE Linux Enterprise Server 15-LTSS
  • freeradius-server >= 3.0.16-3.6.1
  • freeradius-server-devel >= 3.0.16-3.6.1
  • freeradius-server-krb5 >= 3.0.16-3.6.1
  • freeradius-server-ldap >= 3.0.16-3.6.1
  • freeradius-server-libs >= 3.0.16-3.6.1
  • freeradius-server-mysql >= 3.0.16-3.6.1
  • freeradius-server-perl >= 3.0.16-3.6.1
  • freeradius-server-postgresql >= 3.0.16-3.6.1
  • freeradius-server-python >= 3.0.16-3.6.1
  • freeradius-server-sqlite >= 3.0.16-3.6.1
  • freeradius-server-utils >= 3.0.16-3.6.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1023
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-2391
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1018
SUSE Linux Enterprise Server for SAP Applications 15
  • freeradius-server >= 3.0.16-3.6.1
  • freeradius-server-devel >= 3.0.16-3.6.1
  • freeradius-server-krb5 >= 3.0.16-3.6.1
  • freeradius-server-ldap >= 3.0.16-3.6.1
  • freeradius-server-libs >= 3.0.16-3.6.1
  • freeradius-server-mysql >= 3.0.16-3.6.1
  • freeradius-server-perl >= 3.0.16-3.6.1
  • freeradius-server-postgresql >= 3.0.16-3.6.1
  • freeradius-server-python >= 3.0.16-3.6.1
  • freeradius-server-sqlite >= 3.0.16-3.6.1
  • freeradius-server-utils >= 3.0.16-3.6.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1023
SUSE Linux Enterprise Software Development Kit 12 SP4
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-devel >= 3.0.15-2.14.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1018
SUSE Linux Enterprise Software Development Kit 12 SP5
  • freeradius-server >= 3.0.19-3.3.1
  • freeradius-server-devel >= 3.0.19-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1020
SUSE OpenStack Cloud 7
  • freeradius-server >= 3.0.3-17.15.2
  • freeradius-server-doc >= 3.0.3-17.15.2
  • freeradius-server-krb5 >= 3.0.3-17.15.2
  • freeradius-server-ldap >= 3.0.3-17.15.2
  • freeradius-server-libs >= 3.0.3-17.15.2
  • freeradius-server-mysql >= 3.0.3-17.15.2
  • freeradius-server-perl >= 3.0.3-17.15.2
  • freeradius-server-postgresql >= 3.0.3-17.15.2
  • freeradius-server-python >= 3.0.3-17.15.2
  • freeradius-server-sqlite >= 3.0.3-17.15.2
  • freeradius-server-utils >= 3.0.3-17.15.2
Patchnames:
SUSE-OpenStack-Cloud-7-2020-2391
SUSE OpenStack Cloud 8
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1018
SUSE OpenStack Cloud Crowbar 8
  • freeradius-server >= 3.0.15-2.14.1
  • freeradius-server-doc >= 3.0.15-2.14.1
  • freeradius-server-krb5 >= 3.0.15-2.14.1
  • freeradius-server-ldap >= 3.0.15-2.14.1
  • freeradius-server-libs >= 3.0.15-2.14.1
  • freeradius-server-mysql >= 3.0.15-2.14.1
  • freeradius-server-perl >= 3.0.15-2.14.1
  • freeradius-server-postgresql >= 3.0.15-2.14.1
  • freeradius-server-python >= 3.0.15-2.14.1
  • freeradius-server-sqlite >= 3.0.15-2.14.1
  • freeradius-server-utils >= 3.0.15-2.14.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1018
openSUSE Leap 15.1
  • freeradius-server >= 3.0.16-lp151.4.4.1
  • freeradius-server-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-debugsource >= 3.0.16-lp151.4.4.1
  • freeradius-server-devel >= 3.0.16-lp151.4.4.1
  • freeradius-server-doc >= 3.0.16-lp151.4.4.1
  • freeradius-server-krb5 >= 3.0.16-lp151.4.4.1
  • freeradius-server-krb5-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-ldap >= 3.0.16-lp151.4.4.1
  • freeradius-server-ldap-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-libs >= 3.0.16-lp151.4.4.1
  • freeradius-server-libs-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-mysql >= 3.0.16-lp151.4.4.1
  • freeradius-server-mysql-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-perl >= 3.0.16-lp151.4.4.1
  • freeradius-server-perl-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-postgresql >= 3.0.16-lp151.4.4.1
  • freeradius-server-postgresql-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-python >= 3.0.16-lp151.4.4.1
  • freeradius-server-python-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-sqlite >= 3.0.16-lp151.4.4.1
  • freeradius-server-sqlite-debuginfo >= 3.0.16-lp151.4.4.1
  • freeradius-server-utils >= 3.0.16-lp151.4.4.1
  • freeradius-server-utils-debuginfo >= 3.0.16-lp151.4.4.1
Patchnames:
openSUSE-2020-553


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications freeradius-server Not affected
SUSE Linux Enterprise 15 Module for Server Applications freeradius-server Affected
SUSE Linux Enterprise 15-SP1 Module for Server Applications freeradius-server Released
SUSE Linux Enterprise High Performance Computing 12 SP4 freeradius-server Released
SUSE Linux Enterprise High Performance Computing 12 SP5 freeradius-server Released
SUSE Linux Enterprise High Performance Computing 15 LTSS freeradius-server Released
SUSE Linux Enterprise Server 11 SP3 freeradius-server Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS freeradius-server Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS freeradius-server Not affected
SUSE Linux Enterprise Server 12 LTSS freeradius-server Affected
SUSE Linux Enterprise Server 12 SP1 LTSS freeradius-server Affected
SUSE Linux Enterprise Server 12 SP2 BCL freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP3 freeradius-server Affected
SUSE Linux Enterprise Server 12 SP3 BCL freeradius-server Released
SUSE Linux Enterprise Server 12 SP3 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP4 freeradius-server Released
SUSE Linux Enterprise Server 12 SP5 freeradius-server Released
SUSE Linux Enterprise Server 15 LTSS freeradius-server Released
SUSE Linux Enterprise Server ESPOS 15 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 freeradius-server Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 SP3 freeradius-server Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 SP5 freeradius-server Released