Upstream information

CVE-2019-10094 at MITRE

Description

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1144515 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Proxy
  • mgr-cfg >= 4.0.10-3.6.9
  • mgr-cfg-actions >= 4.0.10-3.6.9
  • mgr-cfg-client >= 4.0.10-3.6.9
  • mgr-cfg-management >= 4.0.10-3.6.9
  • patterns-suma_proxy >= 4.0-9.3.8
  • python3-mgr-cfg >= 4.0.10-3.6.9
  • python3-mgr-cfg-actions >= 4.0.10-3.6.9
  • python3-mgr-cfg-client >= 4.0.10-3.6.9
  • python3-mgr-cfg-management >= 4.0.10-3.6.9
  • python3-spacewalk-backend-libs >= 4.0.27-3.13.9
  • python3-spacewalk-certs-tools >= 4.0.12-3.6.8
  • python3-spacewalk-client-tools >= 4.0.10-3.6.8
  • spacewalk-backend >= 4.0.27-3.13.9
  • spacewalk-base-minimal >= 4.0.16-3.9.8
  • spacewalk-base-minimal-config >= 4.0.16-3.9.8
  • spacewalk-certs-tools >= 4.0.12-3.6.8
  • spacewalk-client-tools >= 4.0.10-3.6.8
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Server
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Server
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Server
  • cobbler >= 3.0.0+git20190806.32c4bae0-7.3.7
  • cpu-mitigations-formula >= 0.1-4.6.7
  • mgr-osa-dispatcher >= 4.0.10-3.6.8
  • patterns-suma_server >= 4.0-9.3.8
  • pgjdbc-ng >= 0.7.1-3.3.8
  • py26-compat-salt >= 2016.11.10-10.8.8
  • python3-mgr-osa-common >= 4.0.10-3.6.8
  • python3-mgr-osa-dispatcher >= 4.0.10-3.6.8
  • python3-spacewalk-backend-libs >= 4.0.27-3.13.9
  • python3-spacewalk-certs-tools >= 4.0.12-3.6.8
  • python3-spacewalk-client-tools >= 4.0.10-3.6.8
  • python3-urlgrabber >= 3.10.2.1py2_3-6.22.6
  • spacecmd >= 4.0.16-3.6.7
  • spacewalk-admin >= 4.0.8-3.3.8
  • spacewalk-backend >= 4.0.27-3.13.9
  • spacewalk-backend-app >= 4.0.27-3.13.9
  • spacewalk-backend-applet >= 4.0.27-3.13.9
  • spacewalk-backend-config-files >= 4.0.27-3.13.9
  • spacewalk-backend-config-files-common >= 4.0.27-3.13.9
  • spacewalk-backend-config-files-tool >= 4.0.27-3.13.9
  • spacewalk-backend-iss >= 4.0.27-3.13.9
  • spacewalk-backend-iss-export >= 4.0.27-3.13.9
  • spacewalk-backend-package-push-server >= 4.0.27-3.13.9
  • spacewalk-backend-server >= 4.0.27-3.13.9
  • spacewalk-backend-sql >= 4.0.27-3.13.9
  • spacewalk-backend-sql-postgresql >= 4.0.27-3.13.9
  • spacewalk-backend-tools >= 4.0.27-3.13.9
  • spacewalk-backend-xml-export-libs >= 4.0.27-3.13.9
  • spacewalk-backend-xmlrpc >= 4.0.27-3.13.9
  • spacewalk-base >= 4.0.16-3.9.8
  • spacewalk-base-minimal >= 4.0.16-3.9.8
  • spacewalk-base-minimal-config >= 4.0.16-3.9.8
  • spacewalk-branding >= 4.0.14-3.6.8
  • spacewalk-certs-tools >= 4.0.12-3.6.8
  • spacewalk-client-tools >= 4.0.10-3.6.8
  • spacewalk-config >= 4.0.13-3.3.7
  • spacewalk-html >= 4.0.16-3.9.8
  • spacewalk-java >= 4.0.25-3.10.5
  • spacewalk-java-config >= 4.0.25-3.10.5
  • spacewalk-java-lib >= 4.0.25-3.10.5
  • spacewalk-java-postgresql >= 4.0.25-3.10.5
  • spacewalk-setup >= 4.0.11-3.6.7
  • spacewalk-taskomatic >= 4.0.25-3.10.5
  • susemanager >= 4.0.17-3.6.9
  • susemanager-doc-indexes >= 4.0-10.9.8
  • susemanager-docs_en >= 4.0-10.9.7
  • susemanager-docs_en-pdf >= 4.0-10.9.7
  • susemanager-schema >= 4.0.16-3.8.5
  • susemanager-sls >= 4.0.22-3.10.4
  • susemanager-sync-data >= 4.0.13-3.6.7
  • susemanager-tools >= 4.0.17-3.6.9
  • susemanager-web-libs >= 4.0.16-3.9.8
  • tika-core >= 1.22-3.3.7
  • virtual-host-gatherer >= 1.0.19-3.3.8
SUSE Manager Server 3.2
  • cobbler >= 2.6.6-6.22.1
  • pgjdbc-ng >= 0.7.1-2.6.1
  • py26-compat-salt >= 2016.11.10-6.32.1
  • python2-spacewalk-client-tools >= 2.8.22.5-3.6.1
  • spacecmd >= 2.8.25.11-3.23.1
  • spacewalk-backend >= 2.8.57.19-3.39.2
  • spacewalk-backend-app >= 2.8.57.19-3.39.2
  • spacewalk-backend-applet >= 2.8.57.19-3.39.2
  • spacewalk-backend-config-files >= 2.8.57.19-3.39.2
  • spacewalk-backend-config-files-common >= 2.8.57.19-3.39.2
  • spacewalk-backend-config-files-tool >= 2.8.57.19-3.39.2
  • spacewalk-backend-iss >= 2.8.57.19-3.39.2
  • spacewalk-backend-iss-export >= 2.8.57.19-3.39.2
  • spacewalk-backend-libs >= 2.8.57.19-3.39.2
  • spacewalk-backend-package-push-server >= 2.8.57.19-3.39.2
  • spacewalk-backend-server >= 2.8.57.19-3.39.2
  • spacewalk-backend-sql >= 2.8.57.19-3.39.2
  • spacewalk-backend-sql-oracle >= 2.8.57.19-3.39.2
  • spacewalk-backend-sql-postgresql >= 2.8.57.19-3.39.2
  • spacewalk-backend-tools >= 2.8.57.19-3.39.2
  • spacewalk-backend-xml-export-libs >= 2.8.57.19-3.39.2
  • spacewalk-backend-xmlrpc >= 2.8.57.19-3.39.2
  • spacewalk-base >= 2.8.7.19-3.36.1
  • spacewalk-base-minimal >= 2.8.7.19-3.36.1
  • spacewalk-base-minimal-config >= 2.8.7.19-3.36.1
  • spacewalk-branding >= 2.8.5.16-3.22.1
  • spacewalk-client-tools >= 2.8.22.5-3.6.1
  • spacewalk-html >= 2.8.7.19-3.36.1
  • spacewalk-java >= 2.8.78.24-3.38.1
  • spacewalk-java-config >= 2.8.78.24-3.38.1
  • spacewalk-java-lib >= 2.8.78.24-3.38.1
  • spacewalk-java-oracle >= 2.8.78.24-3.38.1
  • spacewalk-java-postgresql >= 2.8.78.24-3.38.1
  • spacewalk-setup >= 2.8.7.8-3.19.1
  • spacewalk-taskomatic >= 2.8.78.24-3.38.1
  • spacewalk-utils >= 2.8.18.5-3.9.1
  • susemanager >= 3.2.20-3.31.2
  • susemanager-advanced-topics_en-pdf >= 3.2-11.32.1
  • susemanager-best-practices_en-pdf >= 3.2-11.32.1
  • susemanager-docs_en >= 3.2-11.32.1
  • susemanager-getting-started_en-pdf >= 3.2-11.32.1
  • susemanager-jsp_en >= 3.2-11.32.1
  • susemanager-reference_en-pdf >= 3.2-11.32.1
  • susemanager-schema >= 3.2.21-3.31.1
  • susemanager-sls >= 3.2.27-3.35.1
  • susemanager-tools >= 3.2.20-3.31.2
  • susemanager-web-libs >= 2.8.7.19-3.36.1
  • tika-core >= 1.22-3.9.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2019-2521
SUSE Manager Server Module 4.0
  • cobbler >= 3.0.0+git20190806.32c4bae0-7.3.7
  • cpu-mitigations-formula >= 0.1-4.6.7
  • mgr-osa-dispatcher >= 4.0.10-3.6.8
  • patterns-suma_retail >= 4.0-9.3.8
  • patterns-suma_server >= 4.0-9.3.8
  • pgjdbc-ng >= 0.7.1-3.3.8
  • prometheus-exporters-formula >= 0.4-3.3.7
  • pxe-default-image-sle15 >= 4.0.0-20191106084601
  • py26-compat-salt >= 2016.11.10-10.8.8
  • python3-mgr-osa-common >= 4.0.10-3.6.8
  • python3-mgr-osa-dispatcher >= 4.0.10-3.6.8
  • python3-spacewalk-backend-libs >= 4.0.27-3.13.9
  • python3-spacewalk-certs-tools >= 4.0.12-3.6.8
  • python3-spacewalk-client-tools >= 4.0.10-3.6.8
  • python3-susemanager-retail >= 1.0.1568808472.be9f236-3.6.7
  • python3-urlgrabber >= 3.10.2.1py2_3-6.22.6
  • spacecmd >= 4.0.16-3.6.7
  • spacewalk-admin >= 4.0.8-3.3.8
  • spacewalk-backend >= 4.0.27-3.13.9
  • spacewalk-backend-app >= 4.0.27-3.13.9
  • spacewalk-backend-applet >= 4.0.27-3.13.9
  • spacewalk-backend-config-files >= 4.0.27-3.13.9
  • spacewalk-backend-config-files-common >= 4.0.27-3.13.9
  • spacewalk-backend-config-files-tool >= 4.0.27-3.13.9
  • spacewalk-backend-iss >= 4.0.27-3.13.9
  • spacewalk-backend-iss-export >= 4.0.27-3.13.9
  • spacewalk-backend-package-push-server >= 4.0.27-3.13.9
  • spacewalk-backend-server >= 4.0.27-3.13.9
  • spacewalk-backend-sql >= 4.0.27-3.13.9
  • spacewalk-backend-sql-postgresql >= 4.0.27-3.13.9
  • spacewalk-backend-tools >= 4.0.27-3.13.9
  • spacewalk-backend-xml-export-libs >= 4.0.27-3.13.9
  • spacewalk-backend-xmlrpc >= 4.0.27-3.13.9
  • spacewalk-base >= 4.0.16-3.9.8
  • spacewalk-base-minimal >= 4.0.16-3.9.8
  • spacewalk-base-minimal-config >= 4.0.16-3.9.8
  • spacewalk-branding >= 4.0.14-3.6.8
  • spacewalk-certs-tools >= 4.0.12-3.6.8
  • spacewalk-client-tools >= 4.0.10-3.6.8
  • spacewalk-config >= 4.0.13-3.3.7
  • spacewalk-html >= 4.0.16-3.9.8
  • spacewalk-java >= 4.0.25-3.10.5
  • spacewalk-java-config >= 4.0.25-3.10.5
  • spacewalk-java-lib >= 4.0.25-3.10.5
  • spacewalk-java-postgresql >= 4.0.25-3.10.5
  • spacewalk-setup >= 4.0.11-3.6.7
  • spacewalk-taskomatic >= 4.0.25-3.10.5
  • spacewalk-utils >= 4.0.13-3.6.8
  • susemanager >= 4.0.17-3.6.9
  • susemanager-doc-indexes >= 4.0-10.9.8
  • susemanager-docs_en >= 4.0-10.9.7
  • susemanager-docs_en-pdf >= 4.0-10.9.7
  • susemanager-retail-tools >= 1.0.1568808472.be9f236-3.6.7
  • susemanager-schema >= 4.0.16-3.8.5
  • susemanager-sls >= 4.0.22-3.10.4
  • susemanager-sync-data >= 4.0.13-3.6.7
  • susemanager-tools >= 4.0.17-3.6.9
  • susemanager-web-libs >= 4.0.16-3.9.8
  • tika-core >= 1.22-3.3.7
  • virtual-host-gatherer >= 1.0.19-3.3.8
  • virtual-host-gatherer-Kubernetes >= 1.0.19-3.3.8
  • virtual-host-gatherer-VMware >= 1.0.19-3.3.8
  • virtual-host-gatherer-libcloud >= 1.0.19-3.3.8
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.0-2019-2930


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Manager Server Module 4.2 tika-core Not affected
SUSE Manager Server Module 4.3 tika-core Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Manager Server 3.1 tika-core Unsupported
SUSE Manager Server 3.2 cobbler Released
SUSE Manager Server 3.2 pgjdbc-ng Released
SUSE Manager Server 3.2 py26-compat-salt Released
SUSE Manager Server 3.2 spacecmd Released
SUSE Manager Server 3.2 spacewalk-backend Released
SUSE Manager Server 3.2 spacewalk-branding Released
SUSE Manager Server 3.2 spacewalk-client-tools Released
SUSE Manager Server 3.2 spacewalk-java Released
SUSE Manager Server 3.2 spacewalk-setup Released
SUSE Manager Server 3.2 spacewalk-utils Released
SUSE Manager Server 3.2 spacewalk-web Released
SUSE Manager Server 3.2 susemanager Released
SUSE Manager Server 3.2 susemanager-docs_en Released
SUSE Manager Server 3.2 susemanager-schema Released
SUSE Manager Server 3.2 susemanager-sls Released
SUSE Manager Server 3.2 tika-core Released
SUSE Manager Server Module 4.0 cobbler Released
SUSE Manager Server Module 4.0 cpu-mitigations-formula Released
SUSE Manager Server Module 4.0 mgr-osad Released
SUSE Manager Server Module 4.0 patterns-suse-manager Released
SUSE Manager Server Module 4.0 pgjdbc-ng Released
SUSE Manager Server Module 4.0 prometheus-exporters-formula Released
SUSE Manager Server Module 4.0 pxe-default-image-sle15 Released
SUSE Manager Server Module 4.0 py26-compat-salt Released
SUSE Manager Server Module 4.0 python-susemanager-retail Released
SUSE Manager Server Module 4.0 python-urlgrabber Released
SUSE Manager Server Module 4.0 spacecmd Released
SUSE Manager Server Module 4.0 spacewalk-admin Released
SUSE Manager Server Module 4.0 spacewalk-backend Released
SUSE Manager Server Module 4.0 spacewalk-branding Released
SUSE Manager Server Module 4.0 spacewalk-certs-tools Released
SUSE Manager Server Module 4.0 spacewalk-client-tools Released
SUSE Manager Server Module 4.0 spacewalk-config Released
SUSE Manager Server Module 4.0 spacewalk-java Released
SUSE Manager Server Module 4.0 spacewalk-setup Released
SUSE Manager Server Module 4.0 spacewalk-utils Released
SUSE Manager Server Module 4.0 spacewalk-web Released
SUSE Manager Server Module 4.0 susemanager Released
SUSE Manager Server Module 4.0 susemanager-doc-indexes Released
SUSE Manager Server Module 4.0 susemanager-docs_en Released
SUSE Manager Server Module 4.0 susemanager-schema Released
SUSE Manager Server Module 4.0 susemanager-sls Released
SUSE Manager Server Module 4.0 susemanager-sync-data Released
SUSE Manager Server Module 4.0 tika-core Released
SUSE Manager Server Module 4.0 virtual-host-gatherer Released


SUSE Timeline for this CVE

CVE page created: Fri Aug 2 14:45:30 2019
CVE page last modified: Mon Jan 16 19:37:28 2023