Upstream information

CVE-2018-10916 at MITRE

Description

It has been discovered that lftp up to and including version 4.8.3 does not properly sanitize remote file names, leading to a loss of integrity on the local system when reverse mirroring is used. A remote attacker may trick a user to use reverse mirroring on an attacker controlled FTP server, resulting in the removal of all files in the current working directory of the victim's system.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:M/Au:N/C:N/I:P/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 5.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
SUSE Bugzilla entry: 1103367 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-642
SUSE Linux Enterprise Desktop 12 SP4
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-642
SUSE Linux Enterprise Module for Basesystem 15
  • lftp >= 4.8.3-4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-643
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • lftp >= 4.8.4-3.9
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA lftp
SUSE Linux Enterprise Server 12 SP3
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-642
SUSE Linux Enterprise Server 12 SP4
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-642
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-642
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • lftp >= 4.7.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-642
openSUSE Leap 15.0
  • lftp >= 4.8.3-lp150.3.3.1
  • lftp-debuginfo >= 4.8.3-lp150.3.3.1
  • lftp-debugsource >= 4.8.3-lp150.3.3.1
Patchnames:
openSUSE-2019-1110
openSUSE Leap 42.3
  • lftp >= 4.7.4-2.6.1
  • lftp-debuginfo >= 4.7.4-2.6.1
  • lftp-debugsource >= 4.7.4-2.6.1
Patchnames:
openSUSE-2019-1059


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 lftp Released
SUSE Linux Enterprise Desktop 12 SP4 lftp Released
SUSE Linux Enterprise High Performance Computing 12 lftp Released
SUSE Linux Enterprise Module for Basesystem 15 GA lftp Released
SUSE Linux Enterprise Server 12 SP3 lftp Released
SUSE Linux Enterprise Server 12 SP4 lftp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 lftp Released