Upstream information

CVE-2017-2640 at MITRE

Description

An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1028835 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP3
  • finch >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-branding-upstream >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • libpurple-plugin-sametime >= 2.12.0-1.33
  • libpurple-tcl >= 2.12.0-1.33
  • pidgin >= 2.12.0-1.33
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • finch >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • finch >= 2.6.6-0.30.3.1
  • finch-devel >= 2.6.6-0.30.3.1
  • libpurple >= 2.6.6-0.30.3.1
  • libpurple-devel >= 2.6.6-0.30.3.1
  • libpurple-lang >= 2.6.6-0.30.3.1
  • pidgin >= 2.6.6-0.30.3.1
  • pidgin-devel >= 2.6.6-0.30.3.1
Patchnames:
sdksp4-pidgin-13717
SUSE Linux Enterprise Software Development Kit 12 SP3
  • finch-devel >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-devel >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • pidgin-devel >= 2.12.0-1.33
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libpurple >= 2.13.0-3.35
  • libpurple-branding-upstream >= 2.13.0-3.35
  • libpurple-devel >= 2.13.0-3.35
  • libpurple-lang >= 2.13.0-3.35
  • libpurple-plugin-sametime >= 2.13.0-3.35
  • pidgin >= 2.13.0-3.35
  • pidgin-devel >= 2.13.0-3.35
openSUSE Leap 15.0
  • libpurple >= 2.13.0-lp150.3.1
  • libpurple-lang >= 2.13.0-lp150.3.1
  • libpurple-tcl >= 2.13.0-lp150.3.1
  • pidgin >= 2.13.0-lp150.3.1
Patchnames:
openSUSE Leap 15.0 GA libpurple
openSUSE Leap 42.1
  • finch >= 2.10.11-9.1
  • finch-debuginfo >= 2.10.11-9.1
  • finch-devel >= 2.10.11-9.1
  • libpurple >= 2.10.11-9.1
  • libpurple-branding-upstream >= 2.10.11-9.1
  • libpurple-debuginfo >= 2.10.11-9.1
  • libpurple-devel >= 2.10.11-9.1
  • libpurple-lang >= 2.10.11-9.1
  • libpurple-meanwhile >= 2.10.11-9.1
  • libpurple-meanwhile-debuginfo >= 2.10.11-9.1
  • libpurple-tcl >= 2.10.11-9.1
  • libpurple-tcl-debuginfo >= 2.10.11-9.1
  • pidgin >= 2.10.11-9.1
  • pidgin-debuginfo >= 2.10.11-9.1
  • pidgin-debugsource >= 2.10.11-9.1
  • pidgin-devel >= 2.10.11-9.1
Patchnames:
openSUSE-2017-431
openSUSE Leap 42.2
  • finch >= 2.12.0-8.6.1
  • finch-debuginfo >= 2.12.0-8.6.1
  • finch-devel >= 2.12.0-8.6.1
  • libpurple >= 2.12.0-8.6.1
  • libpurple-branding-openSUSE >= 42.2-3.3.2
  • libpurple-branding-upstream >= 2.12.0-8.6.1
  • libpurple-debuginfo >= 2.12.0-8.6.1
  • libpurple-devel >= 2.12.0-8.6.1
  • libpurple-lang >= 2.12.0-8.6.1
  • libpurple-meanwhile >= 2.10.11-8.3.1
  • libpurple-meanwhile-debuginfo >= 2.10.11-8.3.1
  • libpurple-plugin-sametime >= 2.12.0-8.6.1
  • libpurple-plugin-sametime-debuginfo >= 2.12.0-8.6.1
  • libpurple-tcl >= 2.12.0-8.6.1
  • libpurple-tcl-debuginfo >= 2.12.0-8.6.1
  • pidgin >= 2.12.0-8.6.1
  • pidgin-branding-openSUSE >= 42.2-3.3.2
  • pidgin-debuginfo >= 2.12.0-8.6.1
  • pidgin-debugsource >= 2.12.0-8.6.1
  • pidgin-devel >= 2.12.0-8.6.1
Patchnames:
openSUSE-2017-410
openSUSE-2017-457
openSUSE Leap 42.3
  • libpurple >= 2.12.0-9.1
  • libpurple-lang >= 2.12.0-9.1
  • libpurple-plugin-sametime >= 2.12.0-9.1
  • libpurple-tcl >= 2.12.0-9.1
  • pidgin >= 2.12.0-9.1
Patchnames:
openSUSE Leap 42.3 GA libpurple


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 pidgin Unsupported
SUSE Linux Enterprise Desktop 12 SP2 pidgin Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 pidgin Released
SUSE Linux Enterprise Software Development Kit 12 pidgin Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP1 pidgin Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 pidgin Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 pidgin Not affected
SUSE Linux Enterprise Workstation Extension 12 pidgin Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 pidgin Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 pidgin Already fixed
SUSE Linux Enterprise Workstation Extension 15 SP1 pidgin Not affected