Upstream information

CVE-2017-14798 at MITRE

Description

A race condition in the postgresql init script could be used by attackers able to access the postgresql account to escalate their privileges to root.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.9 6.8
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C AV:L/AC:L/Au:S/C:C/I:C/A:C
Access Vector Local Local
Access Complexity Medium Low
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 7.8
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High Low
Privileges Required Low None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1062722 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • postgresql >= 12-2.2
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • postgresql >= 10-6.8
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • postgresql-contrib >= 12-2.2
  • postgresql-devel >= 12-2.2
  • postgresql-docs >= 12-2.2
  • postgresql-plperl >= 12-2.2
  • postgresql-plpython >= 12-2.2
  • postgresql-pltcl >= 12-2.2
  • postgresql-server >= 12-2.2
  • postgresql-server-devel >= 12-2.2
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • postgresql-contrib >= 10-6.8
  • postgresql-devel >= 10-6.8
  • postgresql-docs >= 10-6.8
  • postgresql-plperl >= 10-6.8
  • postgresql-plpython >= 10-6.8
  • postgresql-pltcl >= 10-6.8
  • postgresql-server >= 10-6.8
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • postgresql-init >= 9.4-0.5.3.1
Patchnames:
slessp4-postgresql-init-13352
openSUSE Leap 15.0
  • postgresql >= 10-lp150.4.4
  • postgresql-server >= 10-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA postgresql


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Point of Service 11 SP3 postgresql-init Released
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql-init Affected
SUSE Linux Enterprise Server 11 SP4 postgresql-init Released
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql-init Released
SUSE Linux Enterprise Server 12 LTSS postgresql-init Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql-init Not affected
SUSE Linux Enterprise Server 12 SP2 postgresql-init Not affected
SUSE Linux Enterprise Server 12 SP3 postgresql-init Not affected