Upstream information

CVE-2013-6418 at MITRE

Description

PyWBEM 0.7 and earlier uses a separate connection to validate X.509 certificates, which allows man-in-the-middle attackers to spoof a peer via an arbitrary certificate.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 856323 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • python-pywbem >= 0.7-6.20.1
Patchnames:
sledsp3-python-pywbem
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • python-pywbem >= 0.7.0-4.7
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Python2 packages 15 SP1
  • python2-pywbem >= 0.11.0-2.21
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • python3-pywbem >= 0.11.0-2.21
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • python-pywbem >= 0.7-6.20.1
Patchnames:
slessp3-python-pywbem
SUSE Linux Enterprise Server 11 SP4
  • python-pywbem >= 0.7-6.22.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • python-pywbem >= 0.7.0-4.3
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • python-pywbem >= 0.7-6.20.1
Builds
SAT Patch Nr: 9079


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications python-pywbem Released
SLES_LTSS-10-SP4 python-pywbem Affected
SUSE Linux Enterprise Desktop 11 SP1 python-pywbem Released
SUSE Linux Enterprise Desktop 11 SP2 python-pywbem Affected
SUSE Linux Enterprise Desktop 11 SP3 python-pywbem Released
SUSE Linux Enterprise Desktop 11 SP4 python-pywbem Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search python-pywbem Released
SUSE Linux Enterprise Server 11 SP1 python-pywbem Released
SUSE Linux Enterprise Server 11 SP1 LTSS python-pywbem Released
SUSE Linux Enterprise Server 11 SP2 python-pywbem Affected
SUSE Linux Enterprise Server 11 SP2 LTSS python-pywbem Released
SUSE Linux Enterprise Server 11 SP2 for VMware python-pywbem Affected
SUSE Linux Enterprise Server 11 SP3 python-pywbem Released
SUSE Linux Enterprise Server 11 SP3 LTSS python-pywbem Released
SUSE Linux Enterprise Server 11 SP3 for VMware python-pywbem Released
SUSE Linux Enterprise Server 11 SP4 python-pywbem Released
SUSE Linux Enterprise Server 11 SP4 LTSS python-pywbem Released
SUSE Linux Enterprise Server for SAP Business All-in-One python-pywbem Released