SUSE Conversations


SUSE Linux Enterprise 11 SDK



By: ssalgy

April 21, 2009 8:53 am

Reads:10142

Comments:6

Rating:2.7

SUSE Linux Enterprise Software Development Kit (SDK) 11 is a comprehensive development tool kit that is designed to support developers, as well as independent hardware vendors (IHVs) and independent software vendors (ISVs), in creating applications on or porting them to SUSE Linux Enterprise 11 products.

SUSE Linux Enterprise Server is a highly reliable, scalable and secure server operating system, built to power both physical and virtual mission-critical workloads.

With this affordable, interoperable and manageable open source foundation, enterprises can cost-effectively deliver core business services, enable secure networks and easily manage their heterogeneous IT resources, maximizing efficiency and value.

Recommended by SAP and Microsoft, SUSE Linux Enterprise Server is optimized to deliver high-performance mission-critical services, as well as run edge of network, and web infrastructure applications. This modular operating system runs on five processor architectures and is available with optional extensions for real-time computing, high availability clustering, and running .NET applications on Linux.

Prerequisites

To use this SDK, you must install either:

* SUSE Linux Enterprise Server 11 or
* SUSE Linux Enterprise Desktop 11

Download the SUSE Linux Enterprise 11 SDK here >

SLE 11 SLES 11 SLED 11

VN:F [1.9.22_1171]
Rating: 2.7/5 (3 votes cast)
SUSE Linux Enterprise 11 SDK, 2.7 out of 5 based on 3 ratings

Tags: ,
Categories: SUSE Linux Enterprise Server, Technical Solutions

Disclaimer: As with everything else at SUSE Conversations, this content is definitely not supported by SUSE (so don't even think of calling Support if you try something and it blows up).  It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test, test, test before you do anything drastic with it.

6 Comments

  1. By:mehoggan

    There are tons of websites that tell you to download the SDK, however, when I try and use Yast2 to install the SDK i keep getting the following error, and I can’t seem to find anything on Google about it.

    There was an error in the repository initialization.
    ‘Repository’: [|] Valid metadata not found at specified URL(s)
    History:
    - Can’t copy /var/adm/mount/AP_0x00000001/media.1/media to /var/cache/zypp/raw/Repositoryfn2GK2
    - Can’t provide /media.1/media : Can’t copy /var/adm/mount/AP_0x00000001/media.1/media to /var/cache/zypp/raw/Repositoryfn2GK2

  2. By:ssalgy

    We checked with the SLES engineers, and they said there are many possible reasons for this error (broken DVD images, using the wrong installation option in YaST, mixing versions, etc.) so it’s impossible to give a general answer. In general the SDK is a normal AddOn and can be installed via YaST’s AddOn module.

    We suggest you open a Service Request with Novell Technical Services for this issue if you have a paid subscription (http://support.novell.com/contact/index.html ), or seek assistance via the Discussion Forums (http://forums.novell.com/) or Support Knowledgebase (http://www.novell.com/support/microsites/microsite.do).

    Hope this helps!

    –Susan

  3. By:junaidnaseer

    Hi,

    Sorry, I am posting this here, but this page turned up upon googling for my problem, so I am posting it here.

    I have downloaded both the ISO files for SDK i.e. SLE-11-SDK-DVD-i586-GM-Media1.iso and SLE-11-SDK-DVD-i586-GM-Media1.iso . The first one is of 2.6 GB size while the 2nd one is of 4.7GB size. Both files downloaded fine, without giving an error and I have mounted them and seen them to work apparently fine. They are placed in /home/junaid/sdk/

    I have an SLES11 SP1 installed on my system,which came with my HP625 with an AMD Athlon II P320 processor.

    Now, when I add the first ISO file using the “software repositories” option in the yast control center, and choose to add it as ISO file, it gives the message that, the file SLE-11-SDK-DVD-i586-GM-Media1.iso is not an ISO file, but when I add it anyway, it accepts it and adds it to the repository list with my given name “sdk1″. I can see the required packages, but they have dependency issue, so I assume then I have to add the 2nd ISO file too.

    Again I start the yast, then scroll down and click “software repositories” and in the new window that appears, I choose to add the downloaded 4.7GB file as an ISO file. Again, the same error appears, that it is not an ISO file and if I choose to add it anyway, then it fails to refresh this repository but adds it into the repository list with a name “SUSE Linux Enterprise Software Development Kit 11″, instead of my given name “sdk2″, so it is probably picking the name from some file inside the ISO file .

    If I try to install something from the SDK now using yast, it gives the error

    File ‘/media.1/media’ not found on medium ‘iso:///?iso=SLE-11-SDK-DVD-i586-GM-Media2.iso&url=file:///home/junaid/sdk/’

    I tried mounting the SDK ISOs in two separate directories in the /mnt folder. And then adding the two directories to the repository list as “local directories”, but this gave the same result !

    I really need to do an assignment for which I need octave, which depends on fortran to be installed, which needs the gcc stuff in the sdk ISOs. I am a newbie at this stuff. So please help me if you can.

    I would install the octave from the rpm package but that gives a different error, that I have no clue about. That error is “Could not find the rpm-Package in Pool”

    I have been looking for a solution for the last one week or for a right place to find the solution. Guess noone faced this error before! If this is not the place for this question, then please guide me where I can get the right answer. Support a new linux convert :P

  4. By:carl0slp

    Is just impossible to install more than half of the -devel packages of the SDK.

    The -devel versions included on the SDK are older than the nondevel ones of the system (SLED11-SP2).

    And what the hell you can’t make this repository available online instead inside a DVD???

    I can’t believe such poor quality in an enterprise distro.

  5. By:spider

    Instead of directory media.1 the disk contains a directory media.2. This seems to make it impossible for yast to install from the disk.

Comment

RSS