Linux iManager Plugin Installer


January 8, 2007 10:06 am





Target Platform: SLES, OES Linux.

Now the iManager plugin installer can install any plugins irrespective of platform on which iManager is running. There has been a problem with iManager 2.5 and 2.6 versions w.r.t installing and uninstalling the plugins on different platforms. Most of the time plugins were not uninstalled completely leaving them in the hanging state and thus preventing reinstalling those plugins. Then the user had to manually install/uninstall the plugins which is a more tedious task since the user has to manually copy the right files at the right location in iManager.

This tool has been written to resolve the above-mentioned problems and to make the job of installing/uninstalling plugins smoother. Even for the first time, this tool makes it easier to install the plugins rather than doing it from iManager. If you have a problem with uninstalling the plugins, then just install the new version of the plugin using this tool. All old files will be replaced with new ones automatically.

How to use this application

 perl <plugin file path>

Example : /plugin/sso.npm
0 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 50 votes, average: 0.00 out of 5 (0 votes, average: 0.00 out of 5)
You need to be a registered member to rate this post.

Categories: Free Tools, Technical Solutions

Disclaimer: As with everything else at SUSE Conversations, this content is definitely not supported by SUSE (so don't even think of calling Support if you try something and it blows up).  It was contributed by a community member and is published "as is." It seems to have worked for at least one person, and might work for you. But please be sure to test, test, test before you do anything drastic with it.