Let’s say you’ve cd to / and chown -R me:users * and you now have a system that has corrupted permissions. Have no fear, the SUSE team is here to the rescue. Simple run this command as root and you’ll be back up and running in no time:

SuSEconfig --module permissions
(Visited 1 times, 1 visits today)
Tags:
Category: openSUSE, SUSE Linux Enterprise Desktop, SUSE Linux Enterprise Server, Technical Solutions
This entry was posted Thursday, 31 July, 2008 at 10:27 am
You can follow any responses to this entry via RSS.

Comments

  • Anonymous says:

    In reference to your post with the subject line : Reset your SLE/openSUSE Linux default file system permissions .

    I cannot see the command to run .. can u please tell me the command that will reset the system with defaults permissions

    as on one of our servers some one has done chmod -R 777 / .and we want the system badly .

  • paulparker says:

    A simple permission allowing we NON Techs to copy and load report files would be helpful…

    SUPPORT asks to send the Support Utilities – Supportconfig
    Script Version: 2.25-82
    Script Date: 2008 12 04

    Tarball reports created when logged in as SU size 1.4 MB

    Nervously logged in as SU and created them 😉

    However when loaded using Siebel eService they shows as 65 (bytes ?? )

    When copy 1.4 MB to my desktop then look find only a 252 byte list of files from my three failed attempts… Yes Security is good 🙂

    However…. how do we load or email or ftp these files SUPPORT asks for them ?

    The software SUPPORT would like to have used, works fine in openSUSE but will not yet work here in SLED 10 sp2 which is one of my problems trying to fix :-O

    .

  • dreamcarrior says:

    How about I screw up my system file permissions and changed ownership of /sbin, /bin, /usr/sbin, /usr/bin, /etc folder to a user instead of root? I cannot su to root, or even use sudo. How can I change the permissions back to default and fix the problem?

  • raheelqaiser says:

    On SuSE 11 SP3 its not working,
    SuSEconfig –module permissions is not working as showing error at the end: “Not all operations were successful”

    As showing here: http://imgur.com/3limiRY

    Please suggest what to do?

  • Leave a Reply

    Your email address will not be published. Required fields are marked *